О движке

Общая информация по движку

Навигация: Общая информация >

Общая информация по движку

DataLife Engine v.18.1 - это многопользовательский новостной движок, обладающий большими функциональными возможностями. Движок предназначен, в первую очередь, для создания новостных блогов и сайтов с большим информационным контекстом. Однако он имеет большое количество настроек, которые позволяют использовать его практически для любых целей. Движок может быть интегрирован практически в любой существующий дизайн и не имеет никаких ограничений по созданию шаблонов для него. Еще одной ключевой особенностью DataLife Engine - является низкая нагрузка на системные ресурсы. Даже при очень большой аудитории сайта нагрузка на сервер будет минимальной и вы не будете испытывать каких-либо проблем с отображением информации. Движок оптимизирован под поисковые системы, что приведет на ваш сайт дополнительных клиентов. Использование продвинутой технологии AJAX позволит вам сэкономить вам ваш трафик и трафик посетителей, а также снижает нагрузку на сервер.


Общие Возможности

Навигация: Общая информация >

Общие Возможности

DataLife Engine обладает следующими возможностями:

Общие возможности:

·Использует для хранения данных MySQL

·Минимальная нагрузка на базу данных

·Использование продвинутой технологии AJAX

·Вывод новостей, статей, да и вообще всего что угодно

·Поддержка ЧПУ (человеко-понятный URL) позволяет использовать тему статьи или любой другой текст в URL браузера, благодаря этому индексация сайта в поисковых системах будет более качественной (необходим modrewrite)

·Возможность отключения ЧПУ

·Общая статистика сайта

·Поддержка дополнительных полей (возможность использовать не только краткую и полную новость на сайте, но и имеется возможность для создания любого количества дополнительных полей различных видов для ввода информации)

·Возможность написания статей, содержащих несколько страниц

·Флуд контроль

·Автоматический фильтр слов в комментариях

·Поддержка категорий

·Возможность установки любого количества вложенных категорий

·Каждой категории можно назначить отдельный шаблон

·Автоматическое обрезание длинных слов в комментариях

·Рейтинг новостей

·Календарь

·Поиск по статьям включая дополнительные поля (подсветка найденного текста)

·Обзор непрочитанных новостей с момента последнего посещения сайта

·Возможность просмотра сколько раз была прочитана новость

·Возможность добавления статей в раздел "Избранное"

·Отсылка писем пользователям через форму на сайте

·Вывод страницы используя сжатие gzip

·Поддержка персональных сообщений между пользователями

·Поддержка нескольких языков

·Вывод популярных статей в отдельном блоке

·Возможность создания статистический страниц непосредственно через админпанель

·Возможность выбора между упрощенной регистрацией и расширенной, при выборе расширенной регистрации пользователь будет зарегистрирован только после активации аккаунта. Активация высылается по почте.

·Возможность загрузки и прикрепления файлов к новостям

·Встроенные средства защиты от несанкционированного скачивания файлов (antileech)

·RSS Импорт новостей

·RSS Информеры

·Мультиязычная поддержка новостей на сайте

·Поддержка Облака Тегов

·Автоматическая поддержка смартфонов

Возможности для посетителей сайта:

·Регистрация на сайте

·Добавление комментариев

·Изменение и удаление пользователями своих собственных комментариев

·Возможность добавления новостей со стороны посетителей

·Модерирование новостей

·Статистика по конкретному пользователю (включая рейтинг и профиль)

·Вывод различной информации для зарегистрированных посетителей и нет

·Возможность загрузки фотографии в профиле пользователя

·Возможность восстановления забытого пароля

·Возможность редактирования новости непосредственно на сайте

·Смена скинов на сайте по своему усмотрению

·Ведение закладок для новостей, и быстрый доступ к ним.

·Массовая загрузка картинок на сервер

·Просмотр и добавление видео на сайт

·Персонализация вывода рекламы для определенных групп

·Возможность загрузки большого количества картинок и файлов в один клик

·Система жалоб "в один клик", на ошибки, новости, комментарии, персональные сообщения

Возможности админцентра:

·Добавление, редактирование и удаление новостей

·Полностью настраиваемая админпанель для различных групп пользователей

·Возможность использования двух редакторов (BBCODES или WYSIWYG)

·Антивирус проверяющий состояние файлов на предмет возможного взлома

·Редактирование пользователей

·Имеется возможность использовать смайлы и HTML код

·Неограниченное создание групп пользователей с тонкой настройкой различных прав доступа

·Возможность выставления бана для посетителей

·Средства для создания и редактирования шаблонов непосредственно в админцентре

·Возможность корректировки времени

·Возможность изменения даты публикации

·Автоматическая публикация статьи при наступлении установленного времени

·Возможность отключения календаря и архивов (для экономии ресурсов)

·Возможность фиксации новостей (будут всегда наверху, независимо от даты)

·Отключение регистрации посетителей

·Автоматическая временная приостановка регистрации при достижении максимального количества зарегистрированных пользователей

·Автоматическое уменьшение загруженных картинок с сохранением пропорций до указанных размеров

·Автоматическое удаление пользователей которые не посещали сайт заданное время

·Наложение водяных знаков на картинки

·Возможность загрузки картинок для каждой конкретной новости (при удалении новости, картинки тоже будут удаляться)

·Удобный менеджер загруженных картинок

·Оптимизацию, ремонт, создание резервной копии и восстановление базы данных можно осуществлять непосредственно из скрипта

·Поиск пользователей по IP адресам

·Удобное управление рекламными материалами.

·Быстрый поиск и замена в базе данных

·Публикация "правил" на сайте

·Создание карты сайта для Google

·Создание фильтров для автоподстановки слов и значений

И много других полезных функций...


Список изменений

Навигация: Общая информация >

Список изменений

Список изменений в версии 18.1:

qДобавлена поддержка авторизации в социальной сети Вконтакте с использованием нового протокола VK ID Oauth 2.1. Тем самым добавлена поддержка новых создаваемых приложений в данной сети. Поддержка старых приложений также продолжит работать, без каких-либо дополнительных изменений в автоматическом режиме.

qВ настройки скрипта в админпанели добавлена возможность указать группы пользователей, к которым не применять блокировку по странам. В случае, если Вы запретили просмотр сайта для некоторых стран, Вы можете назначить группы пользователей, которые могут находится в данных странах, и при этом видеть сайт, блокировка к ним не будет применяться.

qДобавлена возможность использования параметра max_completion_tokens для ИИ ассистентов в настройках скрипта в панели управления. А также добавлена возможность отключения параметров max_tokens и temperature в случае отсутствия необходимости их использования. Тем самым добавлена поддержка новых рассуждающих языковых моделей, например o1 и o3-mini и так далее.

qДобавлен полностью новый редактор исходного кода с подсветкой при написании публикаций вместо использовавшегося ранее CodeMirror. Главным и основным преимуществом нового редактора является его скорость работы при рендеринге подсветки на больших объёмах контента. Там, где CodeMirror очень долго рендерит код для подсветки кода или вообще зависает, новый редактор работает практически мгновенно. Особенно актуально это будет для работы с большими публикациями, или с публикациями, где используется очень много различного HTML форматирования. Помимо всего прочего в новом редакторе более продвинутый поиск, добавлены новые функции автозаполнения при написании, которые могут автоматически дописывать как теги и параметры тегов, так и просто уже имеющиеся слова в тексте публикаций. В случае если в коде допускается ошибка в HTML вёрстке данная строка подсвечивается с указанием допущенной ошибки. Также добавлена автоматическая прокрутка к месту, где находится курсор при переходе в редактор исходного кода и автоматическая прокрутка к месту, где находится курсор из в редактора исходного кода обратно в визуальный редактор.

qНовый редактор исходного кода получили также модули редактирования шаблонов, рекламных материалов и плагинов. Теперь при больших объёмах редактируемого контента, их правка происходит удобнее и быстрее. А также появились дополнительные возможности по автоматическому дополнению кода в зависимости от используемого языка ( HTML, CSS, JS, PHP, SQL) и просто текста.

qПри выводе цитат пользователей в комментариях и персональных сообщениях добавлен вывод автора цитаты в виде ссылки на карточку профиля пользователя. Тем самым в цитатах вы можете быстро перейти в профиль пользователя, отправить ему персональное сообщение, или администраторы могут быстро выполнить действия с профилем пользователя.

qДля цитат в комментариях пользователей на сайте также добавлен вывод быстрой ссылки на полный просмотр цитируемого сообщения. Посетители могут при нажатии на ссылку в цитате быстро переместиться на страницу и место на странице, где находится данный комментарий.

qПолностью переписан алгоритм поиска ключевых слов по тексту в модуле "Перекрестные ссылки". Алгоритмы замены также работают по принципу "на лету", с возможностью управлять ими в режиме реального времени, однако больше не используются регулярные выражения для замены и сокращены точки обработки контента, что позволило существенно, в несколько сотен раз, ускорить работу данной возможности DataLife Engine и снизить нагрузку на сервер при большом объёме заданных ключевых слов и ссылок.

qПереработан модуль обработки вывода похожих публикаций при просмотре полных новостей. Теперь поиск похожих новостей производится непосредственно при добавлении или редактировании публикаций, а не при первом просмотре публикации. Добавлена поддержка дополнительных полей при поиске похожих публикаций, тем самым поиск будет лучше если не используются поля краткого и полного описания. Улучшена работа с кешем данного блока на сайте при которой, обработка блока будет происходить только если у публикации есть похожие новости, тем самым в ряде случаев снижается нагрузка на сайт. Также обработка блока будет происходить только при наличии соответствующих тегов вывода похожих новостей в шаблоне, тем самым в случае вывода похожих новостей с использованием других тегов, например {cusom ….} не будет производится запросов к базе данных, и не будет нагрузки для формирования данного блока.

qДобавлена возможность в разделе перестроения публикаций указывать количество публикаций и комментариев, которое необходимо обработать за один проход. Тем самым вы можете увеличить или уменьшить количество обрабатываемых данных за один раз и увеличить скорость обработки, или наоборот снизить нагрузку на сервер. Также в ряде случаев это позволяет не превышать лимиты сервера при обработке, если требуется соединения к внешним сервисам и это занимаем время, например, при обработке тегов [mediа=…] и т.д.

qВ случае включения при редактировании публикаций уведомлений пользователей, о том, что публикация уже редактируется другим пользователем, добавлен вывод уведомлений и при редактировании публикаций на сайте. А также добавлен учёт редактирования публикации непосредственно на сайте в пользовательской части. Тем самым, независимо от того, где начато редактирование на сайте или в панели управления, пользователи будут получать уведомления также везде и на сайте, и в панели управления. Если пользователи не имеют доступа к панели управления сайтом, они также будут получать все необходимые уведомления о том, что публикация находится в стадии редактирования другим пользователем.

qДля шаблонов персональных сообщений (pm.tpl) добавлена поддержка новых тегов: [pm-author] текст [/pm-author] которые выводят текст заключённый в них в случае, если пользователь, просматривающий переписку, является автором этого сообщения, а также теги [not-pm-author] текст [/not-pm-author] которые выводят текст, в случае если пользователь не является автором данного сообщения. Тем самым вы можете выделять для пользователей собственные сообщения и сообщения собеседников.

qДобавлена возможность удаления публикаций на сайте для пользователей, которым разрешено публиковать без модерации, редактировать свои публикации, но при этом отключён доступ к панели управления DataLife Engine. Тем самым данные пользователи смогут удалить свои публикации непосредственно на сайте.

qДля шаблонов вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) добавлена поддержка новых тегов [del] текст [/del] которые выводят ссылку на удаление публикации с сайта для пользователей, которым разрешено удаление данной публикации. Тем самым вы можете добавить возможность удалить пользователям публикацию, без предоставления возможности редактирования публикации.

qДобавлена возможность отправки персонального сообщения пользователю непосредственно в панели управления DataLife Engine в разделе управления пользователями, без необходимости перехода на сайт для отправки сообщения. Сообщение отправляется в всплывающем окне с использованием технологии AJAX без перезагрузки страницы сайта.

qДля предосмотра загруженных изображений в менеджере загрузок DataLife Engine добавлена поддержка HiDPI изображений. В случае если загруженное изображение является изображением высокой чёткости, то в предосмотре также будет использовано изображение высокой чёткости.

qВ разделе управления пользователями в админпанели добавлена возможность быстрого перехода к списку пользователей из любого подраздела этого раздела через меню хлебных крошек. А также после редактирования профиля, Вы можете на выбор либо продолжить редактирование, либо перейти к списку пользователей.

qПри просмотре всех последних комментариев на сайте был убран показ комментариев, добавленных к публикациям, которые в данный момент находятся на модерации. Тем самым пользователи видят комментарии только к действующим и опубликованным новостям на сайте.

qПереработана и улучшена система работы в разделе управления пользователями в панели управления. В случае, если задаются какие-либо параметры поиска пользователей, после выполнения каких-либо действий в данном разделе, при нажатии на кнопку возврата, вы возвращаетесь именно на ту страницу, где и были до начала выполнения этих действий, и с теми же параметрами поиска, которые вы указывали ранее. Тем самым работа в панели управления в данном разделе стала более удобной и быстрой.

qУлучшена и переработана вставка блоков с информацией, предупреждением или ошибками в редакторе, а также других блоков с форматированием. Теперь доступно удаление блоков в один клик при их выборе, а также вы можете перемешать их по тексту выбрав блок.

qДля редактора при добавлении и редактировании комментариев и персональных сообщений добавлена кнопка для быстрого удаления кликабельной ссылки в случае для них разрешено использование ссылок.

qДобавлена поддержка и использование дополнительных полей при автоматическом формировании метатегов описания и ключевых слов. Тем самым, если на сайте не используются поля краткого и полного описания, то метатеги будут автоматически формироваться только из дополнительных полей.

qДобавлена поддержка вложенности друг в друга для глобальных шаблонных тегов [country=X] Текст [/country]. Тем самым вы можете вкладывать блоки друг в друга в шаблоне, сначала определив общий блок, и внутри разделив его по странам. Например, вы можете использовать конструкции вида: [country=RU,BY,DE] Контент для трех стран [country=BY]Только для Беларуси[/country][country=RU]Только для России[/country] продолжение общего блока [/country]. Тем самым упрощается вёрстка сложных конструкций шаблонов. Аналогичная поддержка вложенности добавлена и для обратных тегов [not-country=X] … [/not-country].

qДобавлена поддержка вложенности друг в друга для глобальных шаблонных тегов [tags=X] Текст [/tags]. Тем самым вы можете вкладывать блоки друг в друга в шаблоне, сначала определив общий блок, и внутри разделив его по тегам. Например, вы можете использовать конструкции вида: [tags=test1,test2] Общая шапка блока [tags=test1] только тег test1 [/tags][tags=test2]только тег test2[/tags] продолжение общего блока [/tags]. Тем самым упрощается вёрстка сложных конструкций шаблонов. Аналогичная поддержка вложенности добавлена и для обратных тегов [not-tags=X] … [/not-tags].

qДобавлена поддержка вложенности друг в друга для глобальных шаблонных тегов [news=X] Текст [/news]. Тем самым вы можете вкладывать блоки друг в друга в шаблоне, сначала определив общий блок, и внутри разделив его по новостям. Например, вы можете использовать конструкции вида: [news=1,2] Общая шапка блока [news=1] только новость 1 [/news][news=2] только новость 2 [/news] продолжение общего блока [/news]. Тем самым упрощается вёрстка сложных конструкций шаблонов. Аналогичная поддержка вложенности добавлена и для обратных тегов [not-news=X] … [/not-news].

qДля общего шаблона (main.tpl) добавлена поддержка новых тегов [changeskin] текст [/changeskin] которые выводят текст заключённый в них в случае, если пользователям разрешена смена тем оформления сайта. Тем самым вы можете автоматически включать и отключать отдельные блоки в шаблоне, которые предназначены для вывода оформления смены шаблонов на сайте.

qАдаптирован редактор шаблонов в админпанели под различное масштабирование текста, установленное в настройках оформления панели управления.

qВ связи с тем что Яндекс прекратил поддержку технологии Яндекс Турбо https://webmaster.yandex.ru/blog/yandex-stops-supporting-turbo-technology данная технология была также полностью убрана из DataLife Engine.

qУлучшены алгоритмы копирования и вставки контента в редакторе для публикаций.

qПроведены многочисленные дополнительные оптимизации в обработке шаблонных DLE, направленные на ускорение работы обработки тегов, а также снижение расхода памяти.

qДля дополнительных полей с типом "Чистый HTML или JS код" также как и для остальных полей добавлена автоматическая регулировка их высоты при добавлении публикаций в админпанели. Также добавлена автоматическая регулировка высоты для текстовых полей при добавлении публикаций на сайте и при быстром редактировании публикаций на сайте. Что делает добавление и редактирование публикаций ещё более удобным.

qДобавлена возможность использовать апострофы и кавычки в названиях места жительства и полных именах пользователей.

qДобавлена возможность использовать значение "0" в дополнительных полях публикаций с типом "Список". Ранее при использовании таких значений, поле считалось пустым и значение не сохранялось при повторном редактировании публикации.

qДобавлен форматированный вывод количества скачиваний, загруженных через DataLife Engine файлов. Теперь количество скачиваний будет выводится в формате например: 23 532 234, вместо слитного числа 23532234, что существенно улучшает восприятия числа скачиваний пользователем.

qВнесены изменения в отображение редактора на сайте при использовании темной темы, исправлены некоторые ошибки, связанные с его некорректным отображением в темных темах.

qУведомления пользователя о получении новых персональных сообщений с момента отсутствия на сайте переведены на использование более компактных DLEPush уведомлений, что позволяет пользователю не отвлекаться на них сразу после посещения сайта, при этом иметь необходимую информацию об этом. Также снижен расход ресурсов сервера при уведомлениях пользователя, за счёт сокращения обращений к базе данных.

qУбрана зависимость загрузки необходимых библиотек для работы с ИИ от внешних сервисов. Теперь все необходимые библиотеки располагаются непосредственно на вашем сервере.

qДля комментариев и персональных сообщений добавлена поддержка тегов проверки дополнительных полей([xfgiven_x] текст [/xfgiven_x], [xfnotgiven_x] текст [/xfnotgiven_x], отдельно и независимо от использования в шаблоне тега непосредственно вывода дополнительного поля. То есть данные теги могут использоваться в шаблоне без использования тега [xfvalue_X] в данном шаблоне.

qУлучшена система копирования и вставки контента в редакторе для публикаций. Добавлено сохранение классов CSS, который использует DataLife Engine при формировании своего контента. Например, при копировании через редактор из одного поля в другое цитат, уменьшенных копий изображений и прочего, их оформление будет сохранено.

qОптимизирован ряд запросов к базе данных MySQL, для более быстрой работы сайта и снижения нагрузки на сервер.

qУлучшена система вставки цитат на основе выделенного текста в редакторе для публикаций и комментариев.

qДобавлено автоматическое удаление устаревших и не используемых больше файлов DataLife Engine при обновлении на новые версии. Автоматическое удаление происходит в случае, если у DataLife Engine есть права доступа на удаление этих файлов.

qИсправлена проблема, при которой в случае осуществления поиска по настройкам отображались скрытые поля, которые не должны отображаться, так как были отключены другими переключателями и настройками.

qИсправлена проблема, при которой могла происходить некорректная замена ключевых слов из модуля перекрёстных ссылок в микроразметке структурированных данных schema.org в случаях если этим ссылкам назначена глобальная замена по всей странице.

qИсправлена проблема, при которой происходила не валидная вёрстка HTML при выводе опроса на сайте.

qИсправлена проблема, при которой не работала вставка текста при редактировании комментариев в панели управления.

qИсправлена проблема, при которой некорректно выводились имена категорий при добавлении или редактировании публикаций, в случае если они содержали символы кавычек или амперсанд.

qИсправлена проблема, при регистрации пользователей с использованием функций API.

qИсправлена проблема, при которой не работали теги [xfnotgiven_x] текст [/xfnotgiven_x] в шаблоне вывода персональных сообщений.

qИсправлена проблема, при которой в некоторых случаях могли происходить MySQL ошибки про поиске похожих новостей.

qИсправлена проблема, при которой шаблонные теги [add-favorites] … [/add-favorites] и [del-favorites] … [/del-favorite] не учитывали имена шаблонов которые назначены в настройках категорий, а использовали только стандартные имена шаблонов.

qИсправлена проблема, при которой не работало ограничение на вывод в различных категориях для рекламных материалов, установленное в настройках баннера в панели управления, при просмотре полных публикаций.

Список изменений в версии 18.0:

qДобавлена полностью новая система личных переписок на сайте. Вся система персональных сообщений на сайте была полностью переписана. И теперь представляет из себя не только отправку одного личного сообщения и возможность лишь ответа также в виде отдельного сообщения с цитатой, а является полноценной перепиской между пользователями, где пользователи видят все cdjt сообщения в одной объединенной цепочке, а сама переписка ведётся в форме чата. При получении сообщения, пользователи могут многократно отвечать и слать друг другу сообщения в одной теме. При этом пользователи могут в любой момент покидать переписку, если считают ее законченной или хотят иметь порядок в своих персональных сообщениях, но если при этом другой участник пошлёт новое сообщение в эту же переписку, то вся переписка будет автоматически восстановлена у участника покинувшего его, и он опять может увидеть всю переписку и понять ее суть. Также пользователям теперь доступно редактирование сообщений в переписке, если другой участник его ещё не прочитал. Сообщения также можно удалять из переписки при необходимости. Сообщения можно цитировать, как полностью, так и частично, добавлен улучшенный вывод дат сообщений, и то последний ответил в переписке при выводе списка сообщений и многое многое другое. Эта система теперь полностью новая, написана с нуля, и добавлена для более удобного общения посетителей сайта между собой.

qДобавлена поддержка и использование искусственного интеллекта при создании и редактировании публикаций. Искусственный интеллект поможет вам быстро создать необходимый текст или переписать или изменить стиль написания текста, или сделать перевод и многое другое по вашему желанию. Поддерживается использование искусственного интеллекта на основе API ChatGPT. При этом в настройках вы можете указать точку входа для общения с ChatGPT, тем самым вы можете использовать не только напрямую ChatGPT от OpenAI, но и любой сервис, который поддерживает данный API. Например, пользователи из России, где прямое использование ChatGPT запрещено, могут использовать сервис от https://proxyapi.ru для получения доступа к ChatGPT. Помимо всего прочего вы можете в настройках гибко настроить как необходимо использовать ChatGPT, какую языковую модель необходимо задействовать, каким группам пользователей разрешено использовать искусственный интеллект, стиль ответа, максимальные лимиты и ограничения на длину ответа.

qДобавлена возможность задавать категориям одинаковые имена для URL, в случае если они находятся в разных родительских категориях. Например, вы можете создать структуру категорий "games/rpg/news/", "games/shooters/news/" и так далее. А также проведена оптимизация алгоритмов формирования различных ссылок на сайте, где участвуют категории, тем самым было существенно улучшено быстродействие, и снижен расход ресурсов сервера при большом количестве категорий.

qВ панели управления DataLife Engine в разделе “Анализ производительности” добавлена возможность сразу отключать ту или иную возможность скрипта для снижения нагрузки и увеличения быстродействия. Теперь вам не нужно для отключения той или иной функции переходить в настройки скрипта и искать данные настройки, Вы можете отключить ее, непосредственно нажав на соответствующую кнопку у нужной настройки. Отключение происходит сразу с использованием технологии AJAX.

qДля пользовательского вывода публикаций с использованием тега {custom ….} добавлена поддержка нового параметра unique="yes", который указывает что публикации в этом блоке не должны повторятся если они уже выводились на сайте, т.е. в данном блоке нужно выводить уникальные публикации. Это позволить избегать в блоках пользовательского вывода публикаций повторения одних и тех же новостей, если они подпадают под одни и те же критерии вывода. Например теги два тега {custom category="1" unique="yes" limit="1"} и {custom category="1" unique="yes" limit="1"} выведут разные публикации, несмотря на одни и те же параметры, первый тег выведет первую новость из категории, а второй уже вторую, пропустив первую. Также если публикация выводилась в блоке {content} она также не будет выводится при наличии данной опции в теге {custom ….}.

qДобавлена более расширенная поддержка различных иконок для загруженных файлов в менеджере загрузок, что позволяет более легко идентифицировать различные документы, а также добавлен вывод расширения файла.

qДобавлена возможность скачивать загруженные к публикациям файлы непосредственно в менеджере загрузок, при добавлении и редактировании публикаций.

qДобавлена поддержка форматов OGG, FLAC, AAC для загрузки и воспроизведения музыки и музыкальных плейлистов с помощью плеера DLE.

qДля функций ограничений доступа к сайту по странам, добавлена поддержка IPv6 адресов. А также был изменён используемый провайдер баз данных для определения страны посетителя на использование баз от IP2location.Что привело к тому, что база данных стала намного точнее и обширнее.

qВ настройки скрипта в админпанели добавлена возможность включения определения страны посетителя на основе данных от сервиса Cloudflare в случае, если ваш сайт подключён и проксируется через данный сервис. В данном случае снижается нагрузка на сервер, т.к. DataLife Engine не придётся самостоятельно искать его в локальной базе данных. В случае если данных о стране нет, то будет произведён автоматический поиск по локальной базе данных.

qВ настройки скрипта в админпанели добавлена возможность разрешать или запрещать доступ к сайту для ботов в случае запрета просмотра сайта для определённых стран, в случае если бот находится в запрещённой стране. Например, в случае запрета доступа к сайту для определённых стран, вы можете разрешить при этом индексацию сайта поисковым системам, если они находятся в данной стране.

qВ настройки скрипта в админпанели добавлена возможность включения препятствования обхода блокировки стран с использованием VPN. В случае если пользователь находится в запрещённой стране и зашёл на сайт, он будет заблокирован, и если он попытается войти на сайт повторно с использованием VPN из разрешённой страны, то он также будет определён и заблокирован на сайте.

qДля описаний настроек разрешения и запрещения доступа к сайту по странам, добавлен вывод страны, в которой в данный момент находится пользователь, так как это определил DLE. Чтобы администратор сайта визуально видел, что все работает корректно и его страна определилась так как необходимо и он случайно не заблокировал сам себя.

qПри добавлении и редактировании публикаций в панели управления, добавлена возможность во вкладке "Доступ" задавать список стран, в которых разрешён показ данной публикации. А также добавлена возможность указывать список запрещённых стран для просмотра публикации. Тем самым вы можете легко настроить в каких странах могут просматривать полную новость, а в каких нет.

qДля рекламных материалов, добавляемых в панели управления DataLife Engine добавлена возможность задавать список стран, в которых разрешён показ данных рекламных баннеров и материалов. А также добавлена возможность указывать список запрещённых для просмотра стран. Тем самым вы можете легко настроить в каких странах показывать этот код, а в каких нет. Тем самым таргетируя показ по странам.

qДобавлено автоматическое сохранение состояния выставленных параметров при загрузке изображений и файлов на сервер в менеджере загрузок DataLife Engine, которые в дальнейшем при повторном открытии окна менеджера будут восстановлены. Например, вы поставили не накладывать водяные знаки, изменили размеры уменьшенной копии, изменили хранилище, и по каким то причинам покинули страницу или перешли в другую публикацию, то все это будет сохранено в локальном хранилище браузера и если вы повторно открываете менеджер загрузок, то все ваши выставленные параметры будут восстановлены, а не выставлены по умолчанию. Тем самым вам не нужно каждый раз выставлять параметры повторно.

qВ настройки скрипта в панели управления добавлена возможность указать группы пользователей, пользователи из которых будут выводится по умолчанию в форме обратной связи на сайте, в случае если письмо не отправляется конкретному пользователю. Ранее там выводились только пользователи из группы Администраторы, и Главные редакторы. Теперь вы можете назначить свои группы пользователей по умолчанию.

qДля RSS импорта публикаций на сайт добавлена возможность указывать в настройках потока, необходимо ли добавлять ссылку на источник, откуда получена новость или нет. Вы можете включить добавление источника в краткое или полное описание, или сразу с оба поля. Либо можете отключить добавление источника при импорте публикаций на сайт.

qБыли убраны редакторы BBCODES и Floara. Данные редакторы глобально и морально устарели, их поддержка была ранее давно полностью прекращена. Никаких новых функций в них не добавлялось. Да мы знаем, что удаление данных редакторов не самая популярная мера и пользователи нас просили не удалять эти редакторы. Но сохранение не поддерживаемых редакторов не может сохраняться бесконечно, данные редакторы существенно затрудняли развитие скрипта в целом, так как генерация разного кода, требует дополнительных проверок и фильтраций текста, выполнение большого количества излишнего кода при обработке публикаций. Поэтому было принято решение полностью отказаться от данных редакторов, что позволило существенно облегчить код и ускорить его обработку при добавлении публикаций, а также сократить время на тестирование кода. А также позволило направить силы и ресурсы на добавление новых функций и возможностей. Теперь для публикаций используется единый редактор TinyMCE, а обработка публикаций при их добавлении и редактировании существенно ускорилась и было снижено потребление ресурсов сервера. Для комментариев также осталась возможность полностью отключить редактор, для сайтов, которые не хотят никакого форматирования контента в комментариях и предпочитают только короткий чистый текст.

qПри добавлении и редактировании публикаций в админпанели и сайте визуальный редактор был изменён таким образом, что по умолчанию он содержит одну панель с наиболее часто используемыми при создании контента кнопками. А при необходимости полного набора кнопок пользователь может развернуть панель во время использования редактора. При этом для каждого поля выбранное свёрнутое или развёрнутое состояние редактора автоматически сохраняется и после повторной загрузки страницы будет таким, каким оно для этого поля было выставлено. Тем самым по умолчанию редактор занимает меньше места, отдавая больше места под редактируемых контент, а для каждого поля в отдельности вы можете выбрать и сохранить состояние редактора.

qВнесены изменения в режим включения и отключения адаптированного режима редактора для мобильных телефонов в комментариях на сайте. Теперь не требуется отдельно включать или отключать его в настройках скрипта в панели управления. Теперь он будет автоматически включаться при использовании посетителем мобильных устройств.

qДля настроек выбора оформления панели управления DataLife Engine добавлена возможность выбрать оформление редактора. Каждый пользователь админпанели сам для себя может выбрать либо классический вид редактора, либо облегчённый. Облегчённый вид представляет собой максимально не нагруженный интерфейс редактора, который позволяет концентрировать взгляд пользователя непосредственно на контент, который он пишет. Также пользователь может включить автоматическую высоту редактора, когда высота будет автоматически занимать столько места, на экране, сколько занимает контент в поле. Тем самым небольшой контент, будет занимать немного места на экране, а больший контент позволяет отображает большую редактируемую область.

qДобавлена поддержка адаптированного для мобильных устройств редактора при написании персональных сообщений на сайте.

qДобавлена поддержка темных тем для редактора при написании персональных сообщений с использованием AJAX на сайте.

qПри вставке текста в редактор улучшена очистка вставляемого кода текста от "мусорного кода" во вставляемом тексте.

qПри быстром редактировании публикаций, добавлена поддержка вставки текста из буфера обмена браузера с сохранением HTML тегов.

qПри выставлении бана пользователю в разделе управления пользователями в админпанели, добавлено сохранение аккаунта администратора, который данный бан выставил. Тем самым другие администраторы могут сразу и легко увидеть в панели управления пользователем, кто именно выставил ему блокировку. Что ускоряет решение каких-либо спорных моментов при наличии на сайте большого количества модераторов и администраторов.

qДля шаблона вывода информации о том, что аккаунт или доступ заблокирован (banned.tpl) добавлена поддержка новых тегов: [banned-from] текст [/banned-from] которые выводят текст заключённый в них в случае, если блокировка была выдана человеком, а не например автоматическая по стране. А также добавлен новый тег: {banned-from} который выводит логин администратора, который выдал пользователю блокировку. Тем самым заблокированные пользователи могут сразу видеть кто и за что им выдал блокировку на сайте.

qДля глобального шаблонного тега {catmenu …} предназначенного для вывода списка категорий, добавлена поддержка нового параметра idexclude="1,2,3-5" в котором вы можете указать ID категорий или диапазон категорий, которые не нужно включать в список категорий, и будут выведены все категории кроме указанных.

qВ настройки групп пользователей добавлена возможность ограничивать пользователей в количестве выставления новостям негативного рейтинга и дизлайков для публикаций. Вы можете указать максимальное число негативных рейтингов, которые может выставить пользователь новостям за сутки. Например, установив два, пользователь сможет поставить в течении суток только две негативные оценки. Количество позитивных оценок не ограничивается. Тем самым вы можете защитить сайт от какого-либо негативного посетителя, который массово ставит негативный рейтинг всему подряд.

qВ настройки групп пользователей добавлена возможность ограничивать пользователей в количестве выставления комментариям негативного рейтинга и дизлайков. Вы можете указать максимальное число негативных рейтингов, которые может выставить пользователь комментариям за сутки. Например, установив два, пользователь сможет поставить в течении суток только две негативные оценки комментариям. Количество позитивных оценок при этом не ограничивается. Тем самым вы можете защитить сайт от какого-либо негативного посетителя, который массово ставит негативный рейтинг всему подряд.

qДля шаблона вывода комментариев (commets.tpl) добавлена поддержка новых тегов [replycount] текст [/replycount] которые выводят текст заключённый в них, если комментарий имеет ответы на него от других пользователей, а также добавлены противоположные теги [not-replycount] текст [/not-replycount] которые выводят текст заключённых в них если ответов на комментарий нет. Тем самым вы можете сделать более гибкое оформление информации об ответах на комментарии.

qУлучшено и оптимизировано отображение редактора для публикаций на мобильных устройствах в панели управления DataLife Engine.

qУлучшено и оптимизировано отображение редактора при быстром редактировании публикаций на сайте. Редактор получил динамическую высоту в зависимости количества контента в полях. И в случае, если в поле написано немного информации, то редактор будет занимать столько места, сколько занимает контент. Что облегчает редактирование информации при большом количестве полей.

qПри выводе группы пользователя в комментариях на сайте, в случае если он был забанен, добавлен вывод информации что данный пользователь забанен, также как и при выводе группы в его профиле.

qПри выводе информации на сайте, является ли пользователь онлайн или нет, добавлена проверка является ли он также забаненным на сайте ранее. И в случае, если забанен, то его статус всегда будет оффлайн, даже если он пытался успешно авторизоваться на сайте.

qПереработан и улучшен предосмотр сообщений при массовой рассылке писем в панели управления. Было улучшено оформление, шрифты, а также добавлена полная поддержка настроек оформления панели, которое пользователь делает персонально для себя. Также добавлена полная поддержка визуального оформления панели управления и для окна отправки сообщений.

qДобавлена возможность использования двойных кавычек для ключевых слов, которые необходимо находить и заменять в разделе управления перекрёстными ссылками по сайту.

qДобавлена возможность вставлять live трансляции с сервиса YouTube на свой сайт при помощи тегов [mediа=…..]

qЗащита от флуда в комментариях была перенесена из общих настроек скрипта в настройки групп пользователей. Тем самым вы можете отдельно для каждой группы пользователей включить и отключить данную защиту, а также отдельно для каждой группы назначить своё время таймаута на повторное добавление комментария на сайт.

qСущественно улучшена и оптимизирована система поиска публикаций по шаблону поиска при RSS импорте публикаций в панели управления DataLife Engine. Теперь в качестве начального кода и конечного кода вы можете указывать какой угодно сложный и многострочный код из страницы сайта, попросту скопировав его из кода сайта источника, без необходимости использовать сложДобавлена проверка, в случае запрета доступа к сайту, по стране на все выполняемые на сайте AJAX действия, а не только на прямые просмотры сайта. Что позволяет заблокировать автоматических ботов из запрещённых стран, в случае если им были заданы уже необходимые параметры и токены на выполнение каких-либо автоматических действий.ные конфигурации с тегом {skip}.

qОптимизирован и улучшен вывод навигации по страницам публикаций и комментариев для мобильных устройств. В случае использования посетителем смартфона при просмотре сайта, количество элементов страниц в навигации существенно сокращено, что позволяет навигации легко размещаться в пределах одной строки без переноса ссылок на страницы в навигации на другие строчки. Тем самым визуальный вид страницы приобретает более корректный вид. Удобство навигации при этом полностью сохраняется.

qВ случае если был запрещён доступ к сайту, например пользователь забанен, или ограничен по стране, добавлена отправка корректных HTTP заголовков 503 о том, что страница временно недоступна.

qДобавлена проверка, в случае запрета доступа к сайту, по стране на все выполняемые на сайте AJAX действия, а не только на прямые просмотры сайта. Что позволяет заблокировать автоматических ботов из запрещённых стран, в случае если им были заданы уже необходимые параметры и токены на выполнение каких-либо автоматических действий.

qДобавлена проверка заполненности имени плагина при добавлении плагинов в админпанели, перед отправкой данных на сервер, во избежание возникновения ошибок о том, что не заполнены обязательные поля и потери данных после отправки.

qДобавлена корректная поддержка вставки публикаций с твиттера с использованием тегов [mediа=…] в связи с тем, что сервис изменил домен на x.com

qДобавлена поддержка новой линейки PHP 8.4.xx

qУлучшена и ускорена обработка больших текстов при добавлении и редактировании публикаций, а также снижен расход памяти в некоторых случаях.

qУлучшены и оптимизированы алгоритмы построения дерева категорий при добавлении публикаций в панели управления и на сайте. Что позволило в ряде случаев существенно ускорить рендеринг страниц при большом количестве категорий.

qОптимизирована и улучшена обработка ряда шаблонных тегов, что позволяет в ряде случаев ускорить рендеринг шаблонов и снизить расход памяти.

qУбрана поддержка OpenSearch, в связи с тем, что технология устарела и больше не поддерживается актуальными браузерами.

qИсправлена проблема, при которой можно было отправить E-mail сообщение с сайта через обратную связь забаненному на сайте пользователю.

qИсправлена проблема, при которой могли не работать некоторые AJAX функции на сайте в случае, если в настройках скрипта была отключена поддержка авторизации на сайте, а администратор оставался залогиненным в панели управления DataLife Engine.

qИсправлена проблема, при которой нельзя было удалить все категории у публикации, при использовании массовых действий в панели управления при выборе действия “Изменить категории” для выбранных публикаций.

qИсправлена проблема, при которой не работали некорректно работали некоторые шаблонные теги в шаблонах вывода комментариев, в случае включения AJAX навигации по страницам комментариев.

Список изменений в версии 17.3:

qДобавлена возможность разрешать или ограничивать просмотр сайта посетителем, на основе страны, в которой он находится. Для этого в настройки скрипта в панели управления добавлены настройки, в которых вы можете указать список стран, для которых разрешён просмотр сайта. В случае если посетитель находится в указанных странах, то просмотр ему будет разрешён, а в случае, если нет, то ему будет автоматически заблокирован просмотр сайта. Также для удобства вы можете вместо разрешённых стран, указать список запрещённых стран, и в таком случае если посетитель находится в запрещённой стране, то просмотр ему будет ограничен, а если нет, то просмотр сайта будет разрешён. В случае если посетителю запрещён просмотр сайта на основе страны, то отдельной настройкой вы можете указать причину которую он будет видеть, по которой ему был запрещён просмотр сайта.

qДобавлена возможность указать в настройках скрипта список стран, для которых разрешена авторизация в панели управления DataLife Engine. А также для удобства вместо разрешённых стран, вы можете указать список запрещённых стран. В случае если пользователь находится в запрещённой стране, то все попытки авторизации в панели управления будут автоматически заблокированы не допуская даже попытки авторизации.

qДобавлена возможность выводить тот или иной контент в шаблонах на основе того, в какой стране находится посетитель сайта. Для этого в шаблоны добавлен новый глобальный тег: {country} который выведет ISO код страны, в которой находится посетитель сайта, например, выведет RU если посетитель находится в России, или US если посетитель находится в США. Данный тег, полезен, когда нужно добавить к ссылке какой-либо префикс на основе страны, например вывести флаг посетителя на сайте. Добавлены новые теги [country=X] текст [/country] которые выведут текст, указанный в них, если посетитель находится в указанных X странах, где X это список ISO кодов стран. Страны можно перечислять через запятую. Например, теги [country=RU, BY, KZ] текст [/country] выведут текст если посетитель из России, Беларуси или Казахстана. Также добавлены противоположные теги [not-country=X] текст [/not-country] которые выведут текст, указанный в них, если посетитель находится не в указанных X странах, где X это список ISO кодов стран. Например, [not-country=RU, BY, KZ] текст [/not-country] выведут текст если посетитель не из России, Беларуси или Казахстана, а из любых других стран.

qДобавлена возможность разрешать или запрещать индексацию поисковыми системами для категорий публикаций. В настройках категорий в панели управления вы можете разрешить или запретить для категории индексацию. В случае запрета индексации для категорий, данная категория и публикации в ней будут исключены из карты сайта при ее создании и обновлении, а также для страниц просмотра категорий и публикаций в этой категории будет добавлен метатег 'robots' с содержимым 'noindex, nofollow' запрещающий поисковым системам индексацию данных страниц.

qДля дополнительных полей с типом “Загружаемое изображение” и “Галерея изображений” добавлена возможность указывать по какой стороне устанавливать ограничения на оригинальное изображение и уменьшенную копию, если такие ограничения устанавливаются в настройках поля. Вы можете указать “По наибольшей стороне”, “По ширине” или “По высоте”. Ранее использовались общие настройки скрипта для этих параметров, теперь для каждого поля вы можете установить свои отдельные значения.

qДобавлена возможность размещать рекламные баннеры и материалы между комментариями. Для этого в разделе управления рекламными материалами в панели управления вы можете включить размещение баннера между комментариями и задать ему место расположения. Также как и у вывода кратких новостей, вы можете задать вывод баннера в верхней части, средней и нижней, а также комбинировать их вместе.

qДобавлена поддержка модуля рекламных материалов и тегов баннеров в шаблонах комментариев при использовании AJAX навигации комментариев и при динамической автоматической загрузке ленты комментариев с использованием AJAX.

qДобавлено автоматическое формирование содержимого метатегов “keywords” при показе кратких новостей на основе содержимого страницы, в случае если для данной страницы не было задано специальное значение в панели управления. В случае если для раздела имеется несколько страниц, то ключевые слова, которые были заданы в админпанели, будут использоваться только для первой стартовой страницы, а для последующих страниц данный метатег будет формироваться на основе контента именно данной страницы. Тем самым данный метатег на разных страницах не будет дублироваться, что положительно влияет на общее SEO вашего сайта. Автоматическое формирование будет производится точно также как и ранее для метатега “description”.

qПереработана и улучшена система поиска пользователей в разделе управления пользователями. Для поиска пользователей используется единое поле для поиска, при этом вы можете указать по какому критерию искать пользователя. Помимо поиска по логину и e-mail добавлено ещё 5 дополнительных полей по которым вы можете искать пользователей. Теперь доступен поиск пользователей также по полному имени, дополнительным полям пользователя, месту жительства, подписи и информации о себе. Тем самым вы можете более гибко находить нужных пользователей по различным критериям.

qПереработан и улучшен визуальный вид диалоговых окон, запрашивающих у пользователя подтверждение необратимых действий на сайте и в панели управления, например таких как удаление. Теперь кнопки подтверждения имеют отдельный ярко выраженный цвет, что уменьшает вероятность совершения пользователем автоматического действия, и как следствие снижает вероятность выполнения ошибочного действия без возможности его отмены.

qДобавлена возможность закрывать опрос к публикации непосредственно сразу при добавлении новой публикации в панели управления. Тем самым вы можете создать публикацию сразу с закрытым опросом без необходимости ее редактирования.

qДобавлена возможность назначать дату автоматического закрытия опросов к публикациям при их добавлении или редактировании в панели управления. Для этого вы можете у публикации во вкладке “Дополнительно” выбрать срок действия и в качестве действия выбрать “Закрытие опроса для голосований”. При наступлении указанной даты опрос будет автоматически закрыт и станет доступным только для просмотра результатов.

qВ настройки скрипта в панели управления добавлена возможность включения редиректа с WWW домена на домен без WWW. При включении данной настройки, в случае если посетитель заходит на сайт www.site.ru он будет автоматически перенаправлен на домен без WWW site.ru. Также редирект будет осуществляться и для поисковых систем, для улучшения индексации и ранжирования сайта. Мы рекомендуем на сервере всегда иметь поддержу www домена как алиаса, потому как пользователи могут вручную по привычке вводить адрес с www в строке браузера, но при этом включать редирект, чтобы улучшить индексацию сайта и сделать для пользователя привычным более короткий адрес.

qВ настройки скрипта добавлена возможность указать количество персональных сообщений, выводимых на страницу. Ранее данное значение было фиксированным в 20 сообщений. Теперь вы можете указывать своё собственное значение в настройках.

qДля тега пользовательского вывода публикаций {custom …} добавлена возможность использовать новый параметр name="X", в котором для блока вы можете назначить имя, и в дальнейшем использовать данное имя для отображения или скрытия другого оформления в шаблоне в случае, если в данном блоке есть контент или он отсутствует. Например, написание {custom name="block1" category="6"} покажет публикации из категории ID 6, а сам блок получить имя “block1”. Для оперирования с данным именем добавлены новые глобальные теги: [custom=X] Текст [/custom] где X это имя блока, которые выводят текст заключённый в них в случае, если блок с данным именем содержит информацию. А также добавлены противоположные теги [not-custom=X] Текст [/not-custom] которые выводят текст заключённый в них в случае, если блок с данным именем не содержит никакой информации и публикаций нет. Таким образом вы можете делать дополнительное внешнее оформление блоков или наоборот скрывать его в зависимости от того есть публикации в блоке или нет. Например, [custom=block1] Заголовок {custom name="block1" category="6"} [/custom]. При этом сам блок, может быть, в любом месте на странице и не обязательно внутри данных тегов. Тем самым вы можете адаптировать и менять другое оформление в шаблоне на основе данных тегов.

qДобавлено скрытие публикаций при просмотре краткого описания находясь при просмотре разрешённой категории, в случае если публикация находится одновременно в нескольких категориях и при этом находится в одной из запрещённых категорий. Например, публикация присутствует в категориях: ”Новости, Спорт, Футбол”, категории ”Новости, Спорт” разрешены для просмотра пользователю, а категория “Футбол” запрещена. В таком случае при просмотрах категорий Новости и Спорт данная публикация также будет недоступна.

qДобавлено автоматическое заполнение полей имени и E-Mail при ответе на комментарии для незарегистрированных пользователей, в случае если они ранее уже писали комментарии и вводили на сайте своё имя и почту.

qДобавлен перевод системных сообщений в случае возникновения ошибок при работе с почтовым сервером на языки согласно установленным языковым файлам. Теперь в случае возникновения каких-либо ошибок при отправке писем, вы будете получать сообщения на вашем языке согласно используемому языковому пакету, а не только на английском языке как ранее. В общей сложности добавлена поддержка более 40 языков.

qПри добавлении категории в панели управления, добавлена защита от случайного закрытия окна при нажатии мышкой за пределами окна или при нажатии на ESC на клавиатуре. Тем самым предотвращается случайное неумышленное закрытие окна. Закрыть окно можно нажав на соответствующие иконки или кнопки на окне, предназначенные для этого.

qПри добавлении категорий добавлен автоматический переход на список категорий сразу после добавления. Тем самым администратору больше не нужно нажимать лишние кнопки в панели управления, что упрощает процесс добавления большого количества категорий.

qВ разделе управления категориями убраны промежуточные информационные сообщения о успешном удалении категорий и добавлен автоматический переход на страницу списка категорий после удаления. Тем самым процесс управления категориями стал быстрее и не требует от пользователя лишних нажатий кнопок для перехода.

qПри редактировании комментариев в панели управления добавлена дополнительная идентификация о том, что комментарий был добавлен незарегистрированным пользователем, а также дополнительно выводится его E-mail если он его добавлял при публикации комментария. Тем самым вы можете легко определять кем написан тот или иной комментарий.

qДобавлено автоматическое срабатывание сохранения информации в базе данных, при нажатии на Enter при добавлении или редактировании публикаций в админпанели, в случае если курсор находится на каком-либо поле содержащим одну строку. Ранее при нажатии на Enter происходил либо поиск похожих новостей, либо заполнение мета описания, в зависимости от версии DLE.

qДобавлено кеширование для блоков пользовательского вывода публикаций с использованием блока {custom …} даже в случае, если блок не содержит публикаций для вывода. В данном случае экономится часть ресурсов сервера в случае, если по каким-то причинам отсутствует контент по указанным параметрам.

qДля шаблонов вывода профиля пользователя (userinfo.tpl и profile_popup.tpl) добавлена поддержка нового тега {user-id} который выводи ID пользователя. Данный тег может использоваться в ряде случаев при оформлении шаблона, а также, например для формирования пользовательских ссылок, например ссылок на последние комментарии пользователя и т.д.

qПри выводе в RSS потоке имён категорий, они автоматически разделяются текстовым символом запятой, а не разделителем, указанным в настройках скрипта. Тем самым вы можете использовать более сложные разделители из сложного HTML кода, для вывода на сайте списка категорий, и это не будет влиять на RSS поток.

qВнесены изменения в работу рекламных материалов, добавляемых в админпанели в разделе управления рекламными материалами. Настройка “Категория” установленная для баннера, при просмотре кратких новостей учитывает категорию которую просматривает пользователь на сайте, а при просмотре полных новостей, учитывает категорию к которой принадлежит публикация. Тем самым вы можете устанавливать ограничения на показ баннеров в полной новости на основе категорий публикации. Устанавливая при этом при необходимости ротацию баннеров с одинаковым именем.

qПри просмотре полных новостей и показе баннеров, для которых установлено ограничение по категориям, добавлена проверка всех категорий, которым принадлежит публикация, а не только проверка одной основной первой категории.

qЗагружаемый с использованием AJAX запросов контент был адаптирован для загрузки данных именно с того домена, на котором сейчас выполняется сайт, а не того который указан в настройках скрипта. Данное нововведение позволяет ускорить загрузку в случае, если используются зеркала сайта. А также данные остаются доступными в случае, если основной домен по каким либо причинам недоступен для браузера.

qДобавлено использование HTTP заголовка с кодом 301 для ссылок которые опубликованы с использованием тегов защищённых ссылок [leech=….] в публикациях и комментариях.

qДля шаблона вывода всплывающей карточки профиля пользователя (profile_popup.tpl) добавлена поддержка новых тегов условий сравнения значений. Например, тег [if field = "значение"] текст [/if] выведет текст заключённых в них если значения поля равно указанному значению.

qПереработана и улучшена система анимации на сайте, после выполнения пользователем AJAX действий. Анимация стала более быстрой, а также улучшено позиционирование элементов для лучшего фокуса элемента на сайте после выполнения действий.

qДобавлено автоматическое вычисление размеров диалоговых окон выводимых DataLife Engine на сайте с учётом размеров базового шрифта страницы. Тем самым если пользователь в браузере включает увеличение размеров шрифтов, то окна также будут в увеличенном размере. Что облегчает работу с сайтом людям с ограниченным зрением.

qДобавлена защита от случайного удаления пустой группы пользователей, в которой нет пользователей в разделе управления группами пользователей. Теперь администратору перед удалением необходимо будет дополнительно подтвердить своё намерение, что исключает случайного нажатия на кнопку удаления в меню.

qДобавлена защита от случайного удаления RSS канала из раздела импорта новостей по RSS в панели управления DataLife Engine. Теперь пользователю перед удалением необходимо будет дополнительно подтвердить своё намерение, что исключает случайного нажатия на кнопку удаления в меню.

qВывод информации о том, что публикация была обновлена при помощи тегов [updated] …. [/updated] в течении времени указанного в настройках скрипта, осуществляется только если была отмечена галочка “Выводить информацию о том, что публикация обновлена”. В случае если она не отмечена, то плашка об обновлении не появляется. Ранее она появлялась при любом редактировании публикации. Тем самым вы можете выводить эту информацию не при любом редактировании, а только тогда когда это необходимо.

qДобавлен контроль забаненных IP и пользователей на все AJAX действия на сайте. Например, если IP адрес был внесён в черный список в разделе “Фильтр по: IP, Логину или E-Mail” в панели управления, то данный IP будет блокироваться в том числе не только на просмотр сайта, но и при имитации AJAX действий. Тем самым в панели управления можно блокировать IP ботов и их подсети, которые накручивают рейтинги, просмотры и т.д.

qПри выполнении обновления скрипта до новых версий добавлено автоматическое включение вывода ошибок PHP в случае их возникновения, независимо от того выключены они или нет в настройках скрипта в админпанели. Это позволит администраторам сайта при выполнении обновления визуально увидеть какие именно ошибки возникли при обновлении. Это полезно если, например серверное ПО не отвечает минимальным требованиям, или отсутствуют какие-либо необходимые библиотеки PHP интерпретатора. Вывод ошибок включается только на процесс обновления, для всего остального действуют настройки, установленные в настройках скрипта.

qОбновлена и улучшена система определения устройств, с которых заходит пользователь на сайт. Расширена база устройств для определения смартфонов и планшетов, а также ускорена работы системы в целом.

qСнижена нагрузка на сервер, при просмотре всплывающих карточек пользователя в ряде случаев.

qОптимизировано формирование метатегов страниц сайта, убрано возможное дублирование контента в ряде случаев.

qПроведено множество оптимизаций и улучшений в пользовательском интерфейсе панели управления DataLife Engine. Все устаревшие уведомления в всплывающем окне DLEAlert заменены на уведомления в формате пуш уведомлений DLEPush, которые закрываются автоматически.

qПереработан контроль соответствия серверного ПО минимально необходимым требованиям. В случае если на сервере установлена версия PHP ниже минимально необходимой DLE больше не будет выводить “непонятных” PHP ошибок и аварийно завершать работу. Функции, которые не смогут работать, будут автоматически приостановлены, а для администратора будет выведено понятное сообщение о необходимости обновления версии PHP.

qВсе HTML элементы с типом ‘checkbox’ и ‘radio’ для различных форм, которые генерирует DataLife Engine для вывода на сайте в своём коде, были приведены к единому общему стандарту вывода. Тем самым появилась возможность удобно их кастомизировать с использованием CSS шаблона по своему усмотрению.

qДля шаблонных тегов {image-X} предназначенных для вывода URL изображений, а также для метатегов meta property="og:image” добавлена поддержка svg расширений для вставленных в публикацию изображений.

qДобавлена принудительная очистка и обнуление полей содержащих только значение '<p><br></p>' до пустого значения. Данное нововведение полезно в случае использования на сайте и в панели управления визуального редактора Floara в котором все пустые поля содержат это значение по умолчанию, даже если ничего не писать в редакторе. Тем самым не будет лишнего кода в полях если в них ничего не писалось в данном редакторе.

qДобавлена поддержка сервиса Rutube для вставки видео с использованием тега [media=…] в связи с добавлением сервисом поддержки протокола обмена данными oEmbed.

qВизуальный редактор TinyMCE обновлен до актуальной линейки. Была оптимизирована его работа и исправлен ряд ошибок.

qВесь код DataLife Engine был переписан без использования настройки $config[’charset’]. Уже очень давно DLE работает только на одной общей кодировке UTF-8, поэтому данная настройка была бессмысленна, и ее нельзя было изменить в настройках DLE в панели управления, при этом весь код DLE ее использовал. В новой версии код DLE ее больше не использует. Ее использование осталось только в местах необходимых для обновления с очень старых версий DLE. Также функции DLE, использующие в качестве параметра данную настройку, сохранили ее в целях совместимости работы со старыми сторонними модулями, но передача данных параметров больше не имеет никакого смысла, поэтому рекомендуется будет адаптировать свои старые модули и плагины, если они используют эти функции DLE.

qИсправлена проблема, при которой теги теги [image-x] текст [/image-x] не работали если не использовался в шаблоне тег {image-x} совместно с ними при просмотре полных новостей и при выводе новостей с использованием пользовательского вывода {custom ….}

qИсправлена проблема, при которой могла создаваться пустая карта сайта для статических страниц, если есть статические страницы, но нет страниц, которые нужно помещать в карту. Например, для всех страниц запрещена публикация в карту или запрещена индексация или они закрыты паролем.

qИсправлена проблема, при которой отключённый сайт транслировал RSS поток для турбо страниц с ошибкой.

qИсправлена проблема, при которой некорректно отображалось имя плагина, если в нем возникали ошибки, в разделе показа ошибок, если имя плагина содержало теги [lang=x] … [/lang]

qИсправлена проблема, при которой нельзя было использовать теги {custom …} в шаблоне attachment.tpl

qИсправлена проблема, при которой в некоторых случаях могла происходить некорректная обработка вставки примеров кодов в публикациях.

qИсправлена проблема, при которой могло в ряде случаев не сохраняться расширение файлов, загруженных на сервер, при использовании очень длинных имен файлов.

qИсправлена проблема, при которой не работала функция отключения предварительной загрузки видео, в настройках медиапроигрывателя.

qИсправлена проблема, при которой не работал выбор опции фиксации публикации при добавлении публикации с сайта.

Список изменений в версии 17.2:

qДобавлена новая система пуш уведомлений посетителей сайта при их автоматическом переводе из одной группы в другую. Например, по истечении срока нахождения в группе, или при наборе им определённого рейтинга и т.д. В случае автоматического перевода пользователя в другую группу, он будет получать на сайте соответствующее пуш уведомление о том, что он был переведён в другую группу, а также будет указана соответствующая причина, по которой он был переведён. Тем самым посетители вашего сайта всегда будут знать, что они были переведены в другую новую группу пользователей.

qДобавлена возможность маркировать новые публикации. Для этого в настройки скрипта в админпанели добавлена возможность указать, сколько времени необходимо считать добавленную публикацию на сайт новой. После этого в шаблонах вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) вы можете использовать теги [new] текст [/new] которые выводят текст заключённый в них если публикация считается новой, а также вы можете использовать теги [not-new] Текст [/not-new] которые выводят текст, заключённый в них, если с момента публикации прошло больше указанного в настройках времени. Время в настройках задаётся в часах. Тем самым вы можете маркировать публикации в шаблонах какими-либо плашками о том, что это новая публикация.

qДобавлена возможность маркировать обновлённые публикации. Для этого в настройки скрипта в админпанели добавлена возможность указать, сколько времени необходимо считать после редактирования публикации обновлённой. После этого в шаблонах вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) вы можете использовать теги [updated] текст [/updated] которые выводят текст заключённый в них если публикация считается обновлённой, и также вы можете использовать теги [not-updated] Текст [/not-updated] которые выводят текст, заключённый в них, если с момента редактирования прошло больше указанного в настройках времени. Время в настройках задаётся в часах. Тем самым вы можете маркировать публикации в шаблонах какими-либо плашками о том, что это обновлённая публикация.

qВ настройки скрипта в админпанели DataLife Engine добавлена возможность указывать какое максимальное количество жалоб может отправлять пользователь с сайта. Ранее данное количество было ограничено тремя жалобами на орфографические ошибки. Теперь вы можете указать количество жалоб и данное ограничение будет распространяться на публикации, комментарии, и орфографические ошибки.

qВ настройки групп пользователей добавлена возможность разрешения или запрета для данной группы отправлять жалобы на публикации с сайта. Тем самым вы можете для определённых групп запретить возможность отправлять жалобы на публикации чтобы избегать злоупотреблений.

qВ настройки групп пользователей добавлена возможность разрешения или запрета для данной группы отправлять жалобы на комментарии на сайте. Тем самым вы можете для определённых групп запретить возможность отправлять жалобы на комментарии чтобы избегать злоупотреблений.

qВ настройки групп пользователей добавлена возможность разрешения или запрета для данной группы отправлять жалобы на орфографические ошибки на сайте. Тем самым вы можете для определённых групп запретить возможность отправлять жалобы на орфографические ошибки чтобы избегать злоупотреблений.

qДобавлена возможность закрытия опросов для участия в голосовании, которые используются в новостях. Тем самым вы можете для публикации закрывать опрос, оставляя его в публикации. Закрытые опросы будут выводится в публикации, но пользователи больше не смогут принимать в нем участия, а будут видеть только результаты данного опросы. Данная функция полезна, если опрос потерял со временем актуальность, но вы не хотите его удалять, а оставить вывод результатов на сайте. Опрос также можно в любое время повторно открыть.

qДля шаблонов вывода опросов в публикациях (poll.tpl) добавлена поддержка новых тегов [closed] текст [/closed] которые выводят текст заключённый в них, если опрос был закрыт для голосования, а также добавлены обратные теги [not-closed] текст [/not-closed] которые выводят текст заключённый в них, если опрос открыт для голосования посетителям сайта.

qДля шаблонов вывода опросов в публикациях (poll.tpl) добавлена поддержка нового тега {close-date} который выводит дату закрытия опроса от голосований, если он был закрыт.

qДля дополнительных полей с типом “Одна строка” и “Несколько строк” добавлена возможность указывать в настройках поля минимальное количество символов, которое необходимо написать в случае заполнения данного поля. Данную опцию можно также оставить без ограничений.

qДля дополнительных полей с типом “Одна строка” и “Несколько строк” добавлена возможность указывать в настройках поля максимальное количество символов, которое необходимо написать в случае заполнения данного поля. Данную опцию можно также оставить без ограничений.

qДобавлена поддержка скачивания загруженных файлов на сервер или внешние хранилища через DLE в несколько потоков, а также добавлена поддержка докачки файлов в случае сбоя скачивания. Данное нововведение будет особенно полезно при скачивании больших файлов с использованием медленного интернет-соединения.

qДля быстрого редактирования публикаций на сайте, добавлена возможность изменения категории у публикации при ее редактировании.

qДля системы управления плагинами в панели управления добавлена возможность вставлять блоки действий, между уже существующими действиями. Для этого у каждого блока добавлена кнопка для добавления нового действия, которое будет добавлено сразу после выбранного блока. Тем самым в существующем плагине вы можете при редактировании добавлять дополнительные блоки сразу в нужное вам место.

qДля системы плагинов добавлена возможность использовать в имени плагина, описании плагина, и заметок для плагина теги [lang=X] Текст [/lang] в их тексте. Которые выводят текст в зависимости от того языка, который использует пользователь в админпанели. Где X это ISO код языка из языкового пакета. Тем самым вы можете выводить название, и заметки на разных языках. Например тег [lang=ru]Текст на русском[/lang] выведет данный текст если пользователь использует русский язык, а тег [lang=en] English Text [/lang] если пользователь использует английский язык.

qДобавлена поддержка нового глобального шаблонного тега: [active-plugins=X] Текст [/active-plugins] который выводит текст заключённый в него если указанный плагин включён и используется на сайте. Где X это ID плагина или его имя. Например, вы можете указать [active-plugins=1] Текст [/active-plugins] либо [active-plugins=Мой плагин] Текст [/active-plugins], и если плагин с ID 1 или с именем “Мой плагин” включен в системе, то текст указанный в теге будет выведен. Также вы можете перечислять несколько параметров в теге через запятую, например, [active-plugins=1,2,5] Текст [/active-plugins].

qДобавлена поддержка нового глобального шаблонного тега: [not-active-plugins=X] Текст [/not-active-plugins] который выводит текст заключённый в него если указанный плагин выключен и не используется на сайте. Где X это ID плагина или его имя. Например, вы можете указать [not-active-plugins=1] Текст [/not-active-plugins] либо [not-active-plugins=Мой плагин] Текст [/not-active-plugins], и если плагин с ID 1 или с именем “Мой плагин” выключен в системе и не используется, то текст, указанный в теге будет выведен. Также вы можете перечислять несколько параметров в теге через запятую, например, [not-active-plugins=1,2,5] Текст [/not-active-plugins].

qДля пользовательского вывода публикаций с использованием тега {custom ….} добавлена возможность использование нового параметра favorites="yes", который выведет публикации которые находятся у посетителя в закладках. Например, тег {custom favorites="yes" order="id_as_list”} выведет публикации из закладок пользователя в том порядке сортировки, в котором он их вносил в закладки.

qПолностью переработана система работы настройки разрешения или запрещения комментариев в настройках категорий для определённых категорий сайта. Ранее при запрете комментариев в настройках категории данный запрет распространялся только на новые добавляемые публикации в этой категории, при этом запрет прописывался непосредственно в самой публикации, и для вступления изменений в силу для ранних публикаций необходимо было пересохранять публикацию. Теперь разрешение или запрет на комментарии в категории вступает в силу незамедлительно для всех публикаций в категории, а сам запрет не прописывается непосредственно в саму публикацию. Соответственно вы можете включать и отключать разрешение на комментарии в категории и данное действие будет вступать в силу незамедлительно для публикаций в этой категории.

qДобавлена система автоматических подсказок при заполнении автора публикации во время добавления или редактирования публикаций в панели управления DataLife Engine. Теперь при заполнении поля с автором публикации, если его необходимо заменить, будет выводится список существующих пользователей в базе данных, соответствующих набираемому значению. Тем самым ускоряется процесс редактирования, а также сводится к минимуму возможные ошибки при наборе логина пользователя.

qВ настройки скрипта в панели управления добавлена отдельная настройка какое количество комментариев необходимо выводить на странице просмотра последних комментариев. Тем самым вы можете отдельно независимо указать количество комментариев на страницу при просмотре комментариев в публикации и при просмотре всех последних комментариев на сайте.

qДобавлен автоматический переход сразу на нужный комментарий на странице при переходе по ссылкам, которые пользователи получают в e-mail уведомлениях о новых комментариях в публикации, если они подписаны на данные уведомления. Тем самым пользователь сразу видит на странице добавленный комментарий.

qДля дополнительных полей с типом “Список” добавлена возможность использовать символы запятых в значениях списка. Ранее данный символ был зарезервирован под системные нужды в данном типе дополнительных полей.

qДля шаблонов вывода кратких и полных новостей добавлена поддержка новых тегов: [ifxfset fields="X"] текст [/ifxfset] которые выводят текст заключённый в них если поле с именем X было задано и заполнено для новости. При этом вы можете перечислить несколько имён полей через запятую. Например [ifxfset fields="test1,test2"]оба поля с именем test1 и test2 заполнены[/ifxfset] выведет текст если оба поля были заполнены в новости. А также добавлены теги [ifxfnotset fields="X"] текст [/ifxfnotset] которые выводят текст заключённый в них если поле с именем X не было задано и заполнено для новости. При этом вы также можете перечислить несколько имён полей через запятую. Например [ifxfnotset fields="test1,test2"]оба поля с именем test1 и test2 не были заполнены[/ifxfnotset] выведет текст если оба поля не были заполнены в новости. Основное отличие от существующих тегов [xfgiven_x] и [xfnotgiven_x] заключается в том, что вы одновременно можете перечислить несколько полей и проверяется заполненность всех перечисленных полей одновременно, а также проверяется именно заполненность полей без значений, например если у поля задано “0” или значение “нет”, это тоже является заполненным полем в публикации. Если нужно проверять сами значение, то как и прежде задействуйте теги [if field = "значение"] текст [/if].

qДля шаблонов вывода профиля пользователя (userinfo.tpl и profile_popup.tpl) добавлена поддержка новых тегов: [own-profile] Текст [/own-profile] которые выводят текст, заключённый в них, в случае если пользователь просматривает собственный профиль на сайте, а также теги [not-own-profile] текст [/not-own-profile] которые выводят текст, заключённый в них, в случае если пользователь просматривает чужой профиль на сайте.

qДля шаблона вывода меню категорий (categorymenu.tpl) шаблонные теги [category-icon] текст [/category-icon] а также [not-category-icon] текст [/not-category-icon] были заменены на теги [cat-icon] текст [/cat-icon] и [not-cat-icon] текст [/not-cat-icon] соответственно. Связано это с тем, что данные теги имели тоже же название что и глобальные теги для всех шаблонов привязанные к публикациям, что приводило к их некорректной работе при просмотре разделов и публикаций.

qДобавлена поддержка настройки “Автоматическая конвертация ссылок в кликабельные” для всех редакторов, включая и визуальные редакторы. Теперь данная настройка применяется независимо от используемого редактора, а также для дополнительных полей с типом “Несколько строк” независимо от редактора. Дополнительно настройка применяется и для комментариев, если пользователю разрешено публикация ссылок, и он публикует ссылку просто текстом в некликабельном виде, то она будет автоматически сконвертирована в кликабельную ссылку.

qДобавлен режим галереи при просмотре увеличенных изображений в панели управления DataLife Engine в разделе управления загруженными изображениям.

qДобавлена возможность сохранения и вывода логина пользователя в шаблоне добавления комментариев, в случае если комментарий оставляет незарегистрированный пользователей. Для этого в шаблоне addcomments.tpl добавлена поддержка нового тега {guest-name}, который выводит логин незарегистрованного пользователя, которое он вводил во время предыдущего добавления комментария. Тем самым незарегистрованному пользователю не нужно будет вводить каждый раз свой логин, когда он добавляет комментарий на сайте.

qДобавлена возможность сохранения и вывода почтового адреса E-Mail пользователя в шаблоне добавления комментариев, в случае если комментарий оставляет незарегистрированный пользователей. Для этого в шаблоне addcomments.tpl добавлена поддержка нового тега {guest-mail}, который выводит E-Mail незарегистрованного пользователя, который он вводил во время предыдущего добавления комментария. Тем самым незарегистрованному пользователю не нужно будет вводить каждый раз свой почтовый адрес, когда он добавляет комментарий на сайте.

qДобавлена возможность использования одновременно в пределах одной страницы разных редакторов. Например, вы можете для быстрого редактирования публикаций использовать редактор Floara, а для комментариев использовать адаптированный редактор для мобильных TinyMCE.

qДобавлена проверка заполненности обязательных дополнительных полей при быстром редактировании публикаций на сайте.

qПри добавлении комментариев на сайте, внесены изменения в уведомления в случае, если комментарий отправляется на модерацию. Ранее информационное сообщение имело информационный визуальный тип “Ошибка”, что могло вводить пользователей в заблуждение, и они отправляли комментарии повторно. Теперь информирование происходит в виде более мягкого предупреждения что комментарий был добавлен, но находится на модерации.

qУлучшена система удаления всех комментариев пользователя на сайте. Ранее в некоторых случаях в базе могли остаться комментарии, являющиеся ответами на удаляемый комментарий, что приводило к наличию в базе неиспользуемых излишних данных.

qВизуальный редактор TinyMCE был переведён на использование новейшей линейки 7.xx

qВ случае выключения сайта в настройках скрипта, например для проведения каких-либо работ на сайте добавлена отправка корректных HTTP заголовков 503 о том, что страница временно недоступна. Это исключает попадание страниц с информацией о том, что сайт отключён в индекс поисковых систем, если в момент отключения сайта они посещают сайт для индексации.

qВ случае падения MySQL сервера, добавлена отправка более корректных HTTP заголовков 503 о том, что страница временно недоступна. Это исключает попадание страниц с ошибкой работы сайта в индекс поисковых систем, если в момент сбоя они посещают сайт.

qВнесены изменения в информирование посетителей в случае, если для них запрещено добавление комментариев на сайте. Если добавление комментариев запрещено в этой публикации именно для их группы, но какие-либо другие группы могут добавлять комментарии, то выводится сообщение что именно для их группы нет доступа к добавлению комментариев. В случае если комментарии недоступны вообще для данной публикации для всех групп и не зависимо от группы пользователей, то сообщение об ограничении именно для их группы не выводится. Тем самым пользователь не вводится в заблуждение о том, что только ему недоступны комментарии а другим доступны.

qИсправлена проблема, при которой не удалялись файлы бэкапов при автоматическом создании бэкапов по крону, в случае превышения установленным лимитов на количество хранимых файлов бэкапов.

qИсправления безопасности при работе в разделе управления базой данный в панели управления DataLife Engine.

qИсправлена проблема, при которой не работал переход к комментариям при просмотре последних новостей в случае, если была отключена поддержка ЧПУ в настройках скрипта.

qИсправлена проблема, при которой в некоторых случаях могла некорректно определяться нужная страница с комментарием, при переходе по ссылке при показе последних комментариев, если включена предварительная модерация комментариев перед их публикацией.

qИсправлена проблема, при которой пользователь переносился в несуществующую группу, если было настроено продвижение по группам в настройках групп, а сама группа, в которую нужно продвигать была удалена. В случае отсутствия группы, пользователь будет оставаться в этой же группе и никуда не продвигаться дальше.

qИсправлена проблема, при которой в некоторых случаях могла происходит ошибка при добавлении или редактировании RSS информеров в панели управления DataLife Engine.

qИсправлена проблема, при которой в некоторых случаях могла происходит ошибка в разделе управления категориями в панели управления.

qИсправлена проблема, при которой не действовала настройка групп пользователей “Скрывать только полную новость из недоступных разделов” при использовании тега пользовательского вывода {custom …}.

qИсправлена проблема, при которой не корректно обрабатывался глобальный тег {news-id} в случае если просматривается несуществующая публикация.

qИсправлена проблема, при которой мог неверно выводится заголовок публикации при использовании тега {news-title} в пользовательском выводе комментариев при использовании тега {customcomments ….}.

qИсправлена проблема, связанная с некорректным определением даты публикации: “вчера и сегодня” в ряде случаев.

qИсправлена проблема, при которой в ряде случаев мог происходить некорректный подсчёт отправляемых через обратную связь файлов.

Список изменений в версии 17.1:

qДля дополнительных полей с типом список добавлена возможность выбора нескольких значений из списка. Вы можете в настройках данного дополнительного поля установить можно ли для него выбирать одновременно нескольких значений или нужно выбрать только одно из списка. Также вы можете указать разделитель при выводе значений данного поля на сайте. Дополнительно вы можете назначить для данного поля является ли оно обязательным к заполнению или может быть оставлено пустым.

qДобавлена возможность включать в карту сайта Sitemap также и ссылки на изображения, загруженные к публикациям. Данная опция может включаться либо отключаться непосредственно при создании карты в админпанели. При включении данной опции все изображения, которые были загружены к публикации будут также добавлены в карту согласно стандартам поисковой системы Google https://developers.google.com/search/docs/crawling-indexing/sitemaps/image-sitemaps?hl=ru. А если опция отключена, то карта будет создаваться без ссылок на изображения. Включение изображений в карту увеличивает время, необходимое для создания карты и требует дополнительных запросов к базе данных, поэтому вы сами решаете есть ли необходимость включать данную опцию или нет. При этом включение изображений в карту существенно улучшает индексацию изображений на вашем сайте.

qДобавлена новая система уведомлений пользователей на сайте о успешном выполнении или наоборот о ошибке выполнения запрошенных ими действий на сайте. Ранее информация выводилась на странице в всплывающем окне DLEAlert, которое пользователю нужно было также дополнительно закрыть, нажав на кнопку “Ок” или на закрытие окна. Новая система выполнена в формате пуш уведомлений, которые всплывают в углу браузера и по прошествии времени автоматически закрываются, не требуя от посетителя сайта никаких действий. Разработчики дополнительных шаблонов, модулей и плагинов могут также использовать новые встроенные функции для вызова пуш уведомлений. Пуш о успешном выполнении вызывается функцией DLEPush.info (message, title), пуш о предупреждении вызывается функцией DLEPush.warning (message, title), пуш уведомления о возникновении ошибки вызывается функцией DLEPush.error (message, title). Разные типы уведомлений обладают специальным сигнализирующим оформлением.

qВ настройки скрипта в панели управления DataLife Engine, в разделе управления изображениями добавлена возможность включать принудительное добавление уникального префикса для загружаемых изображений. При включении данной опции к имени всех загружаемых изображений будет добавлен уникальный префикс. Данное нововведение будет полезно, для тех, кто часто изменяет загруженное изображение на другое, во избежание браузерного кеширования, чтобы пользователи сразу видели изменённое изображение на сайте. В случае если данная настройка отключена, то будет сохранено оригинальное имя изображения и только если такой файл уже существует на сервере, то к нему будет применён уникальный префикс. Сам же префикс больше не привязан непосредственно к времени загрузки как ранее, и является уникальным и сгенерированным случайным образом.

qДобавлена возможность сортировки заданных внешних хранилищ в том порядке вывода, в котором это необходимо. Для этого вы можете путём простого переноса в нужное место задать нужный вам порядок сортировки в панели управления в разделе управления хранилищами. Тем самым наиболее часто используемые вы можете разместить выше при необходимости.

qДобавлена возможность установить настройки режима быстрого редактирования публикаций на сайте. Теперь вы можете выбрать для быстрого редактирования нужно ли редактировать только уже ранее заполненные поля публикации или же выводить все поля для редактирования, в том числе и не заполненные ранее. При выборе режима редактирования только заполненных полей, быстрое редактирование на сайте, как и ранее будет выводить только заполненные ранее при добавлении поля. В случае если выбран режим всех полей, то независимо от того пустое поле или нет, было оно ранее заполнено или нет, при быстром редактировании вы можете редактировать и краткое и полное описание и все дополнительные поля для публикаций.

qДобавлено полное сохранение имени файла загружаемого на сервер с использованием DataLife Engine и предназначенное для скачивания. При загрузке файла на сервер, его имя будет сохранено так, как оно было изначально, и соответственно при скачивании оно будет сохранено на компьютер с тем же именем. Например, если в имени использовались кириллические символы (мой файл.txt), то они также останутся при скачивании без транслитерации: мой файл.txt, тоже самое касается и других языков.

qДля системы плагинов в панели управления DataLife Engine добавлена возможность выполнить все необходимые действия с плагином непосредственно при редактировании самого плагина. Например, на странице редактирования плагина вы можете, не покидая страницу проверить обновления или обновить, скачать его или удалить. Ранее на страницы редактирования плагина можно было только отредактировать его. В общей сложности добавлено пять новых опций.

qДля системы плагинов в панели управления DataLife Engine добавлен вывод ссылки на редактирование плагина в меню опций плагина, тем самым вы можете открывать редактирование плагинов в новых вкладках браузера, что полезно при одновременном редактировании разных плагинов в панели управления.

qДобавлена возможность менять имя автора комментария при редактировании комментариев на сайте и в админпанели, в случае если комментарий был оставлен незарегистрированным пользователем. Теперь в случае, если пользователь написал в поле имени какой-либо недопустимый текст, администратор может его отредактировать, не удаляя сам комментарий на сайте.

qДобавлено автоматическое динамическое изменение содержимого тегов [add-favorites] текст [/add-favorites] и [del-favorites] текст [/del-favorites] при добавлении или удалении публикации в закладки на сайте. При этом не важно, где в шаблоне расположены эти теги и какого их содержимое. Содержимое будет обновляться автоматически при осуществлении AJAX действия, без необходимости перезагрузки страницы и пользователь автоматически будет видеть, что публикация была либо добавлена в закладки, либо удалена из них.

qПри выводе кнопки “Пожаловаться” в комментариях на сайте добавлена проверка, является ли пользователем автором данного комментария и если является, то кнопка жалобы для этого комментария у него не выводится, т.к. пользователи не могут жаловаться на собственные комментарии.

qДобавлена поддержка нового глобального тега {lang text="LANG_PARAMETER"}, который предназначен для вывода информации из языкового файла website.tpl, который в данный момент используется, где LANG_PARAMETER это значение параметра, который необходимо вывести. Например, тег {lang text="attach_images"} выведет надпись “Прикрепить изображения” из языкового пакета, в случае использования русского языка и если используется английский язык, то “Attach Images”. Данный тег будет полезен при разработке дополнительных модулей и плагинов, когда вы можете разместить дополнительные языковые данные непосредственно в языковой пакет и автоматически выводить нужные вам фразы при смене языка пользователем на сайте, выводя значения в шаблоне в виде тега, а не прямого написания фразы.

qДля шаблонов вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) добавлена поддержка нового тега {edit-date=формат даты} который выводит дату редактирования публикации в заданном в теге формате. Тем самым вы можете задавать свой собственный формат для даты редактирования, или выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {edit-date=d} выведет день месяца, а тег {edit-date=F} выведет название месяца, а тег {edit-date=d-m-Y H:i} выведет полную дату и время.

qДля шаблона вывода всплывающей карточки пользователя (profile_popup.tpl) добавлена поддержка нового тега {usertitle} который выводит логин пользователя в нужном вам месте. Ранее логин пользователя выводился только в заголовке карточки, теперь вы можете вывести его дополнительно в нужном вам месте в шаблоне.

qДля дополнительных полей с типом “Дата и время” добавлена поддержка нового тега [xfvalue_X format="Формат"], где X это имя дополнительного поля, а “Формат” это формат вывода заданной в поле даты и времени. Тем самым в разных местах шаблона, вы можете выводить данное дополнительное поле в разных форматах даты и времени, а не только в том формате, которое указано для поля по умолчанию в настройках поля. Например тег [xfvalue_test format="j F Y H:i"] выведет дату и время указанное в поле в формате времени j F Y H:i.

qДля шаблонов вывода профиля пользователя (userinfo.tpl и profile_popup.tpl) добавлена поддержка новых шаблонных тегов: [banned] текст [/banned] выводят текст заключённый в них если пользователь в данный момент забанен на сайте, [not-banned] текст [not-banned] выводят текст заключённый в них если пользователь не забанен на сайте, {ban-description} выводит причину по которой пользователь забанен, {ban-date} выводит дату до которой пользователь был забанен на сайте. Тем самым при помощи новых тегов вы можете выводить информацию для других посетителей сайта при посещении профиля пользователя, о том, что данный пользователь был забанен и по какой причине он был забанен.

qДобавлена возможность указать в настройках скрипта в админпанели, какой именно провайдер будет использован для уведомлений поисковых систем с использованием протокола IndexNow. Выбор провайдера не влияет на то какие поисковые системы будут уведомлены, они автоматически синхронизуют данные, но выбор влияет на то, какой из провайдеров быстрее отвечает и ближе доступен к вашему сайту по расположению. Тем самым каждый может выбрать оптимального провайдера для своего сайта.

qВ настройки скрипта добавлена возможность включения специально адаптированного редактора для мобильных устройств при написании комментариев на сайте. При включении данной опции, будет отображён специальный облегчённый редактор с минимумом набора кнопок в нем. Данный редактор не перегружает информацией мобильный экран, а также в нем упрощена загрузка и управление изображениями.

qДобавлена автоматическая поддержка всех поддерживаемых сервером часовых поясов, которые вы можете установить для сайта по умолчанию или пользователь сможет выбрать в своём профиле. А также в случае, если на сервере обновляются часовые пояса, то DataLife Engine автоматически будет их также использовать. Тем самым добавлено более 300 новых регионов для выбора часового пояса, и обновляться они будут автоматически в случае появления новых. Для удобства выбора часового пояса добавлен поиск по часовым поясам при выборе.

qДобавлена система поиска по настройкам скрипта в админпанели. Теперь вы можете более быстро найти нужную настройку, начав набирать ее название. Также для удобства визуального отображения текст в найденной настройке подсвечивается.

qДобавлен редактор с подсветкой исходного кода, для раздела управления шаблонами E-mail сообщений, а также улучшена визуальная составляющая данного раздела. Тем самым редактировать шаблоны для E-Mail сообщений стало более удобней.

qДобавлено автоматические перестроение облака тегов при перестроении публикаций в админпанели. Данное нововведение будет полезно, если при ручной самостоятельной работе с базой данных были некорректно обновлены связи между таблицами. Например, в случае добавления публикаций минуя DLE.

qДобавлено автоматическое перенаправление пользователя на главную страницу сразу после регистрации на сайте. Тем самым уменьшается количество кликов пользователем на сайте при его регистрации на сайте и уменьшается количество шагов, которые необходимо сделать посетителю сайта.

qДобавлена поддержка IPv6 адресов для настройки “Список IP для которых разрешена авторизация в админпанели скрипта” в настройках админпанели. Тем самым если администратор сайта имеет IPv6 адрес вместо не IPv4 адреса, то для доступа к сайту он может ограничить доступ для необходимых ему IPv6 адресов.

qУлучшена система визуального отображения выбранных категорий при добавлении и редактировании публикаций в панели управления.

qДля редактора TinyMCE возвращена возможность устанавливать размеры изображения непосредственно при редактировании свойств данного изображения.

qВнесены изменения в работу кнопки отметки пользователя спамером. Теперь данная кнопка не появляется у комментариев пользователей, которые находятся в защищенной от этого группе пользователей.

qСортировка внешних хранилищ, при выборе их во время загрузки файлов если это разрешено, приведена к такому же отображению, как и в разделе управления внешними хранилищами.

qПереработана и улучшена система определения цвета наложения водяных знаков на изображения. Теперь DataLife Engine лучше и качественнее определяет цветовые участки, на которые будет наложен водяной знак, что позволяет более точно определить какой водяной знак (темный или светлый) необходимо наложить в данном случае.

qУлучшена система предварительной проверки e-mail адреса при регистрации пользователя на сайте и изменении адреса в профиле.

qПри редактировании значений дополнительных полей пользователей в панели управления, добавлено использование прав именно редактируемого пользователя, а не с использование прав того, кто редактирует. Например, если пользователю запрещено добавлять ссылки в дополнительных полях, то при редактировании пользователя администратором, данный запрет также будет использоваться и сохраняться.

qДобавлена возможность использовать HTML код в дополнительных полях профилей пользователей, в случае если для данных полей не включён безопасный режим. Ранее допускалось использование только BB тегов.

qДобавлена возможность использования дополнительных полей с типом “Дата и Время” в главном шаблоне main.tpl при просмотре полных публикаций. Ранее данный тип полей не был доступен в полном объёме вывода согласно настройкам поля.

qДобавлен автоматический сброс кеша файла пользовательских стилей adminpanel.css, расположенного в шаблоне, при очистке кеша в админпанели.

qДля тегов [ifxfvalue ….] … [/ifxfvalue], предназначенного для проверки значений дополнительных полей, добавлена проверка по списку значений, если дополнительное поле имеет включённую опцию “Использовать как перекрестные ссылки”. Например, если поле имеет несколько значений, то проверка будет происходить не по полю целиком, а каждое значение в поле по отдельности. Аналогичное поведение проверки добавлено и для тегов [if ….] … [/if] для данных типов дополнительных полей.

qДобавлена поддержка PHP линейки 8.3.xx

qВизуальный редактор TinyMCE обновлён до актуальной линейки. Улучшена скорость его рендеринга.

qПри использовании редактора TinyMCE в случае, если изображение загружается не через менеджер файлов, а через окно вставки изображений в редакторе, добавлено сохранение написанного описания изображения в случае если создаются при этом уменьшенные копии.

qВ связи с тем что поисковые системы прекратили поддержку предварительных уведомлений от сайтов об изменении карты сайта sitemap.xml https://developers.google.com/search/blog/2023/06/sitemaps-lastmod-ping?hl=ru, данная функция уведомлений также была исключена из DataLife Engine. Теперь все происходит автоматически со стороны поисковых систем, вам достаточно просто добавить адрес в панели вебмастера поисковой системы и поисковые системы будут автоматически проверять и переиндексировать данный сайт.

qУлучшена система отображения загруженных изображений и файлов в окне загрузки файлов. Префикс файлов для удобства скрывается из имени загруженных файлов для более удобной ориентации по файлам. Также сам префикс более корректно определяется в имени и избегается случайное удаление части имени в ряде определенных случаев.

qИсправлена проблема, при которой невозможно было добавлять ответы на комментарии при включённой защите от спама reCAPTCHA v3.

qИсправлена проблема, при которой некоторые дополнительные поля могли принимать некорректные значения при перестроении публикаций в панели управления.

qИсправлена проблема, при которой могли в некоторых случаях некорректно обрабатываться шаблоны комментариев если комментарий был оставлен не зарегистрированным пользователем.

qИсправлена проблема, при которой не загружался список внешних хранилищ при загрузке изображений, если несколько разных сайтов объединялись в единую базу пользователей.

qИсправлена проблема, при которой некорректно очищался кеш при одобрении комментария, находящегося на модерации.

qИсправлена проблема, при которой пользователь с логином “noname”, не мог выставлять оценки для публикаций и комментариев.

qИсправлена проблема, при которой при перестроении публикаций в админпанели, в индекс поиска публикаций на основе дополнительных полей попадали публикации, не опубликованные на сайте.

qИсправлена проблема, при которой некоторые часовые пояса пользователь не мог выбрать в своём профиле.

qИсправлена проблема, при которой могла некорректно отображаться дата публикации “Вчера” и “Сегодня” в случае, если произошла смена дня относительно серверного времени согласно часовому поясу, который выбрал пользователь для себя в профиле на сайте.

qИсправлена проблема, при которой при просмотре полных новостей мог не работать непосредственный переход к нужному комментарию в блоке комментариев выводимых тегом {customcomments …..} если таковой присутствует на странице.

qИсправлена проблема, при которой не очищался кеш для страниц полных новостей в случае редактирования публикации в админпанели, в случае если включён третий тип ЧПУ в настройках скрипта.

Список изменений относительно версии 16.1:

qДобавлена возможность для пользователей сайта самостоятельно удалять свой аккаунт на сайте, в случае если они этого желают. Данное разрешение включается в настройках групп пользователей. И может быть выбрано из нескольких вариантов. Вы можете разрешить пользователям полностью самостоятельно принимать решение об удалении аккаунта, либо можете разрешить только отправку запроса администрации сайта на удаление аккаунта, либо вообще запретить самостоятельное удаление. Администраторская группа всегда защищена от самостоятельного удаления в целях безопасности от кражи аккаунта. Администратора может удалить только другой администратор. В случае если пользователю разрешено самостоятельное удаление, то он сам может удалить свой аккаунт и все свои данные с сайта в своём профиле подтвердив данное решение дополнительным вводом своего пароля от аккаунта. В случае если включена отправка запроса администрации, то в разделе управления пользователями для администраторов сайта будет показан список пользователей, которые запросили удаление данных и аккаунта с сайта, и администратору необходимо будет принять решение о удалении данного аккаунта или об отклонении данного запроса. После удаления аккаунта администратором, пользователь получить соответствующее уведомление, что его запрос на удаление выполнен.

qДля шаблона вывода профиля пользователя (userinfo.tpl), добавлена поддержка новых тегов: [delete] Текст [/delete] которые выводят текст заключённый в них в виде ссылки на удаление собственного профиля на сайте пользователем, в случае если это ему разрешено настройками групп пользователей.

qДобавлен новый раздел “Хранилища” в панели управления DataLife Engine. В данном разделе вы можете добавлять различные системы внешних хранилищ, на которые в дальнейшем будут загружаться файлы с использованием DataLife Engine. Тем самым на сайт может использовать не одно определенное внешние хранилище для файлов, а разные. Причём для разных нужд могут использоваться разные хранилища. В данном разделе вы можете добавлять хранилища, отключать их, назначать какое-либо хранилище, хранилищем по умолчанию и т.д.

qВ настройки скрипта в админпанели добавлена возможность указывать в какие хранилища загружать те или иные файлы. Вы можете настроить разные хранилища для изображений к публикациям, комментариям, статических страниц, аватаров пользователей и т.д. Для всех случаев вы можете задать или хранилище по умолчанию, либо любое другое хранилище, созданное в разделе управления хранилищами.

qВ настройки групп пользователей добавлена возможность разрешать или запрещать пользователям выбирать хранилище непосредственно перед самой загрузкой файлов и изображений. В случае если данная возможность разрешена пользователю, то он сможет выбрать перед загрузкой файлов, в какое хранилище их необходимо разместить. Тем самым разные файлы по желанию могут быть размещены по разным хранилищам. А в случае, если это запрещено, то загрузка будет согласно всем настройкам по умолчанию.

qДля дополнительный полей с типами “Загружаемое изображение”, “Загружаемая галерея изображений”, “Загружаемый аудиоплейлист”, “Загружаемый видеоплейлист”, и “Загружаемый файл” добавлена возможность указания в настройках данных полей в какое хранилище необходимо загружать файлы. Тем самым вы можете загружать разные дополнительные поля в разные хранилища, которые указаны в разделе управления хранилищами.

qДля дополнительных полей профилей пользователей добавлена возможность назначения опции “безопасный режим поля”, при данном типе поля полностью отключается возможность использования BB тегов или HTML тегов. А также данные поля можно будет безопасно использовать при выводе их в атрибутах HTML тегов шаблона.

qПри выводе списка последних комментариев на сайте, добавлен автоматический переход к выбранному комментарию при клике на заголовок новости к которому от относится. При этом автоматически ищется страница, на которой он находится, если, например комментарий находится на второй странице у новости, то пользователь автоматически попадёт на вторую страницу, а также браузер будет автоматически прокручен к данному комментарию. Тем самым пользователь будет видеть его сразу визуально. Для того чтобы добавить автоматический поиск при формировании пользовательских ссылок в шаблоне, вам необходимо добавить к ссылкам атрибут: onclick="findCommentsPage(this, '{id}', '{news-id}'); return false;"

qДобавлена автоматическая маркировка загружаемых пользователем аватаров уникальным значением имени файла аватара. Тем самым при каждой загрузке пользователем аватара для своего аккаунта, его имя будет автоматически меняться, и новый аватар будет виден сразу после загрузки, без использования кэша из браузера. Тем самым больше не требуется очистка кэша браузера при смене аватара пользователем на сайте.

qДобавлена возможность быстрого прикрепления изображений к комментариям, при быстром редактировании комментариев на сайте. В случае если в шаблоне добавления комментария используются теги для вывода быстрой формы загрузки и прикрепления изображений к комментарию, то при редактировании также будет автоматически добавляться форма быстрой загрузки изображений к комментарию.

qДобавлена возможность быстрого прикрепления изображений к комментариям, при ответах на комментарии. В случае если в шаблоне добавления комментария используются теги для вывода быстрой формы загрузки и прикрепления изображений к комментарию, то при ответах на комментарии будет также автоматически добавляться форма быстрой загрузки изображений к комментарию. Тем самым возможности при добавлении нового комментария и при добавлении ответа на комментарий будут идентичны.

qДля пользовательского вывода публикаций с использованием тега {custom …} добавлена возможность пользовательского назначения периода, на который необходимо кешировать блок в параметре cache. Вы можете указывать период в минутах, часах или днях. Для указания времени кеширования используются значения с суффиксами “m”, “h” и “d”. Например, если вы укажите {custom cache="30m" ….} то блок будет принудительно закеширован на 30 минут, если вы укажите {custom cache="2h" ….}, то блок будет кеширован на 2 часа, если указать {custom cache="1d" ….} то блок будет кеширован на один день. Если указать просто {custom cache="yes" ….} то как и ранее будет включён автоматический контроль кеша и он будет обновляться по мере обновления информации. Указание времени принудительного кеширования позволит сэкономить ресурсы сервера если блок нет необходимости обновлять сразу, например, при добавлении новых публикаций или комментариев.

qДля пользовательского вывода комментариев с использованием тега {customcomments …} добавлена возможность пользовательского указания периода, на который необходимо кешировать блок в параметре cache. Вы можете указывать период в минутах, часах или днях. Для указания времени кеширования используются значения с суффиксами “m”, “h” и “d”. Например, если вы укажите {customcomments cache="30m" ….} то блок с комментариями будет принудительно кеширован на 30 минут, если вы укажите {customcomments cache="2h" ….}, то блок с комментариями будет кеширован на 2 часа, если указать {customcomments cache="1d" ….} то блок с комментариями будет кеширован на один день. Если указать просто {customcomments cache="yes" ….} то как и ранее будет включён автоматический контроль кеша и он будет обновляться по мере обновления информации. Указание времени принудительного кеширования позволит сэкономить ресурсы сервера если блок нет необходимости обновлять сразу если меняется информация на сайте.

qДля панели управления DataLife Engine добавлена полная поддержка языков, использующих способ написания текста справа налево. Для этого в языковые пакеты добавлена директива “direction” в которой указывается тип написания текста для данного языка ‘ltr’ либо ‘rtl’. При этом в случае, если используется тип написания справа налево, то DataLife Engine подключит для панели управления специально подготовленный и адаптированный для этого файл CSS со стилями панели управления, который будет корректно зеркально отображать всю панель управления. Тем самым пользователи могут использовать необходимое для данного языка оформление панели.

qДля визуальных редакторов WISYWIG добавлена поддержка языков, использующих написание текста справа налево. Для этого также используется значение директивы “direction”, которая устанавливается в языковых пакетах, при создании перевода на нужный язык. Указав написание справа налево “rtl” в директиве, редакторы автоматически будут использовать данный режим написания текста.

qДля всех обычных текстовых полей, которые DataLife Engine генерирует в панели управления и на сайте добавлена автоматическая поддержка языков, использующих написание справа налево. Переключение происходит автоматически, как только пользователь начинает писать текст на данном языке. Тем самым улучшена и облегчена интеграция и создание сайтов на данных языках.

qВ разделе управления группами пользователей добавлена возможность включать или отключать разрешение на использование модуля “Заголовки, описания, метатеги”. Тем самым вы можете разрешать другим группам пользователей использовать данный раздел, а не только для групп администраторов.

qВ разделе управления группами пользователей добавлена возможность включать или отключать разрешение на использование модуля “Перекрестные ссылки”. Тем самым вы можете разрешать другим группам пользователей использовать данный раздел, а не только для групп администраторов.

qВ разделе управления группами пользователей добавлена возможность включать или отключать разрешение на использование модуля “Редиректы”. Тем самым вы можете разрешать другим группам пользователей использовать данный раздел, а не только для групп администраторов.

qДля модуля “Редиректы” в панели управления, добавлена возможность отключать или включать редиректы. Тем самым при необходимости вы можете временно выключить или включить нужный вам редирект без необходимости их удаления и повторного добавления.

qДля модуля “Перекрестные ссылки” в панели управления, добавлена возможность отключать или включать ключевые слова Тем самым при необходимости вы можете временно выключить или включить замену нужных вам слов без необходимости их удаления и повторного добавления.

qДля модуля “Заголовки, описания, метатеги” в панели управления, добавлена возможность отключать или включать заданные правила. Тем самым при необходимости вы можете временно выключить или включить указанные правила для данных страниц без необходимости их удаления и повторного добавления.

qВ админпанели в разделе редактирования публикаций, добавлено визуальное отображение количества найденных публикаций при использовании расширенного поиска по различным параметрам.

qВ настройки скрипта добавлена возможность указать сколько найденных публикаций показывать в результатах быстрого поиска на сайте. Ранее всегда отображалось только пять найденных результатов, теперь вы можете указать своё необходимое вам значение в настройках.

qВнесены изменения в логику работы быстрого поиска. Теперь результаты поиска, в случае если они не входят в окно по высоте не загораживают непосредственно само поле поиска.

qДля суммарного рейтинга публикаций пользователя добавлено использование нового тега {ratingscore} в шаблонах вывода профиля пользователя и быстрой карточки пользователя (userinfo.tpl и profile_popup.tpl). Данный тег выводит число усреднённого рейтинга всех публикаций пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д. Данный тег позволяет задать, например, собственное оформление звезд рейтинга с частичным заполнением, а не только 2 или 4 заполненных звезды.

qДля суммарного рейтинга комментариев пользователя добавлено использование нового тега {commentsratingscore} в шаблонах вывода профиля пользователя и быстрой карточки пользователя (userinfo.tpl и profile_popup.tpl). Данный тег выводит число усредненного рейтинга всех комментариев пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д. Данный тег позволяет задать, например, собственное оформление звезд рейтинга с частичным заполнением, а не только 2 или 4 заполненных звезды.

qВнесены изменения в работу тега [active] … [/active] для шаблона меню категорий. Теперь данный тег выводит текст, заключённый в них и для родительских категорий, в случае если категория, в которую зашёл посетитель сайта является вложенной субкатегорией данных родительских категорий. Ранее данный тег выводил текст только для одной категории, непосредственно в той в которой находился посетитель. Тем самым вы можете посвечивать в том числе и активные родительские категории.

qДобавлена корректная система подсчёта хеша загружаемых файлов непосредственно по содержанию, в случае их загрузки на внешние хранилища.

qДобавлена поддержка подсчёта цифровой контрольной подписи загружаемых на внешние хранилища файлов, в случае если файл поступает на внешнее хранилища, минуя сервер где установлен DataLife Engine, например если файл загружается с внешнего сайта по URL, а не с компьютера.

qВнесены изменения в логику работы поиска по сайту. Теперь данные на сервер передаются при помощи GET запросов, а не POST. Тем самым посетители сайта при использовании навигации по страницам результатов поиска смогут использовать кнопку “Назад” в браузере, а также перегружать страницу без предупреждений от браузера, а также вы можете оставлять ссылки на результаты поиска и определенные страницы результатов на других сайтах и делится этими страницами.

qДля визуального редактора TinyMCE добавлена возможность при написании комментариев вставлять изображения из буфера обмена и путём переноса картинки в редактор и автоматически их загружать на сервер, в случае если для загрузки комментариев включена и используется упрощённая форма загрузки комментариев. То есть вы можете использовать как упрощённую форму и вставлять в текст редактора, так и автоматически загружать в поле самого текста в редакторе.

qДля визуального редактора TinyMCE добавлена возможность вставки раскрывающихся списков (Accordion), а также возможность управления ими. Данные списки вставляются с использованием HTML5 тегов “details” и “summary”.

qПри просмотре загруженных файлов онлайн на сайте, добавлена возможность просмотра файлов и при включённой настройке блокирования скачивания файлов при обращении с других сайтов. Ранее просмотр становился недоступен т.к. обращение к просмотру сайтов происходили с внешних сервисов Google и Microsoft.

qУлучшена система загрузки файлов на сервер с внешних сайтов. Добавлена возможность загружать файлы в случае, если URL содержит не простые прямые ссылки на файл, а с использованием различных параметров в ссылках.

qУлучшен выбор родительских категорий при создании и редактировании категорий. В случае наличия большого количества категорий их можно найти при помощи быстрого поиска по списку категорий.

qУлучшена система выхода и разлогинивания пользователя на сайте. В случае если пользователь выходит с сайта, то производится полная очистка всех данных с браузера, в том числе и тех что были установлены сторонними плагинами и скриптами на сайте.

qВнесены изменения в логику обработки тегов [if field = "значение"] текст [/if], теперь они выполняются раньше чем происходит подключение и обработка тегов {custom ….} и {include file=”….”}. Тем самым вы можете использовать данные теги внутри этих конструкций, не создавая избыточной нагрузки на сервер и выполняя их только если выполняются условия той конструкции, в которой они находятся.

qПосле загрузки видео или аудио файлов на сервер, ссылка на вставку плеера теперь выбирается по умолчанию при выборе вставки. Тем самым вставка медиафайлов осуществляется быстрее при написании публикаций.

qОбновлена инструкция по созданию приложения на сервисе Google для использования авторизации на сайте при помощи Google аккаунтов.

qПереработана система поиска похожих новостей при редактировании публикаций в панели управления. Теперь система данного поиска учитывает какой режим поиска включён в настройках скрипта: “Простой” или “Полнотекстовый”.

qУвеличена скорость работы поиска похожих новостей в разделе редактирования публикаций при использовании полнотекстового режима поиска на больших базах данных с большим объёмом контента.

qОптимизирована работа с кэшем в панели управления, что в некоторых случаях позволяет более реже очищать кэш некоторых данных при выполнении ряда действий. Тем самым снижается нагрузка на сервер и увеличивается производительность работы сайта.

qУлучшена производительность сайта, в случае выполнения каких-либо автоматических программ по крону. Кеш теперь очищается более точно и только в случае необходимости если какие-либо данные в базе данных были изменены. Тем самым снижается нагрузка на сервер.

qУлучшена система формирования контрольной подписи, необходимой для выполнения различных действий, для пользователей, которые не авторизованы на сайте. Данная подпись больше не зависит от IP пользователей, тем самым им не будет отказано в выполнении действия на сайте, в случае если неожиданно изменился IP адрес между выполнениями действий.

qОбновлён визуальный редактор TinyMCE до актуальной версии. Было исправлены различные небольшие ошибки в работе редактора.

qИсправлена проблема, при которой некорректно обрабатывался тег {THEME} при использовании его в шаблоне вывода результатов быстрого поиска по сайту.

qИсправлена проблема, при которой не обновлялась информация об облаке тегов и перекрёстных ссылках в случае если публикация автоматически снималась с сайта по крону, в случае если истекал установленный срок ее публикации на сайте.

qИсправлена проблема, при которой в некоторых случаях могло некорректно отображаться название кнопки для загрузки видео файлов для дополнительных полей с типом “Загружаемый видео плейлист”.

qИсправлена проблема с некорректным отображением раздела редактирования дополнительных полей публикаций и пользователей в панели управления DataLife Engine.

qИсправлена проблема, при которой вложенные комментарии отображались на один уровень меньше, чем указано в настройке: “Максимальный уровень вложенности комментариев” в панели управления скриптом.

qИсправлена проблема, при которой при отключении комментариев на сайте, переставала корректно работать пользовательская сортировка публикаций по просмотрам на сайте.

Список изменений относительно версии 16.0:

qДобавлена поддержка двухфакторной авторизации с использованием одноразовых паролей из приложения Google Authenticator или любых других приложений, поддерживающих одноразовые OTP пароли. Пользователь может сам выбрать в своём профиле, какую двухфакторную авторизацию он хочет использовать. Он может выбрать использование приложений, либо одноразовый пароль будет отправляться по E-Mail. Для использования могут быть использованы любые приложения, поддерживающие OTP верификацию, включая встроенные средства операционных систем смартфонов, а не только Google Authenticator.

qДобавлена поддержка нового типа капчи на сайте Cloudflare Turnstile Sites. Данный тип капчи обеспечивает наиболее качественную защиту от спам ботов, а также работает максимально комфортно для посетителей сайта, которым не потребуется делать выбор надоедливых картинок, или написания текста. Все максимально просто, автоматически и быстро.

qДобавлена возможность ограничивать количество скачиваний для загруженных на сайт файлов. Для этого в настройках групп пользователей, вы можете для данной группы указать сколько файлов в день им разрешено скачивать. При этом ведётся учёт скачиваний именно уникальных файлов, а не просто попыток скачиваний. Например, вы разрешили скачивать пять файлов в день, посетитель скачал пять файлов, и ему будет запрещено скачивать какие-либо другие файлы после этого, но если при скачивании какой то файл был повреждён или случайно удалён, то эти файлы, которые он уже скачивал, он также может скачать без проблем повторно. Если вы не хотите устанавливать лимит на скачивание, то данное ограничение можно также отключить.

qДобавлен новый тип дополнительных полей для публикаций: “Загружаемый видео плейлист”. В данном поле вы можете быстро загружать видео файлы, которые будут выводится на сайте в виде готового видео плеера со списком загруженных файлов для их воспроизведения. Тем самым вы можете быстро и удобно организовывать публикацию видео на своём сайте. В свойствах поля вы можете задать максимальное количество загружаемых файлов, а также максимальный размер файла допустимый к загрузке.

qДобавлен новый тип дополнительных полей для публикаций: “Загружаемый аудио плейлист”. В данном поле вы можете быстро загружать аудио файлы, которые будут выводится на сайте в виде готового аудио плеера со списком загруженных файлов для их воспроизведения. Тем самым вы можете быстро и удобно организовывать публикацию аудио файлов на своём сайте. В свойствах поля вы можете задать максимальное количество загружаемых файлов, а также максимальный размер файла допустимый к загрузке.

qДля системы быстрого поиска на сайте добавлена поддержка полнотекстового поиска. Теперь быстрый поиск на сайте в зависимости от того, что включено в настройках также будет использовать либо полнотекстовый, либо простой поиск. Тем самым результаты при быстром поиске не будут отличаться от результатов от раздела полного поиска на сайте, если был включён полнотекстовый режим поиска на сайте.

qДля быстрого поиска на сайте добавлена поддержка системы шаблонов. Теперь для вывода результатов поиска используется новый файл шаблона fastsearchresult.tpl в котором вы можете использовать все без исключения теги, которые поддерживает шаблон вывода кратких новостей. Тем самым вы можете выводить и дополнительные поля, и оформлять результаты так, как вам хочется без каких-либо ограничений.

qПри редактировании комментариев на сайте, в случае если осуществляется вывод загруженных изображений с использованием тега {images} в комментариях, добавлен вывод списка загруженных изображений для быстрого удаления изображений из редактируемого комментария.

qДобавлен вывод загруженных изображений для комментариев в админпанели в разделе редактирования комментариев. Тем самым вы можете сразу видеть изображения, если в шаблоне для них используется отдельный тег вывода и их нет в тексте комментария. А также вы можете быстро удалить при необходимости загруженные изображения в один клик.

qВ настройки скрипта добавлена возможность указывать свойства RSS потоков, которые используются на сайте. Данные свойства используются для определения какие теги допустимы в потоке, их стандарты и прочее. Вы можете указать свойства для всех трех потоков, используемых на сайте. Данные свойства необходимы различным сервисам использующие данные потоки в своей работе, тем самым в случае, если у какого-то сервиса изменились требования к RSS потокам, вы можете самостоятельно указать в настройках нужные параметры без необходимости ждать обновлений DataLife Engine или самому править файлы скрипта. Также вы можете использовать потоки вообще для каких-то других собственных сервисов, и задавать необходимые параметры самостоятельно.

qВ настройки скрипта в админпанели добавлена возможность скрывать поле краткого описания при добавлении и редактировании публикаций. Вы можете отключить данное поле, если не пользуетесь им при написании публикаций, чтобы оно вам не мешало. Данное нововведение будет полезно тем, кто использует, например только дополнительные поля со своими свойствами.

qВ настройки скрипта в админпанели добавлена возможность скрывать поле полного описания при добавлении и редактировании публикаций. Вы можете отключить данное поле, если не пользуетесь им при написании публикаций, чтобы оно вам не мешало. Данное нововведение будет полезно тем, кто использует, например только дополнительные поля со своими свойствами.

qДля шаблона добавления новостей (addnews.tpl) добавлена поддержка новых тегов: [allow-shortstory] текст [/allow-shortstory] которые выводят текст заключённый в них в случае, если в настройках скрипта включена поддержка поля краткого описания, и скрывают текст в случае данное поле отключено. Также добавлены теги: [allow-fullstory] текст [/allow-fullstory] которые выводят текст заключённый в них в случае, если в настройках скрипта включена поддержка поля полного описания, и скрывают текст в случае данное поле отключено.

qДобавлена возможность сортировки публикаций по дате их редактирования. Порядок сортировки может быть выполнен в настройках скрипта в панели управления, на сайте самим пользователем если это разрешено, а также в настройках каждой категории отдельно.

qДобавлена возможность сохранять резервные копии базы данных на внешнее хранилище. Для этого в настройках скрипта вы можете включить настройку “Сохранять резервные копии на внешнее хранилище”. При включении данной опции резервная копия будет автоматически переноситься на внешнее хранилище.

qДобавлена возможность автоматически конвертировать загружаемые изображения в один выбранный формат в настройках скрипта формат. Вместо настройки автоматического конвертирования загружаемых изображений в формат WebP, вы можете выбрать один из четырех форматов: PNG, JPG, WEBP, AVIF. Либо вы можете вообще отключить автоматическое конвертирование в другой формат и изображение будет оставаться в том формате, в котором оно изначально.

qДобавлена возможность использовать для отложенной загрузки изображений не только средства jаvascript, но и нативную поддержку браузером. Теперь в настройках скрипта вы можете выбрать тип отложенной загрузки: Отключена, включена с использованием jаvascript и включена с использованием нативной поддержкой браузером. Нативная поддержка браузером работает точнее и быстрее, не требует загрузки на страницу дополнительных скриптов, но при этом поддерживается только современными браузерами. Не все посетители вашего сайта могут иметь такие браузеры. В случае использования пользователем старого браузера, изображение он будет видеть в любом случае, однако отложенная загрузка для него не будет работать.

qДля тегов вывода изображений и встроенных фреймов (img и iframe) добавлена возможность добавлять атрибут loading="lazy" при добавлении публикаций. Для добавления нативной отложенной загрузки изображений и фреймов, браузерами, которые поддерживают данный атрибут.

qДобавлена поддержка новых глобальных тегов: [category-description] текст [/category-description], которые выводят текст заключённый в них если просматриваемая категория имеет заданное описание категории. А также добавлена поддержка тегов: [not-category-description] текст [/not-category-description], которые выводя текст заключённый в них, если категория не имеет описания. Данные теги будут полезны при оформлении различных блоков шаблона для случаев, когда описание задано, и для случаев, когда описание отсутствует.

qДля пользователей, находящихся в группе “Главные редакторы”, добавлена возможность менять автора публикаций. Ранее такая возможность была только у администраторов сайта.

qДля системы плагинов добавлена возможность указывать несколько плагинов, которые обязательны присутствовать в системе для работы устанавливаемого плагина. Для назначения нескольких плагинов, их имена перечисляются через запятую. Ранее можно было указать только один обязательный плагин.

qДобавлено автоматическое переключение на тёмную тему в панели управления DataLife Engine (в случае если включено автоматическое включение ночного режима) в зависимости от установленной темы операционной системы. Теперь переключение будет не только по времени, но и в случае, если тема операционной системы была переключена на тёмную, то также будет произведено переключение и в панели управления.

qДля шаблона вывода RSS добавлена поддержка нового тега {full-story limit="X"} который выводит текст полной новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов. Данный тег будет полезен если сайт добавляется в сервис Дзен Новости (Яндекс новости), совместно с использованием тега <yandex:full-text>.

qПри использовании сравнения с использованием тегов [if field = "значение"] текст [/if] для дополнительных полей с типом “дата” а также “дата и время” добавлена автоматическая проверка именно как значения даты. При сравнении вы можете использовать дату в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, а также использовать не только знак равенства, но и проверять больше ли дата или меньше указанного значения. Ранее данный тип полей сравнивался просто как текстовое значение.

qУлучшена система сравнения с использованием тегов [if field = "значение"] текст [/if] при использовании в сравнении значения дополнительных полей. Проводится дополнительная конвертация ранее экранированных символов в обычные символы, что упрощает сравнение.

qУпрощена система расширенной регистрации на сайте, посетителю при регистрации потребуется меньше шагов при прохождении расширенной регистрации на сайте.

qДля шаблонов вывода кратких и полных новостей, а также для шаблона главной страницы (shortstory.tpl, fullstory.tpl, main.tpl) добавлена поддержка новых тегов: [xfvalue_X video="Nr"] который выводит загруженные для дополнительного поля с типом "Видео плейлист" видео c выбранным номером по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста, [xfvalue_X video-url="Nr"] который выводит загруженные для дополнительного поля с типом "Видео плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста, [xfvalue_X video-description="Nr"] который выводит загруженные для дополнительного поля с типом "Видео плейлист" описания видео, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста. [xfgiven_X video="Nr"] текст [/xfgiven_X video="Nr"] которые выводят текст заключённый в них если видео с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер видео, [xfnotgiven_X video="Nr"] Текст [/xfnotgiven_X video="Nr"] которые выводят текст заключённый в них если видео с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер видео. Все данные теги будут полезны при использовании собственных сторонних видео плееров, для организации видео просмотра на своём сайте.

qДля шаблонов вывода кратких и полных новостей, а также для шаблона главной страницы (shortstory.tpl, fullstory.tpl, main.tpl) добавлена поддержка новых тегов: [xfvalue_X audio="Nr"] который выводит загруженные для дополнительного поля с типом "Аудио плейлист" видео по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста, [xfvalue_X audio-url="Nr"] который выводит загруженные для дополнительного поля с типом "Аудио плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста, [xfvalue_X audio-description="Nr"] который выводит загруженные для дополнительного поля с типом "Аудио плейлист" описания аудио файла, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста. [xfgiven_X audio="Nr"] текст [/xfgiven_X audio="Nr"] которые выводят текст заключённый в них если аудио с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла, [xfnotgiven_X audio="Nr"] Текст [/xfnotgiven_X audio="Nr"] которые выводят текст заключённый в них если аудио с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла. Все данные теги будут полезны при использовании собственных сторонних аудио плееров, для организации аудио просмотра на своем сайте.

qИзменено формирование мета тега заголовка (Title) страницы при показе главной страницы в случае, если установлено использование статической страницы main в качестве главной страницы. Теперь в заголовке используются только основной заголовок, указанный в настройках скрипта в панели управления.

qУлучшена система быстрого редактирования комментариев на сайте и в панели управления. В случае возникновения какой-либо ошибки, пользователю будет выведено сообщение об ошибке в всплывающем окне, при этом сохранится возможность внесения дальнейших изменений в комментарий для устранения возникших ошибок.

qУлучшена поддержка дополнительный полей, имеющих тип “Одна строка” c опцией безопасного режима. Для данных полей добавлена возможность использования URL в качестве контента, и они могут использоваться для вставки ссылок в публикациях.

qВнесены изменения, направленные на предотвращение возникновения ссылок на публикации, длина которых превышает суммарный лимит на длину URL установленными стандартами в 255 символов.

qОбновлена система показа уменьшенных копий изображений. Внешний вид стал ещё более современным, добавлена более плавная анимация, больше уровней масштабирования.

qДобавлено использование более крипто безопасных алгоритмов в различных генераторах случайных значений, используемых различными функциями идентификации пользователей.

qДля визуального редактора TinyMCE добавлена возможность установить размер текста быстро и удобно в любых величинах, а не только из списка предопределенных размеров.

qДля визуального редактора Froala добавлена возможность использования в текстах любых шрифтовых иконок, а не только FontAwesome старых версий.

qСущественно ускорена работа DLE и снижена нагрузка на сервер при формировании RSS потоков для Турбо страниц и Яндекс Дзена.ли остатки HTML сущностей в данные ссылки.

qПри написании дополнительных полей в публикации с опцией “Перекрестные ссылки”, в случае если тег был написан с использованием разного регистра букв, то и при выводе данного поля в хлебных крошках и метатегах заголовка будет использовано слово с тем же регистром букв как оно и было написано в публикации, а не маленькими буквами как было ранее. URL при этом остаётся как и ранее неизменным.

qПри написании слов для облака тегов в публикации, в случае если тег был написан с использованием разного регистра букв, то и при выводе данного тега в хлебных крошках и метатегах заголовка будет использовано слово с тем же регистром букв как оно и было написано в публикации, а не маленькими буквами как было ранее. URL при этом остаётся как и ранее неизменным.

qМинимальным требованием для работы DLE установлено наличие на сервере PHP 8.0 и выше. Ранее минимальной версией PHP являлось 7.4. Помимо этого были снижены рекомендуемые требования к версии PHP, теперь для работы всех функций DLE также достаточно иметь линейку PHP 8.0.x, а не 8.1.x

qОбновлён визуальный редактор TinyMCE до актуальной линейки.

qИсправлена проблема, при которой объединение комментариев было в одну строку, при использовании редактора BBCODES для комментариев.

qИсправлена проблема, при которой появлялись лишние строки при массовом объединении комментариев на сайте, в случае использования визуальных редакторов для комментариев.

qИсправлена проблема, при которой при изменении поисковой строки в поиске не происходил возврат на первую страницу поиска, если пользователь находится не на первой странице и использует только клавиатуру.

qИсправлена проблема, при которой некорректно работал тег {related-ids} в шаблоне полной новости, при первом показе публикации на сайте.

qИсправлена проблема, при которой не работала проверка некоторых полей в теге [if field = "значение"] текст [/if] при подключении пользовательского вывода публикаций с использованием тега {custom …}

qИсправлена проблема, при которой невозможно было добавить в некоторых случаях новые ключевые слова в облако тегов при выполнении массовых действий над новостями.

qИсправлена проблема, при которой могли в некоторых случаях не нажиматься некоторые кнопки в редакторе BBCODES при быстром редактировании публикаций на сайте.

qИсправлена проблема, при которой формировалась не валидная вёрстка в случае использования древовидной вёрстки комментариев, если при этом достигался лимит вложенности комментариев.

qИсправлена проблема, при которой могла не происходит разблокировка кнопки загрузки изображений для дополнительных полей с типом “Галерея изображений”, при переносе изображения из одной галереи в другую.


Установка скрипта

Навигация: Работа с движком >

Установка скрипта

Установка скрипта на сервер

Установка скрипта на сервер проходит в автоматическом режиме и не должная вызывать особых проблем, но вам необходимо выполнить некоторые действия по настройке прав доступа на папки.

1.Для начала скопируйте все файлы из папки upload в данном архиве на ваш сервер.

2.Установите права для записи (CHMOD 777) для папок backup, templates, uploads, engine/data, engine/cache.

3.Наберите в URL вашего браузера адрес вашего сайте, например http://адрес вашего сайта/ и следуйте его инструкциям.

Внимание: чистая установка скрипта приводит к удалению данных ранее установленного скрипта DLE, для обновления установленного скрипта читайте инструкцию по обновлению.

Автоматический инсталлятор проверит все необходимые файлы и настроит подключение к базе данных. После завершения установки вы сможете посмотреть работу скрипта на демонстрационной странице http://адрес вашего сайта/ Для доступа к админпанели необходимо запустить http://адрес вашего сайта/admin.php


Обновление скрипта

Навигация: Работа с движком >

Обновление скрипта

Начиная с версии 13.0 для DataLife Engine доступно два типа обновления. Ручное и автоматическое. В случае если вашем сайте установлена версия ниже 13.0 вам необходимо воспользоваться ручным обновлением. В случае если на вашем сайте стоит версия 13.0 и выше вы можете воспользоваться как автоматическим так и ручным обновлением.

Автоматическое обновление:

В админпанели вашего сайта, на главной странице, нажмите на кнопку "Проверить обновления" и в случае наличия новой версии, нажмите на ссылку обновления скрипта, далее следуйте инструкциям на вашем сайте. Также вы можете сразу перейти в админпанели в раздел обновления по адресу http://вашсайт/admin.php?mod=upgrade и следовать дальнейшим инструкциям. По завершению обновления внесите необходимые изменения в ваши шаблоны, согласно списку изменений, опубликованному на сайте по адресу: https://dle-news.ru/templates-changelog.html

Ручное обновление:

1.Создайте резервную копию базы данных и всех файлов скрипта на сервере.

2.Обновите все файлы находящиеся на вашем сервере на файлы из папки /upload/ архива дистрибутива (за исключением шаблонов из папки /templates/). Внимание: Файлы из архива дистрибутива, нужно заливать на сервер поверх существующих, а не удалять предварительно папки на сервере.

3.Войдите в админпанель вашего сайта как администратор и следуйте дальнейшим инструкциям.

4.Внесите необходимые изменения в ваши шаблоны, согласно списку изменений, опубликованному на сайте по адресу: https://dle-news.ru/templates-changelog.html


Начало работы и шаблоны

Навигация: Работа с движком >

Начало работы и шаблоны

Одной из особенностей движка является то, что в него можно подключить любой существующий дизайн не испытывая при этом каких-либо ограничений. Движок поддерживает работу с несколькими шаблонами одновременно. Все шаблоны находятся в папке /tеmplates/. Каждая вложенная папка в этой папке является отдельным макетом сайта. Поэтому если вы скачали новый скин для движка просто скопируйте его в папку и разрешите его использование в админ панели. Также вы можете разрешить смену дизайна для посетителей вашего сайта и они сами смогут выбрать, как будет выглядеть их любимый сайт. Также вы можете установить количество новостей, выводимых на страницу, для этого зайдите в настройки скрипта и установите соответствующий параметр.

Внимание: В файлах шаблона вы можете использовать обычный html текст, либо можете использовать специальные теги, для вставки тех или иных возможностей, прочитать подробнее о допустимых тегах вы сможете в данном руководстве ниже в разделе Шаблоны.


Главные и глобальные теги для шаблонов

Навигация: Работа с движком >

Главные и глобальные теги для шаблонов

Основной макет вашей страницы находится в файле шаблона main.tpl именно этот файл скрипт DLE подгружает в первую очередь и к нему подключаются все другие компоненты движка. Остановимся на основных из них. {AJAX}, {info}, {content}, {custom} именно эти теги отвечают за правильный вывод новостей.

Тег {AJAX} выводит служебные скрипты JavaScript необходимые для нормальной работы движка в целом и технологии AJAX в частности. Рекомендуется размещать в самом начале шаблона после тега <body>

Тег {info} выводит служебную информацию и ошибках о произведенных действиях (например "Вход не выполнен, неверный пароль" или "Необходимо заполнить все поля") рекомендуется устанавливать перед тегом {content}

Тег {content}, отвечает за непосредственный вывод статей и прочих встроенных модулей в движок

Тег {tags}, отвечает за вывод облака тегов (специальных ключевых слов добавленнных в новость)

Теги [sort]{sort}[/sort], отвечают за вывод выбора пользователем порядка сортировки новостей, если это разрешено в настройках скрипта

Глобальные теги, которые можно применить ко всем шаблонам:

Тег {custom}, отвечает за вывод статей в пользовательском формате, имеет следующие параметры:

{custom name="X" id="1,2,5-8" category="2,3,5-8" author="x" days="x" template="custom" available="global" navigation="no" from="0" limit="10" fixed="yes" unique="yes" order="date" sort="desc" cache="yes"}

Где

name это имя блока, которое в дальнейшем может использоваться для определения необходимости показывать или скрывать какой либо контент за пределами этого блока если в данном блоке есть контент или он отсутствует. Например, написание {custom name="block1" category="6"} покажет публикации из категории ID 6, а сам блок получить имя “block1”. Для оперирования с данным именем используются теги: [custom=X] Текст [/custom] где X это имя блока, которые выводят текст заключённый в них в случае, если блок с данным именем содержит информацию. А также добавлены противоположные теги [not-custom=X] Текст [/not-custom] которые выводят текст заключённый в них в случае, если блок с данным именем не содержит никакой информации и публикаций нет. Таким образом вы можете делать дополнительное внешнее оформление блоков или наоборот скрывать его в зависимости от того есть публикации в блоке или нет. Например, [custom=block1] Заголовок {custom name="block1" category="6"} [/custom]. При этом сам блок, может быть, в любом месте на странице и не обязательно внутри данных тегов. Тем самым вы можете адаптировать и менять другое оформление в шаблоне на основе данных тегов.

id это список ID новостей которые вы хотите вывести, разделяются запятой без пробелов. Также вы можете указывать диапазон ID новостей при помощи тире. Например 1,4-8,11 выведет новости c ID 1, новости имеющих id c 4 по 8, а также с ID 11.

idexclude полностью противоположен параметру id="список id новостей" и позволяет вывести новости, которые не принадлежат указанным в параметре id. Например, {custom idexclude="5-10"} выведет все новости, id которых не принадлежит диапазону от пяти до десяти.

category это список ID категорий, из которых производить выборку новостей, разделяются запятой без пробелов. Также вы можете указывать диапазон категорий при помощи тире. Например 1,4-8,11 выведет новости из категории 1, категорий имеющих id c 4 по 8, а также из категории 11.

categoryexclude полностью противоположен параметру category="список категорий" и позволяет вывести новости, которые не принадлежат указанным в параметре категориям. Например, {custom categoryexclude="2,7"} выведет все новости которые не принадлежат категориям и id 2 и 7.

tags это список ключевых слов из облака тегов, назначенных новостям. Например тег {custom tags="новости,шаблоны"} выведет все новости, которые содержат ключевые слова из облака тегов "новости" и "шаблоны".

template файл шаблона который будет использоваться при выводе новостей в данном случае это будет custom.tpl если вы используете на сайте несколько шаблонов то данный файл должен присутствовать в каждом шаблоне. В данном шаблоне используются теги аналогичные для короткой новости.

available раздел в котором будет выводится запрашиваемые новости, может принимать следующие значения:

main - на главной странице

date - при просмотре новостей за определенные даты

cat - при просмотре категории

showfull - при просмотре полной новости

search - при просмотре результатов поиска

userinfo - при просмотре профиля

register - при регистрации

stats - при просмотре статистики

pm - при просмотре персональных сообщений

feedback - при просмотре обратной связи

favorites - при просмотре закладок

newposts - при просмотре новых сообщений

addnews - при добавлении новости

lastnews - при просмотре последних новостей на сайте

lastcomments - при просмотре последних комментариев

lostpassword - при восстановлении пароля от аккаунта на сайте

static - при просмотре статических страниц

catalog - при просмотре каталога страниц

alltags - при просмотре облака тегов

tags - при просмотре новостей из облака тегов

allnews - при просмотре всех новостей на сайте или всех новостей какого либо пользователя

Вы можете комбинировать разделы при помощи "|", например available="userinfo|register|main" будет выводить ваши новости на главной, при регистрации и при просмотре профиля пользователя. Если нужно отображать во всех разделах сайта, то данный параметр не указывается.

from номер новости с которой начнется вывод

limit сколько новостей будет выведено

order критерий сортировки новостей, может принимать следующие значения:

date - сортировка новостей по дате публикации

editdate - сортировка новостей по дате редактирования

rating - сортировка новостей по рейтингу

reads - сортировка новостей по количеству просмотров

comments - сортировка новостей по количеству комментариев

title - сортировка новостей по заголовкам новостей

rand - сортировка новостей в случайном порядке

id_as_list - сортирует публикации так как они указаны в списке для ID публикаций. Например, тег {custom id="3,4,1,2" order="id_as_list"} выведет сначала новость c ID 3 потом 4 потом 1 потом 2.

lastviewed - вывод последних просмотренных пользователем публикаций

sort указывает порядок сортировки публикаций. При использовании значения desc публикации сортируются по убыванию, а при использовании asc по возрастанию.

author логин автора новости, при указании данного параметра будут выводится только новости указанного автора. Допускается перечисление через запятую нескольких авторов. Например, тег {custom author="admin" limit="5"} выведет 5 новостей автора с логином "admin".

authorexclude указывает логины авторов, которые необходимо исключить из показа. Логины авторов в данном параметре также можно перечислять через запятую. Например, при использовании {custom authorexclude="admin,test"} будут выведены новости всех авторов, кроме авторов с логином "admin" и логином "test".

catalog выводятся все публикации содержащие указанный в параметре символьный код. Допускается также перечисление символьных кодов в параметре через запятую. Например, при использовании {custom catalog="а,б"} будут выведены новости, которые содержат символьные коды "а" или "б".

catalogexclude выводятся все публикации, которые не содержат указанный в параметре символьный код. Допускается также перечисление символьных кодов в параметре через запятую. Например, при использовании {custom catalogexclude="а,б"} будут выведены новости, которые не содержат символьные коды "а" и "б".

xfields выводятся все публикации, содержащие указанное в параметре значение дополнительных полей новостей. Допускается также перечисление значений в параметре через запятую. Например, при использовании {custom xfields="значение 1,значение 2"} будут выведены новости, в которых есть дополнительные поля содержащие "значение 1" или "значение 2".

xfieldsexclude выводятся все публикации, не содержащие указанное в параметре значение дополнительных полей новостей. Допускается также перечисление значений в параметре через запятую. Например, при использовании {custom xfieldsexclude="значение 1,значение 2"} будут выведены новости, в которых нет дополнительных полей содержащих "значение 1" и "значение 2".

days указывает временной период, где x это количество дней за которые выводить публикации. Например, тег {custom days="2" limit="5"} выведет 5 новостей за 2 последних дня.

banners принимает значения yes или no. Данный параметр включает или отключает вывод рекламных материалов, которые назначены для вывода между публикациями. По умолчанию если данный параметр отсутствует в теги, вывод рекламных материалов между публикациями будет отключён.

futureannounce принимает значения yes или no. Данный параметр работает совместно с параметром days="X", и указывает что публикации нужно брать из будущих дат. Например, тег {custom futureannounce="yes" days="1"} означает что необходимо вывести публикации, дата которых назначена на завтра, т.е. на +1 дней, а тег {custom futureannounce="yes" days="2"} выводит публикации дата которых назначена на завтра и послезавтра, и т.д. Данных параметр будет полезен вебмастерам, для вывода грядущих анонсов на своём сайте.

cache принимает значения yes или no - устанавливает кешировать вывод или нет, рекомендуется кешировать для снижения нагрузки. Вы можете указывать период в минутах, часах или днях. Для указания времени кеширования используются значения с суффиксами “m”, “h” и “d”. Например, если вы укажите {custom cache="30m" ….} то блок будет принудительно закеширован на 30 минут, если вы укажите {custom cache="2h" ….}, то блок будет кеширован на 2 часа, если указать {custom cache="1d" ….} то блок будет кеширован на один день.

navigation принимает значения yes или no - устанавливает использовать вывод навигации по страницам или нет. Навигация выводится только для страниц сайта, которые поддерживают навигацию для тега {content}, например, главная страница, страницы категорий и т.д. Если же страница не поддерживает навигации, например, вывод полной новости, или статической страницы, то для данного тега навигация автоматически также будет отключена независимо от указанного значения.

fixed принимает значения yes, no, only или without - устанавливает учитывать ли при выводе публикаций, то что новости были зафиксированы или нет. В случае если указано yes, то зафиксированные новости будут выведены в начале, если no, то зафиксированные новости будут выводится в общем списке новостей без учета данного параметра. В случае если указано значение only, то будут выводится только зафиксированные новости. В случае если указано значение without, то зафикисрованные новости не будут вообще выводится.

sortbyuser="yes" принимает только одно значение, и разрешает возможность использования пользовательской сортировки [sort]{sort}[/sort] для данного блока публикаций.

unique="yes" принимает только одно значение, и указывает что публикации в этом блоке не должны повторятся если они уже выводились на сайте, т.е. в данном блоке нужно выводить уникальные публикации. Это позволить избегать в блоках пользовательского вывода публикаций повторения одних и тех же новостей, если они подпадают под одни и те же критерии вывода. Например теги два тега {custom category="1" unique="yes" limit="1"} и {custom category="1" unique="yes" limit="1"} выведут разные публикации, несмотря на одни и те же параметры, первый тег выведет первую новость из категории, а второй уже вторую, пропустив первую. Также если публикация выводилась в блоке {content} она также не будет выводится при наличии данной опции в теге {custom ….}.

favorites="yes" принимает только одно значение, и выведет публикации которые находятся у посетителя в закладках. Например, тег {custom favorites="yes" order="id_as_list”} выведет публикации из закладок пользователя в том порядке сортировки, в котором он их вносил в закладки.

Внимание все параметры данного тега являются необязательными, необходимо указать только как минимум один любой параметр, все остальные параметры, если они не заданы, будут взяты из общих настроек скрипта. Например:

{custom id="1,2" order="date"} - выведет новости с ID 1 и 2 и отсортирует их по дате

{custom category="2,7" from="5" cache="yes"} - выведет новости из категорий 2 и 7 при этом количество новостей будет взято из настроек скрипта, а выборка будет осуществляться после 5 новости, отвечающей данному условию

{custom order="date" from="9" limit="5"} - выведет 5 последних новостей, начиная с десятой новости

Помните что каждое использование этого тега создает дополнительную нагрузку на базу данных, т.к. идет дополнительная выборка, поэтому используйте ее с умом если необходимо экономить на ресурсах.

Тег [available=раздел] текст [/available], выводит текст заключенный в теги если просматривается указанный раздел сайта:

Тег принимает параметры аналогичные параметру available тега {custom}. Вы можете комбинировать разделы при помощи "|", например userinfo|register|main

Для примера:

[available=userinfo|register|main] текст [/available]

будет выводить текст заключенный в теги, на главной, при регистрации и при просмотре профиля пользователя.

Внимание вы можете задать также тег [not-available=userinfo|register|main] текст [/not-available] который полностью противоположен тегу aviable и выводить текст везде кроме перечисленных разделов.

Тег [category=X]текст[/category], выводит текст заключенный в теги если просматривается указанная категория:

Тег принимает в качестве параметра ID категории, и допускает перечисление нескольких категорий

[category=1,2,3,7-10] текст [/category]

будет выводить текст заключенный в теги, если посетитель просматривает категории у которых ID равен 1 или 2 или 3, а также с 7 до 10.

Внимание вы можете задать также тег [not-category=1,2,3,7-10] текст [/not-category] который полностью противоположен тегу category и выводить текст везде кроме перечисленных категорий.

Тег [group=X]текст[/group], выводит текст заключенный в теги если пользователь принадлежит указанной группе пользователей:

Тег принимаем в качестве параметра ID группы, и допускает перечисление нескольких групп

[group=1,2,3] текст [/group]

выводят текст заключенный в теги, если посетитель является администратором, главным редактором или журналистом.

Внимание вы можете задать также тег [not-group=1,2,3] текст [/not-group] который полностью противоположен тегу group и выводить текст для всех, кроме перечисленных групп.

[country=X] текст [/country]

выводят текст, указанный в них, если посетитель находится в указанных X странах, где X это список ISO кодов стран. Страны можно перечислять через запятую. Например, теги [country=RU, BY, KZ] текст [/country] выведут текст если посетитель из России, Беларуси или Казахстана.

[not-country=X] текст [/not-country]

выводят текст, указанный в них, если посетитель находится не в указанных X странах, где X это список ISO кодов стран. Например, [not-country=RU, BY, KZ] текст [/not-country] выведут текст если посетитель не из России, Беларуси или Казахстана, а из любых других стран.

{country}

выведет ISO код страны, в которой находится посетитель сайта, например, выведет RU если посетитель находится в России, или US если посетитель находится в США.

[page-count=1,2,3] текст [/page-count]

Будет выводить текст заключенный в них, если пользователь находится на определенной по номеру страницы в навигации по новостям, независимо от раздела сайта, где 1,2,3 это номера страниц в навигации. Данный тег позволит очень гибко настроить вывод той или иной информации, на определенной странице и полезен для информационных блоков и рекламы. Вы можете использовать данный тег совместно с другими, опеределяющими разделы сайта и категории.

Например, комбинация тегов [aviable=cat][category=1][page-count=1] текст [/page-count][/category][/aviable] выведут текст, только если пользователь просматривает первую страницу категории с id1, и при этом просматривает именно краткие новости, и при переходе на другую страницу в этой категории, данного текста он уже не увидит.

[not-page-count=1,2,3] текст [/not-page-count]

Выводит текст опубликованный в тегах на любых номерах страниц кроме указанных в теге.

{banner_имя} этот тег предназначен для вывода рекламной информации на сайте. Само имя для баннера задается в специальном модуле в админпанели.

[banner_имя] текст [/banner_имя] выводят текст заключенных в них, если указанный баннер выводится на странице сайта.

{inform_имя} этот тег предназначен для вывода RSS информеров и новостей с других сайтов. Имя и все настройки для данного тега устанавливаются в админпанели скрипта.

[static=имя страницы] текст [/static]

будет выводить текст заключенный в теги, если посетитель просматривает статическую страницу с указанным именем. Допускается также перечесление страниц в теге через запятую. Например [static=test1,test2,test3] текст [/static] будет выводить текст на страницах test1, test2 и test3

[not-static=имя страницы] текст [/not-static]

будет выводить текст заключенный в теги, если посетитель не просматривает статическую страницу с указанным именем. Допускается также перечесление страниц в теге через запятую.

[smartphone] текст [/smartphone]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт с мобильного телефона.

[not-smartphone] текст [/not-smartphone]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт не с мобильного телефона.

[tablet] текст [/tablet]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт с планшета.

[not-tablet] текст [/not-tablet]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт не с планшета.

[desktop] текст [/desktop]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт со стационарного компьютера или ноутбука.

[not-desktop] текст [/not-desktop]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт не со стационарного компьютера или ноутбука.

[ios] текст [/ios]

выводят текст заключенных в них, в случае если устройство посетителя сайта использует операционную систему iOS от Apple

[not-ios] текст [/not-ios]

выводят текст заключенных в них, в случае если устройство посетителя сайта не использует операционную систему iOS

[android] текст [/android]

выводят текст заключенных в них, в случае если устройство посетителя сайта использует операционную систему Android от Google

[not-android] текст [/not-android]

выводят текст заключенных в них, в случае если устройство посетителя сайта не использует операционную систему Android

Также вы можете подключать один шаблон в другой, используя тег {include file="my_block.tpl"} данный тег подключает указанный файл my_block.tpl в шаблон. Тег призван облегчить структуру шаблона, если используется сложная верстка со множеством тегов.

{customcomments id="1,2,5-8" category="2,3,5-8" author="x" days="x" template="custom" available="global" from="0" limit="10" order="date" sort="desc" cache="yes"}

Выводит комментарии в любом месте сайта в пользовательском формате. Данный тег является вспомогательным дополнительным выводом комментариев, и может, например, использоваться для вывода последних комментариев на главной странице сайта в блоке и т.д.

Данный тег может принимать следующие параметры:

id - список ID комментариев, которые вы хотите вывести, разделяются запятой без пробелов. Также вы можете указывать диапазон ID комментариев при помощи тире. Например, 1,4-8,11 выведет комментарии c ID 1, комментарии имеющие id c 4 по 8, а также с ID 11.

newsid – список ID новостей, из которых вы хотите вывести комментарии, разделяются запятой без пробелов. Также вы можете указывать диапазон ID новостей при помощи тире. Например, 1,4-8,11 выведет комментарии из публикаций c ID 1, имеющих id c 4 по 8, а также с ID 11.

newsidexclude - список ID новостей, из которых вы не хотите выводить комментарии, разделяются запятой без пробелов. Также вы можете указывать диапазон ID новостей при помощи тире. Например, 1,4-8,11 выведет комментарии из всех публикаций кроме ID 1, имеющих id c 4 по 8, а также с ID 11.

category - список ID категорий новостей, из которых производить выборку комментариев, разделяются запятой без пробелов. Также вы можете указывать диапазон категорий при помощи тире. Например 1,4-8,11 выведет комментарии из категории 1, категорий имеющих id c 4 по 8, а также из категории 11.

categoryexclude - полностью противоположен параметру category="список категорий" и позволяет вывести комментарии, новости которых не принадлежат указанным в параметре категориям. Например, {customcomments categoryexclude="2,7"} выведет все комментарии у новостей, которые не принадлежат категориям и id 2 и 7.

subcat указывает необходимо ли включать в выборку также публикации, находящиеся в подкатегориях или нет. Данный параметр может принимать следующие значения: subcat="yes" который указывает, что также нужно выбрать все публикации находящиеся и в подкатегориях указанной категории, а также значение subcat="only" который указывает, что нужно выбрать публикации только из подкатегорий, без учета указанной категории. Например, у вас на сайте есть категории с ID 1, 2 и 3. Категории 2 и 3 при этом являются подкатегориями первой. При использовании тега {custom category="1" subcat="yes"} будут выбраны все новости, из категорий 1, 2 и 3. А при использовании тега {custom category="1" subcat="only"} будут выбраны все публикации только из категорий 2 и 3.

author - указывает логин автора комментария, при указании данного параметра будут выводится только комментарии указанного автора. Допускается перечисление через запятую нескольких авторов. Например, тег {customcomments author="admin" limit="5"} выведет 5 комментариев автора с логином "admin".

authorexclude - указывает логины авторов, которые необходимо исключить из показа. Логины авторов в данном параметре также можно перечислять через запятую. Например, при использовании {customcomments authorexclude="admin,test"} будут выведены комментарии всех авторов, кроме авторов с логином "admin" и логином "test".

days - указывает временной период, где x это количество дней, за которые выводить комментарии. Например, тег {customcomments days="2" limit="5"} выведет 5 комментариев за 2 последних дня.

template - файл шаблона который будет использоваться при выводе комментариев в данном случае это будет custom.tpl если вы используете на сайте несколько шаблонов, то данный файл должен присутствовать в каждом шаблоне. В данном шаблоне используются теги аналогичные тем, что вы используете в шаблоне вывода комментариев (comments.tpl).

available раздел в котором будет выводится запрашиваемые комментарии, может принимать следующие значения:

global - во всех разделах

main - на главной странице

date - при просмотре новостей за определенные даты

cat - при просмотре категории

showfull - при просмотре полной новости

search - при просмотре результатов поиска

userinfo - при просмотре профиля

register - при регистрации

stats - при просмотре статистики

pm - при просмотре персональных сообщений

feedback - при просмотре обратной связи

favorites - при просмотре закладок

newposts - при просмотре новых сообщений

addnews - при добавлении новости

lastnews - при просмотре последних новостей на сайте

lastcomments - при просмотре последних комментариев

lostpassword - при восстановлении пароля от аккаунта на сайте

static - при просмотре статических страниц

catalog - при просмотре каталога страниц

alltags - при просмотре облака тегов

tags - при просмотре новостей из облака тегов

allnews - при просмотре всех новостей на сайте или всех новостей какого либо пользователя

Вы можете комбинировать разделы при помощи "|", например available="userinfo|register|main" будет выводить ваши новости на главной, при регистрации и при просмотре профиля пользователя.

from - указывает номер комментария с которой начнется вывод. Нумерация комментариев начинается с нуля. Например, если вы хотите пропустить первый комментарий, который совпадает с вашими условиями, то нужно указывать from="1"

limit - указывает сколько комментариев будет выведено.

order - указывает критерий сортировки комментариев, может принимать следующие значения:

date - сортировка комментариев по дате, например, тег {customcomments order="date" limit="5"} выведет пять последних комментариев.

rating - сортировка комментариев по рейтингу, например, тег {customcomments order="rating" limit="5"} выведет пять самых рейтинговых комментариев.

rand - сортировка комментариев в случайном порядке, например, тег {customcomments order="rand" limit="5"} выведет пять комментариев в случайном порядке.

id_as_list - сортирует публикации так как они указаны в списке для ID публикаций. Например, тег {custom id="3,4,1,2" order="id_as_list"} выведет сначала новость c ID 3 потом 4 потом 1 потом 2.

sort - указывает порядок сортировки комментариев. При использовании значения desc публикации сортируются по убыванию, а при использовании asc по возрастанию.

cache - принимает значения yes или no и указывает кешировать вывод или нет, мы рекомендуем кешировать блоки данного вывода для снижения нагрузки на сервер. Вы можете указывать период в минутах, часах или днях. Для указания времени кеширования используются значения с суффиксами “m”, “h” и “d”. Например, если вы укажите {customcomments cache="30m" ….} то блок с комментариями будет принудительно кеширован на 30 минут, если вы укажите {customcomments cache="2h" ….}, то блок с комментариями будет кеширован на 2 часа, если указать {customcomments cache="1d" ….} то блок с комментариями будет кеширован на один день.

Все параметры данного тега являются необязательными. Достаточно указать одного любого параметра. Вы также можете комбинировать различные параметры данного тега по своему усмотрению.

{* Закомментированный код *}

Данный тег предназначен для комментирования кода, все что заключено между "{*" и "*}" будет удалено из шаблона. И будет отсутствовать при выводе на сайте. Данные теги будут полезны разработчикам шаблонов, для отладки той или иной функциональности, когда нужно временно закомментировать ту или иную функциональность. Данный тег является глобальным и может использоваться во всех шаблонах.

{lang text="LANG_PARAMETER"}

Данный тег предназначен для вывода информации из языкового файла website.tpl, который в данный момент используется, где LANG_PARAMETER это значение параметра, который необходимо вывести. Например, тег {lang text="attach_images"} выведет надпись “Прикрепить изображения” из языкового пакета, в случае использования русского языка и если используется английский язык, то “Attach Images”

{catmenu}

Для вывода меню категорий используется тег {catmenu}. Данный тег вы можете использовать в любом файле шаблонов, он является глобальным. Данный тег в свою очередь использует и подключает файл шаблона categorymenu.tpl.

{catmenu id="1,2,3-5" idexclude="1,2,3-5" subcat="yes" template="custom" cache="yes"}

Выводит меню категорий в пользовательском формате, где:

id="1,2,3-5" - список ID категорий которые необходимо вывести в меню. Вы можете перечислить несколько категорий через запятую, либо указать диапазон ID через тире.

idexclude="1,2,3-5" - список ID категорий которые не нужно включать в список категорий, и будут выведены все категории кроме указанных. Вы можете перечислить несколько категорий через запятую, либо указать диапазон ID через тире.

subcat="yes" - данный параметр принимает значения "yes", "no" или "only" и используется совместно с параметром id данного тега, и указывает нужно ли автоматически подключать подкатегории для указанного списка категорий. Например, есть категория с ID 1, у данной категории есть подкатегории с ID 2 и ID 3, то при использовании тега {catmenu id="1" subcat="yes"} будет выведена категория 1 и ее подкатегории 2 и 3, а при использовании тега {catmenu id="1" subcat="no"} будет выведена только категория с ID 1. Значение "only" означает что нужно выводить только подкатегории из указанной категории. Например, при использовании тега {catmenu id="1" subcat="only"} будут выведены только подкатегории принадлежащие категории с ID "1". Также например, при помощи простой конструкции [available=cat] {catmenu id="{category-id}" subcat="only"} [/available] вы можете автоматически выводить список подкатегорий у просматриваемой на сайте категории.

template="custom" - указывается имя шаблона, которое будет использоваться для формирования меню вместо стандартного categorymenu.tpl

cache="yes" - данный параметр принимает значения "yes" или "no" и указывает кешировать данный блок или нет. При включении кеширования, автоматически пропадет возможность управлять подсветкой активной просматриваемой категории через теги [active] текст [/active] в шаблоне.

{catnewscount id="X"}

Выводит количество публикаций для указанной категории, где X это ID нужной вам категории. Данный тег будет полезен для вывода количества публикаций, в уже сформированных вручную в шаблонах меню на сайтах.

{category-id}

Выводит ID просматриваемой посетителем сайта категории. Данный тег будет полезен при организации меню на сайте, а также когда нужно быстро переназначить какие-либо CSS классы или сами имена файлов шаблонов, при оформлении шаблонов вывода публикаций.

{category-title}

Выводит имя просматриваемой посетителем сайта категории. Данный тег будет полезен, когда на сайте нужно отдельно вывести имя просматриваемой категории.

{category-description}

Выводит заданное описание категории, когда пользователь просматривает данную категорию, также вывод доступен и при выводе полных публикаций

[category-description] текст [/category-description]

Выводят текст заключённый в них если просматриваемая категория имеет заданное описание категории

[not-category-description] текст [/not-category-description]

Выводят текст заключённый в них, если категория не имеет описания.

{category-icon}

Выводит иконку просматриваемой пользователем категории, либо категории новости, если просматривается полная новость

{category-url}

Выводит URL просматриваемой категории

{page-title}

Выводит указанный вами в разделе "Заголовки, описания, метатеги" заголовок для страницы

{page-description}

Выводит указанное вами в разделе "Заголовки, описания, метатеги" описание для страницы

{page-count}

Выводит номер страницы, на которой находится пользователь

[script] код [/script] Глобальные теги которые позволяют разместить исполняемый jаvascript код. При этом данный код будет размещён непосредственно в исполняемом блоке других JS скриптов DataLife Engine, и будет запущен непосредственно после загрузки других JS скриптов, которые используются при подключении. Тем самым вы можете упорядочить все JS коды в шаблоне, стандартизировать их порядок исполнения, и в будущем избегать каких-либо конфликтов.

{cache-id}

Выводит текущий актуальный ID кэша

[active-plugins=X] Текст [/active-plugins]

Выводит текст заключённый в него если указанный плагин включён и используется на сайте.Где X это ID плагина или его имя. Например, вы можете указать [active-plugins=1] Текст [/active-plugins] либо [active-plugins=Мой плагин] Текст [/active-plugins], и если плагин с ID 1 или с именем “Мой плагин” включен в системе, то текст указанный в теге будет выведен. Также вы можете перечислять несколько параметров в теге через запятую, например, [active-plugins=1,2,5] Текст [/active-plugins]

[not-active-plugins=X] Текст [/not-active-plugins]

Выводит текст заключённый в него если указанный плагин выключен и не используется на сайте. Где X это ID плагина или его имя. Например, вы можете указать [not-active-plugins=1] Текст [/not-active-plugins] либо [not-active-plugins=Мой плагин] Текст [/not-active-plugins], и если плагин с ID 1 или с именем “Мой плагин” выключен в системе и не используется, то текст, указанный в теге будет выведен. Также вы можете перечислять несколько параметров в теге через запятую, например, [not-active-plugins=1,2,5] Текст [/not-active-plugins].

Данные из профиля пользователя:

{profile-link} - Выводит ссылку на профиль пользователя

{profile-login} - Выводит логин пользователя

{ip} - Выводит IP пользователя

{foto} - Выводит ссылку на аватар пользователя

{fullname} - Выводит полное имя пользователя

[fullname] текст [/fullname] - Выводит текст заключенный в теги в случае если полное имя указано в профиле пользователя

{land} - Выводит страну пользователя

[land] текст [/land] - Выводит текст заключенный в теги в случае если страна указана в профиле пользователя

{mail} - Выводит E-mail адрес пользователя

{group} - Выводит группу пользователя

{registration} - Выводит дату регистрации пользователя

{lastdate} - Выводит дату последнего посещения пользователя

{group-icon} - Выводит иконку группы пользователя

{time_limit} - Выводит дату до которой пользователь находится в группе, если группа является временной

[time_limit] текст [/time_limit] - Выводит текст заключенный в теги в случае если пользователь находится во временной группе

{comm-num} - Выводит количество комментариев пользователя

{comments} - Выводит адрес ссылки на комментарии пользователя

[comm-num] текст [/comm-num] - Выводит текст заключенный в теги если пользователь имеет комментарии на сайте

[not-comm-num] текст [/not-comm-num] - Выводит текст заключенный в теги если пользователь не имеет комментариев на сайте

{news} - Выводит адрес ссылки на новости пользователя

{rss} - Выводит адрес ссылки на RSS новостей пользователя

{news-num} - Выводит количество новостей пользователя

[news-num] текст [/news-num] - Выводит текст заключенный в теги если пользователь имеет новости на сайте

[not-news-num] текст [/not-news-num] - Выводит текст заключенный в теги если пользователь не имеет новостей на сайте

{new-pm} - Выводит количество непрочитанных персональных сообщений пользователя

{all-pm} - Выводит общее количество персональных сообщений пользователя

{favorite-count} - Выводит общее количество публикаций в закладках пользователя

[profile_xfvalue_X] - Выводит значение дополнительного поля с именем "X" из его профиля

[profile_xfgiven_X] текст [/profile_xfgiven_X] - Выводит текст заключенный в теги если дополнительное поле с именем "X" указано в его профиле

[profile_xfnotgiven_X] текст [/profile_xfnotgiven_X] - Выводит текст заключенный в теги если дополнительное поле с именем "X" не указано в его профиле

{admin-link} - Выводит ссылку на админпанель если он имеет к ней доступ

[admin-link] текст [/admin-link] - Выводит текст заключенный в теги если пользователь имеет доступ к админпанели


Теги при написании новостей

Навигация: Работа с движком >

Теги при написании новостей

При написании публикаций помимо HTML кода и визуального оформления в редакторе допустимо использование следующих дополнительных специальных тегов:

[leech=ссылка] текст [/leech] Полностью аналогичен тегу URL, за исключением того что производит шифрование ссылки

[img] ссылка [/img] Вставка картинки новость

[img=выравнивание] ссылка [/img] Вставка картинки новость и выравнивание ее по указанному параметру

[img=выравнивание|свой текст для alt] ссылка [/img] Вставка картинки новость и выравнивание ее по указанному параметру, а также назначение картинке собственного описания

[quote] текст [/quote] Цитата

[hide] текст [/hide] Показывает скрытый текст только для пользователей, которым разрешен просмотр скрытого текста в настройках групп

[hide=2,3,4] текст [/hide] Показывает скрытый текст только для пользователей, группы которые перечислены в теге. Где 2,3,4 это ID групп пользователей которым разрешен просмотр данного текста.

{pagebreak} Разрыв страницы

[page=номер страницы] текст [/page] Вставка ссылки на указанный номер страницы внутри новости

[thumb] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку

[thumb=выравнивание] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку и выравнивание ее по указанному параметру

[thumb=выравнивание|свой текст для alt] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку и выравнивание ее по указанному параметру, а также назначение картинке собственного описания

[video=http://test.ru/video.avi] Позволяет установить проигрывание видеофайла в новости

[videо=300x250,http://site.ru/video.mp4] Данный тег позволяет установить размеры видео для данного конкретного тега

[video=http://test.ru/video.avi|http://test.ru/sample.jpg] Позволяет установить проигрывание видеофайла в новости, а также картинку предосмотра для перед началом проигрывания.

[video=http://test.ru/video.avi|http://test.ru/sample.jpg|Описание для видео] Позволяет установить проигрывание видеофайла в новости, установить картинку предосмотра перед началом проигрывания, а также задать отдельное описание для видео, которое будет показано в проигрывателе.

[video=http://test.ru/video.mp4,http://test.ru/video2.mp4] Позволяет установить проигрывание двух видеофайлов в новости, для этого будет создан плейлист из двух видеофайлов. Им также могут быть заданы и картинка для превью и описание, так как указано выше.

[audio=http://test.ru/music.mp3] Позволяет установит проигрывание MP3 в новости

[audio=http://test.ru/music1.mp3,http://test.ru/music2.mp3] Позволяет установит проигрывание плейлиста из нескольких MP3 файлов в новости

[spоiler] текст [/spoiler] Скрывает указанный в теге текст и показывает его при клике на него

[spоiler=Заголовок] текст [/spoiler] Выводит собственный заголовок по щелчку на который будет показан скрытый текст

[media=ссылка на страницу с видео] предназначен для публикации видео и другого контента на сайте с сервисов поддерживающих oEmbed, таких как youtube.com, instagram, twitter, facebook, flickr, vimeo, docs.com, vine, gettyimages, codepen.io, dailymotion, mixcloud, soundcloud, coub, ifixit, Apple Keynote. В данном теге вы просто указываете URL страницы где размещено видео или нужный контент, скрипт автоматически распознает тип хранилища и вставит нужный HTML код для просмотра видео или виджета.

[media=300x250,http://....] Данный тег позволяет установить размеры видео для данного конкретного тега


Избранное / Фавориты

Навигация: Работа с движком >

Избранное / Фавориты

Возможности движка позволяют каждому зарегистрированному пользователю добавлять понравившуюся новость в свои закладки. Не путайте с закладками браузера. После авторизации на сайте каждый посетитель может добавить новость в закладки нажав на плюсик, после этого он может легко просмотреть новость или комментарии к ней, независимо от даты новости и не используя при этом поиск.


Персональные сообщения

Навигация: Работа с движком >

Персональные сообщения

Все авторизованные на сайте пользователи могут отправлять друг другу персональные сообщения. Данные сообщения в дальнейшем можно просматривать, удалять их, а также отвечать на них. Для этого используется определенный шаблон для их вывода. При редактировании этого шаблона будьте предельно внимательны. Чтобы не нарушить функциональность этого модуля. Для редактирования этого шаблона не требуется знание PHP, однако вы должны разбираться в HTML и его особенностях. Другими словами просто не изменяйте без особой надобности поля для ввода информации из форм.


ЧПУ и настройка

Навигация: Работа с движком >

ЧПУ и настройка

DataLife Engine использует в своей работе для вывода новостей ЧПУ (человеко-понятный URL), что позволяет тему статьи или любой другой текст добавить в URL браузера, благодаря этому индексация сайта в поисковых системах будет более качественной, что приведет больше посетителей на ваш сайт с поисковых систем. Для работы ЧПУ необходимо чтобы на вашем сервере был установлен модуль modrewrite. Если Ваш сервер не поддерживает этого, то вы можете отключить эту функцию. Для этого вам необходимо обязательно удалить с корневого каталога файл .htaccess и при установке скрипта отключить поддержку этой функции. Для более корректной работы ЧПУ мы рекомендуем устанавливать скрипт в корневую папку вашего сайта.

При включенном ЧПУ ссылки будут имеют следующий вид

Полная новость

С использованием ЧПУ зависит от типа ЧПУ установленного в настройках скрипта

http://website.com/index.php?newsid=1234543 - без использования ЧПУ

Добавление новостей на сайт вашими посетителями

http://website.com/addnews.html - с использованием ЧПУ

http://website.com/index.php?do=addnews - без использования ЧПУ

Профиль пользователя

http://website.com/user/имя пользователя/ - с использованием ЧПУ

http://website.com/index.php?subaction=userinfo&user= имя - без использования ЧПУ

Регистрация на сайте

http://website.com/index.php?do=register - без использования ЧПУ

Обзор непрочитанных сообщений

http://website.com/newposts/ - с использованием ЧПУ

http://website.com/index.php?subaction=newposts - без использования ЧПУ

Вывод всех новостей

http://website.com/lastnews/ - с использованием ЧПУ

http://website.com/index.php?do=lastnews - без использованиия ЧПУ

Вывод всех новостей указанной категории

http://website.com/альтернативное имя категории/ - с использованием ЧПУ

http://website.com/index.php?do=cat&category=альтернативное имя - без использования ЧПУ

Вывод всех новостей за 2005 год

http://website.com/2005/ - с использованием ЧПУ

http://website.com/index.php?year=2005 - без использованиия ЧПУ

Вывод всех новостей за указанный месяц

http://website.com/2005/12/ - с использованием ЧПУ

http://website.com/index.php?year=2005&month=04 - без использования ЧПУ

Вывод всех новостей за указанный день

http://website.com/2005/12/01/ - с использованием ЧПУ

http://website.com/ index.php?year=2005&month=04&day=30 - без использования ЧПУ

Обратная связь с администрацией сайта и другими участниками

http://website.com/index.php?do=feedback

Каталог сайта (сортировка по символьному коду)

http://website.com/catalog/a/ - с использованием ЧПУ

http://website.com/index.php?catalog=а - без использованиия ЧПУ

Вывод облака тегов

http://website.com/tags/ - с использованием ЧПУ

http://website.com/index.php?do=tags - без использованиия ЧПУ

Правила сайта

http://website.com/rules.html - с использованием ЧПУ

http://website.com/index.php?do=rules - без использованиия ЧПУ

Ссылки для вывода всех новостей указанной категории вы должны самостоятельно добавить в дизайн вашей страницы. Более подробно о создании категорий читайте ниже.


Поддержка Смартфонов

Навигация: Работа с движком >

Поддержка Смартфонов

Datalife Engine позволяет автоматически определять с использованием чего посетитель заходит на ваш сайт. И в случае если пользователь заходит на ваш сайт с мобильного аппарата, то DataLife Engine способен распознать это и подготовить для вывода специальную облегченную версию вашего сайта, с минимумом графики и использованного для передачи трафика.

Для включения данной возможности вам необходимо в Админпанели в настройках скрипта включить пункт: Включить автоматическую поддержку смартфонов, там же в настройках скрипта вы можете включить вывод в новостях картинок или отключить. Также можно принудительно включить отображение версии сайта для смартфонов, для этого нужно перейти по ссылке http://site.ru/index.php?action=mobile

Также в вашей папке шаблонов /templates/ должна находится папка с шаблоном smartphone именно этот шаблон используется для вывода сайта в случае если пользователь зашел на ваш сайт с использованием мобильного телефона. В данном шаблоне вы можете использовать все теже возможности что и в обычном шаблоне. Все теги и возможности полностью идентичны обычному шаблону. Но мы рекомендуем использовать самый минимум и не забывать о размерах экрана мобильного телефона. В архиве дистрибутива мы подготовили один такой стандартный шаблон с самым минимумом информации и размером. На него мы и рекомендуем опираться, при создании собственного шаблона.


Система жалоб на грамматические ошибки на сайте

Навигация: Работа с движком >

Система жалоб на грамматические ошибки на сайте

В скрипте DataLife Engine присутствует система жалоб на грамматические и иные ошибки на сайте. Посетитель может выделить любой текст в браузере, нажать Ctrl+Enter, и ему будет предложено отправить уведомление администрации сайта о наличии ошибки в выделенном тексте. При этом пользователь может выделить любой текст на любой странице вашего сайта.

Рекомендуем вам разместить, в какой-либо видимой части вашего сайта, блок-уведомление о наличии такой возможности для ваших посетителей.

Управление жалобами на грамматические ошибки осуществляется в админпанели в разделе управления жалобами. Само уведомление отправляется с сайта с использованием технологии AJAX без перезагрузки страницы, и не доставляет неудобств пользователям.


Добавление новостей

Навигация: Работа с админпанелью >

Добавление новостей

Вход в админцентр осуществляется по адресу http://website.com/admin.php После авторизации вы сможете добавлять, редактировать и удалять новость, управлять пользователями и шаблонами, производить настройку скрипта, управлять картинками и многое другое.

При добавлении новости на сайт Вам необходимо задать заголовок статьи. Поле ЧПУ URL статьи является необязательным используется при включенных ЧПУ. Вы можете задать там свой текст, который будет в строке браузера, либо можете оставить его пустым, тогда текст будет сформирован из заголовка статьи, с учетом правил транслитации. Поле Дата задает дату новости, если отмечена галочка Текущая дата то будет автоматически вставлена текущая дата, с учетом коррекции времени, либо вы можете снять эту галочку, и ввести дату самостоятельно используя удобный календарь, нажав на значок рядом с полем. Если указать дату которая не наступила, то новость будет автоматически опубликована при наступлении указанной даты, при условии что новость допущена к публикации. Также вы можете выбрать категорию к которой принадлежит статья. После этого используя удобные кнопки для вставки тегов напишите вашу новость в кратком и полном описании, также если созданы дополнительные поля введите информацию и там. Внимание поле Полное описание не является обязательным, если оно пустое, то текст будет автоматически взят с Краткого описания. Используя ссылку [Загрузить картинку] вы сможете вставить в текст новости загруженные на сервер картинки либо загрузить непосредственно для этой статьи свою картинку. Также имеется возможность загрузки картинки непосредственно с другого сервера, минуя загрузку на собственный компьютер. Внимание если вы загружаете для этой статьи собственные картинки, то они будут автоматически удалены с сервера, при удалении новости.


Редактирование новостей

Навигация: Работа с админпанелью >

Редактирование новостей

Редактирование новостей идентично их добавлению за исключением поля Дата. Вы можете либо не изменять дату, для этого оставьте отмеченным Не изменять дату новости, либо снимите с него флажок и установите на Текущая дата и время, либо введите свою дату используя календарь.


Личные настройки

Навигация: Работа с админпанелью >

Личные настройки

В данном разделе вы сможете редактировать свой собственный профиль, изменить E-mail адрес, поменять дополнительные поля в виде полного имени, места жительства, установить новый пароль.


Настройка системы

Навигация: Работа с админпанелью >

Настройка системы

В данной разделе осуществляется общая настройка параметров системы, обратите внимание на то что настройка разбиты на разделы и для выбора раздела просто нажмите на соответствующую иконку.


Система плагинов

Навигация: Работа с админпанелью >

Система плагинов

Данная система плагинов позволяет модифицировать любую функциональность скрипта по своему усмотрению. Установка плагинов на сайт, обновление плагинов, осуществляется в один клик, непосредственно в панели управления DataLife Engine. Если плагин разработан под новую систему, то пользователям больше не придется читать инструкции по установке, что-то править непосредственно в файлах скрипта, и т.д. Им достаточно будет просто закачать плагин в админпанели и все.

Cистема плагинов построена по технологии виртуальной файловой системы. Вы описываете в плагине, в каком файле и какие действия нужно произвести, на основе этой информации DataLife Engine создаст виртуальные копии этих файлов, со всеми нужными изменениями и модификациями, и будет работать с созданными виртуальными копиями, не затрагивая при этом оригинальных файлов. При этом вы можете описать изменения практически во всех файлах, за исключением ряда базовых, например корневых файлов, но они не несут какого либо функционала, кроме как подключение других файлов. Также может быть изменена функциональность файлов, отвечающих за AJAX функции, для этого они были полностью переписаны для работы через контроллер. Какие это преимущества дает? Во-первых, оригинальные файлы всегда остаются неизменными, поэтому плагины могут быть легко изменены, удалены, обновлены и т.д. Во вторых эта система использует минимально возможную нагрузку на сайты в целом, т.к. виртуальные копии файлов создаются всего один раз, в момент установки или обновления плагинов, после чего DataLife Engine работает с этими измененными файлами как с обычными нативными файлами и нет никаких расходов памяти на точки вызова, хранение и контроль информации о том где и какую функциональность нужно менять и т.д. Нагрузка на сервер увеличится только на ту нагрузку, которую принесет с собой сам плагин, а система управления плагинами не будет вызывать какой либо дополнительной нагрузки. В-третьих, нет никаких проблем непосредственно с обновлением скрипта, скрипт может обновляться, на новые версии, а ваши плагины автоматически применяться к новым версиям. При этом различные плагины могут модифицировать один и тот же файл не вызывая конфликтов, при условии конечно если разные плагины не производят прямо противоположных друг другу действий.

Итак в самом модуле управления плагинами, вы можете либо создать плагин непосредственно в панели управления, либо загрузить готовый плагин. Рассмотрим добавление нового плагина в непосредственно в панели управления:

На первой вкладке вы задаете общие данные о плагине. Его название, его краткое описание. Для удобства различения с другими плагинами, вы можете указать ему иконку, которую он будет использовать в списке плагинов. Также вы задаете версию непосредственно самого плагина, и версию DataLife Engine c которой он совместим.

На следующей вкладке, вы задаете непосредственно действия над файлами, которые необходимо произвести. Вы можете добавить один или несколько файлов над которыми необходимо произвести действия, а также каждому файлу назначить одно или несколько действий, которые необходимо произвести. В файлах вы можете произвести следующие действия:

1. Найти и заменить какой либо код.

2. Найти и добавить выше нужный код.

3. Найти и добавить ниже какой либо код.

4. Полностью заменить содержимое файла на свое.

5. Создать новый виртуальный файл, который не существует в оригинальном DLE.

Вы можете в любое время также добавлять или удалять файлы, менять или удалять действия над файлами. Для удобства восприятия и редактирования, весь код при этом подсвечивается, а поля могут динамически растягиваться.

Тем самым, ситуация, при которой вы раньше вручную правили файлы скрипта, а изменения где то хранили у себя в блокноте, и каждый раз при обновлении скрипта, повторно вносили их в файлы скрипта, с новой версией полностью уходит в прошлое. Вы можете самостоятельно создать свой личный плагин непосредственно в админпанели, описав один раз нужные вам изменения в скрипте, и при обновлении скрипта до новой версии, вам не придется больше об этом заботиться, ваши изменения будут автоматически применяться к новым версиям.

На следующей вкладке вы можете добавить необходимые действия в базе данных MySQL, которые должен производить плагин в тех или иных ситуациях. Вы можете задать список MySQL запросов которые необходимо выполнить при установке плагина, при его обновлении, при его отключении, при его включении, при его удалении. При этом на каждое действие вы можете задать как один, так и список из нескольких запросов к базе данных.

Для существующего плагина, вы можете выполнить следующие действия: Вы можете его отключить, при этом он остается на сайте, но полностью игнорируется скриптом, и все его действия над файлами приостанавливаются. Вы можете его обновить до более новой версии, если таковая есть. Скачать плагин на компьютер для установки его на другой сайт. При этом сам файл скачивается в XML формате, и в данном XML содержится описание всех действий. По сути плагин представляет собой XML файл, который может быть установлен на сайт в админпанели.

Рассмотрим загрузку уже готового плагина на сайт. Вы можете загрузить и установить на свой сайт уже готовый плагин. При нажатии соответствующей кнопки вы можете загрузить либо XML файл с плагином. Либо ZIP архив с плагином. Это позволяет создавать очень сложные плагины, содержащие в себе большое количество других дополнительных файлов, как графических, так и PHP файлов. Чтобы например не описывать все действия непосредственно в самом плагине, можно создать дополнительные файлы и упаковать их в архив, разложив по новым местам. При этом важно знать, что в архиве могут быть только те PHP файлы, которые не входят в состав дистрибутива, а только ваши дополнительные файлы, в случае если будут файлы входящие в дистрибутив, такая загрузка будет заблокирована. Модификацию стандартных файлов, нужно описывать уже в самом плагине. Сам файл с XML плагином должен находится в корне вашего архива.

В случае если вы загружаете архив с плагином, и у DataLife Engine не будет прав на запись находящихся в вашем архиве файлов. Он автоматически запросит FTP доступ для того чтобы загрузить ваш архив. Если доступов не требуется, то все будет скопировано автоматически без них. При этом эти доступы не будут нигде храниться, а будут автоматически удалены после того как будут не нужны.

Система управления плагинами, обладает также встроенной системой логирования ошибок в плагине. В случае если какое либо действие над файлами не может быть выполнено, или произойдут какие либо ошибки, вы можете их легко увидеть и исправить. Например, это крайне удобно, если ваш плагин будет не совместим со следующей версией DLE, вы это быстро увидите, и можно легко адаптировать плагин.

Для плагинов имеется возможность использовать в имени плагина, описании плагина, и заметок для плагина теги [lang=X] Текст [/lang] в их тексте. Которые выводят текст в зависимости от того языка, который использует пользователь в админпанели. Где X это ISO код языка из языкового пакета. Тем самым вы можете выводить название, и заметки на разных языках. Например тег [lang=ru]Текст на русском[/lang] выведет данный текст если пользователь использует русский язык, а тег [lang=en] English Text [/lang] если пользователь использует английский язык.


Голосования

Навигация: Работа с админпанелью >

Голосования

В данном разделе вы можете создавать, редактировать и удалять опросы на сайте. Вы можете создавать опросы которые будут видны на всех страницах сайта, а также опросы которые будут видны только при просмотре определенных категорий.


Статические страницы

Навигация: Работа с админпанелью >

Статические страницы

Помимо написания динамически изменяемых новостей движок позволяет также написание статических страниц, частое изменение которых не планируется. Для того чтобы создать статическую страницу выберите "Создать новую страницу" после этого напишите название страницы, причем только латинскими буквами, потому что оно будет передаваться в URL сайта для просмотра, также введите описание страницы, это информация только для вас, и последнее создайте шаблон самой страницы, разрешено использование HTML. После создания страницы вы сможете ее просмотреть, изменить, либо удалить.

Адрес статической страницы с использование ЧПУ выглядит так: http://webseite.com/название страницы.html

Адрес статической страницы без ЧПУ выглядит так: http://webseite.com/index.php?do=static&page=название страницы


Группы пользователей

Навигация: Работа с админпанелью >

Группы пользователей

В данном разделе вы можете добавлять и редактировать новые и существующие группы пользователей. При добавлении новой группы пользователей вы выставляете ей доступные категории и права на сайте.

Доступные разделы: Разделы в которые имеет доступ выбранная группа

Доверительные разделы: В случае если разрешаете группе публиковать новости на сайте без предварительной модерации, либо разрешаете редактировать новости других пользователей, то в данном пункте вы указываете какие разделы вы доверяете группе. Редактирование новостей в неуказанных группах будет запрещено. Посетитель всегда может добавлять новости в доступные ему разделы, но если одна из категорий будет не в доверительном разделе то вся новость не будет опубликована без предварительной модерации. Категории в которые неразрешено добавлять новости без модерации выделяются красным цветом при добавлении.

Разрешить доступ в админпанель: данная опция разрешает пользователю доступ в админпанель, но не предоставляет доступа ко всем ее функциям. Разрешается доступ только для добавления или редактирования новостей из админпанели. Доступ ко всем функциям имеют только Администраторы.

Скрывать только полную новость из недоступных разделов: В случае если пользователю запрещен доступ в раздел вы можете выбрать, запретить ему полный доступ, либо запретить только просмотр полных новостей. В случае если вы запретите просмотр только полных новостей вы существенно сократите нагрузку на сервер и время выборки новостей.

Разрешить добавлять новости Вы можете запретить либо разрешить пользователям добавлять новости на сайт.

Публиковать новости без проверки: Разрешение на публикацию новостей в доверительные разделы без предварительной модерации

Разрешить фиксировать новости: Разрешение пользователям фиксировать новости на сайте

Редактирование собственных новостей: Разрешение пользователям редактировать собственные новости уже после опубликования на сайте

Редактирование всех новостей: Разрешение пользователям редактировать любые новости из доверительных разделов.

Разрешить добавление комментариев: Разрешение пользователям оставлять комментарии на сайте

Изменение своих комментариев: Разрешение пользователям редактировать собственные комментарии

Удаление своих комментариев: Разрешение пользователям удалять собственные комментарии

Изменение всех комментариев: Разрешение пользователям производить изменение любых комментариев

Удаление всех комментариев: Разрешение пользователям проводить удаление любых комментариев на сайте

Просмотр скрытого текста: Разрешение пользователям на просмотр содержимого тега [hide] [/hide]

Разрешить использование PM: Разрешение пользователям использование персональных сообщений на сайте.

Разрешить скачивание файлов: Разрешение пользователям скачивать загруженные на сервер файлы

Использование обратной связи: Разрешение пользователям использовать обратную связь на сайте

Использование поиска по сайту: Разрешение пользователям использовать поиск по сайту

Временное размещение в группе: Вы можете временно размещать пользователей в данной группе, при переносе пользователя в данную группу укажите до какого срока он будет размещен в данной группе, после окончания данного срока, пользователь будет автоматически перемещен в основную группу

Основная группа по окончании лимита: Укажите основную группу пользователя в которую он будет перемещен после окончания срока пребывания во временной группе.


Настройка категорий

Навигация: Работа с админпанелью >

Настройка категорий

В данном разделе вы можете создавать и редактировать категории. При создании новой категории вы указываете ее имя, альтернативное имя категории, путь для иконки категории, выбрать является ли новая категория подкатегорией и где. А также дополнительно вы можете указать какой шаблон будет использоваться при показе статей из данной категории, а также при просмотре этой категории. Иконка является необязательным параметром. Внимание: альтернативное имя задается только латинскими буквами и служит для вывода всех новостей данной категории. Например вы создаете категорию с именем «Софт», и альтернативным именем «soft», то для просмотра всех новостей из указанной новости при включенном ЧПУ в строке браузера необходимо набрать http://website.com/soft/, а при выключенном ЧПУ необходимо набрать http://website.com/?do=cat&category=soft


Дополнительные поля

Навигация: Работа с админпанелью >

Дополнительные поля

В данном разделе вы сможете создавать и редактировать дополнительные поля. Дополнительные поля, позволяют облегчать добавление информации на сайт, по умолчанию имеются только два поля, это краткое и полное описание новости. Однако вы можете создать и другие поля для ввода информации, например ссылку на источник или на программу, и настроив вывод поля всего один раз в шаблонах, отпадает необходимость постоянного форматирования часто повторяющегося ввода информации.

При добавлении нового поля вы вводите его название (латинскими буквами), описание поля (выводится рядом с полем ввода), категорию к которой принадлежит данное поле (вы можете выбрать, вводить ли данное поле для всех категорий или данное поле принадлежать только одной категории, вы можете назначать также выборочно, категории к которым будет принадлежать данное поле, для этого выберите нужные категории в списке удерживая кнопку Ctrl), тип поля (вы можете выбрать три типа поля, либо это одна строка, либо это какой то большой текст, либо это выпадающее меню со списком значений), также можете назначить значение поля по умолчанию. Если вы хотите чтобы поле являлось необязательным при вводе информации, поставьте соответствующую галочку, в противном случае новость не будет добавлена, если данное поле не введено.


Фильтр по IP, Логину или E-Mail

Навигация: Работа с админпанелью >

Фильтр по IP, Логину или E-Mail

Вы можете воспользоваться данным разделом, чтобы заблокировать определенные IP адреса, или заблокировать определенные электронные адреса, имена пользователей при регистрации. При вводе IP адреса, то доступ на сайт данному IP или подсети закрывается полностью, а не только для регистрации.

Примечание: вы можете воспользоваться в фильтре символом звездочки * для подстановки в имя пользователя, IP адрес или электронный адрес (например: 127.0.*.*, *@mail.ru, username*).


IP утилиты

Навигация: Работа с админпанелью >

IP утилиты

Данный модуль предназначен, для быстрого и удобного поиска и редактирования пользователей, использовавших для регистрации или авторизации указанный IP адрес. Допускается поиск как по полному IP адресу, так и по сокращенному. Также в данном модуле вы можете найти все IP адреса которые использовал определенный пользователь.


Управление рекламой

Навигация: Работа с админпанелью >

Управление рекламой

Данный модуль предназначен, для быстрого и удобного размещения и управления вашими рекламными материалами на сайте. Для того чтобы разместить на сайте ваш баннер, вам достаточно один раз добавить тег баннера в шаблон, после чего вы можете без проблем менять или редактировать код баннера в админпанели, не затрагивая при этом шаблоны.

После добавления своего баннера вы можете разместить его тег в шаблонах main.tpl или fullstory.tpl. Если вы добавляете баннер для показа между короткими новостями, то добавлять тег в шаблон ненужно, баннер будет добавлен между новостями автоматически.

Пример работы:

- Название: header
- Описание: Верхний баннер
- Включить показ баннера: Да
- Показывать только на главной: Нет
- Закрепить в расположении: Нет
- Расположение в коротких новостях: Нет

Если вы хотите чтобы данных баннер показывался только для определенных групп, то вы можете выбрать при добавлении баннера те группы пользователей, для которых необходимо показывать данный баннер. Также вы можете установить дополнительно время и дату начала показа баннера и время и дату окончания показа

После этого вы можете добавить в ваш шаблон в main.tpl или fullstory.tpl тег для вывода баннера: {banner_header}

Вы можете при добавлении кода баннера использовать HTML и JavaScript.


Анализ производительности

Навигация: Работа с админпанелью >

Анализ производительности

В данном разделе производится анализ всех настроек скрипта и настроек групп пользователей, и по результатам анализа выдаются рекомендации по изменению и отключению тех или иных возможностей скрипта. При этом результаты выводятся с подробными описаниями, почему нужно отключить ту или иную возможность, а также результаты выводятся в специальных графически выделенных блоках, определяющих степень нагрузки той или иной возможности. Рекомендации выделенным красным, необходимо выполнять в первую очередь, т.к. позволяют снизить существенно нагрузку на сервер. Рекомендации в желтом блоке указывают на среднюю степень нагрузки. Рекомендации, выделенные зеленым, способны лишь незначительно снизить нагрузку. Тем самым использование данного раздела рекомендуется в первую очередь, тем, кто испытывает проблемы с нагрузкой на сайт, на своем хостинге и хочет попытаться решить проблему "малой кровью", без смены тарифного плана на хостинге и перехода на более мощные ресурсы. Данный раздел будет полезен как новичкам, недавно пользующимся скриптом, так и более опытным пользователям.


Система Вопрос - Ответ

Навигация: Работа с админпанелью >

Система Вопрос - Ответ

Система «Вопрос-ответ» позволяет пресечь деятельность спам ботов при регистрации, добавлении новостей или комментариев. Для этого администратор должен задать список вопросов и ответов к ним в специальном разделе. При этом данная система может включаться отдельно для регистрации, добавления новостей, добавления комментариев. Для регистрации посетителей на сайте, система включается в настройках скрипта, а для добавления новостей и комментариев включается в настройках групп, и может включаться только для некоторых групп пользователей. Система «Вопрос-ответ» является полностью автономной и независимой от каптчи на сайте и может использоваться как совместно с каптчей, так и отдельно.

Данная система работает со следующими тегами:

Шаблонные теги [question] и [/question] выводят текст, заключенный между ними, только в том случае, если система активирована.

Тег {question} выводит вопрос для посетителя.


Перекрестные ссылки

Навигация: Работа с админпанелью >

Перекрестные ссылки

Данный модуль предназначен, для быстрого и удобного создания перелинковки по сайту по ключевым словам. В данном разделе вы задаете ключевое слово и URL, в случае нахождения данного ключевого слова на вашей странице, оно будет заменено на гипертекстовую ссылку. В отличии от модуля "фильтр слов", который также присутствует в скрипте, в данном модуле ключевые слова ищутся по всей странице, включая весь контент (новости, комментарии, шаблоны, сторонние модули и т.д.), а не только в новостях и комментариях. Также любое внесение или изменение ключевых слов в данном разделе, приводит к моментальному применению на всех страницах вашего сайта, не требуя перестроения публикаций. Также в данном модуле поддерживается указание склонения слов, например, вы можете задать ключевое слово "Иван(ов|ова|ову)" и ссылка будет применяться к словам: Иванов, Иванова, Иванову и т.д. Поиск ключевых слов осуществляется только по словам целиком, а не просто по всем вхождениям в тексте.


Система логов админпанели

Навигация: Работа с админпанелью >

Система логов админпанели

В данном разделе собираются все действия пользователей, осуществляемых в админпанели скрипта, за последние 30 дней, тем самым администратор сайта может всегда посмотреть, какие действия осуществлял тот или иной пользователь админпанели. Собираемые скриптом данные удалить в скрипте нельзя, они автоматически удаляются скриптом по истечении 30 дней, с момента их осуществления.


RSS информер

Навигация: Работа с админпанелью >

RSS информер

Данный модуль предназначен для публикации новостей ваших партнеров с других сайтов в определенном блоке на вашем сайте. Зайдя в админпанель для добавления нового информера вы задаете ему следующие параметры:

Название RSS информера - в данном поле вы указываете имя для информера имя может быть уникальным а может быть таким же как и у других информеров. В случае если имя одинаковое то информеры показываются в режиме ротации.

Описание RSS информера - краткое описание предназначенное для вас этого информера

Категория - вы можете указать категорию в которой показывать этот информер, либо сделать доступным показ во всех категориях

URL для RSS информера - здесь вы указываете путь к RSS источнику из которого будут братся новости

Шаблон для информера - укажите шаблон который будет подгружатся для показа отформатированной информации в этом блоке. Например informer.tpl

Количество новостей в блоке - укажите количество новостей которые должны показываться в данном блоке

Количество символов в заголовке - укажите максимальное количество символов в заголовке, при превышении данного лимита заголовок будет автоматически обрезаться. Вы можете установить значение 0, тогда заголовок будет импортироватся целиком

Количество символов в тексте новости- укажите максимальное количество символов в новости, при превышении данного лимита новость будет автоматически обрезаться. Вы можете установить значение 0, тогда новость будет импортироватся целиком


Используемые классы CSS

Навигация: Шаблоны >

Используемые классы CSS

DataLife Engine использует следующие классы CSS:

.calendar - Вывод таблицы календаря

.monthlink - Ссылка перехода по месяцам в календаре

.day-active-v - Класс для рабочих дней если новости есть

.day-active - Субботние и воскресные дни в которых есть новости
.day - Класс для рабочих дней если новостей нет
.weekday - Субботний и воскресный дни в которых нет новостей

.day-current - Текущая дата, или если посетитель просматривает новости за данный день

.archives - Вывод списка архивов

.xfields - Ввод дополнительный полей в добавлении новости

.rating - Вывод рейтинга

.quote - Используется для вывода цитаты или информации о скрытом тексте

.scriptcode - Используется для вывода информации, заключенной в тег [CODE]

.pm - Таблица при выводе списка полученных приватных сообщений

.pm_head - Заголовок таблицы

.pm_list - Список самих сообщений

.pm_progress_bar - Шкала заполненности ящика персональных сообщений

#dropmenudiv - Выпадающее меню при использовании быстрого или полного редактирования

#newpm, #newpmheader - Для настройки уведомления о получении нового персонального сообщения

.editor_button,

.editor_buttoncl,

.editbclose, .editor_button_brk - Стили для настройки кнопок BB редактора при быстром редактировании новостей на сайте.

.editor - общий стиль для BB редактора.

.clouds_xsmall, .clouds_small, .clouds_medium, .clouds_large, .clouds_xlarge - Для настройки размеров различных ключевых слов в облаке тегов, в зависимости от их популярности

.highslide-active-anchor, .highslide-image-blur, .highslide-html-content, .highslide-loading, a.highslide-full-expand, .highslide-display-block, .highslide-display-none - Для настройки показа всплывающего окна с оригинальным изображением из уменьшенной копии

.highslide-dimming - Используется для задания затемняющего фона при включении режима "Галереи" для показа загруженных изображений.

#loading-layer - оформление информационного окна о выполнении AJAX действия.

#searchsuggestions - оформление быстрого поиска на сайте.

.mass_comments_action - оформление меню выбора действия над комментариями на сайте.

Не забудьте использовать данные стили в вашем главном шаблоне.


Общая информация

Навигация: Шаблоны >

Общая информация

DataLife Engine позволяет использовать шаблонную систему для вывода новостей, а также для вывода различных модулей. Мы попытались максимально упростить использование шаблонов в движке, для того чтобы их использовать вам не надо обладать никакими знаниями языков программирования, только язык верстки HTML. Однако для более полного и легкого использования шаблонов мы рекомендуем вам внимательно прочитать руководство по работе с шаблонами, чтобы выяснить какие теги используются в шаблонах и для чего они предназначены.

Шаблоном в DLE является папка которая находится в свою очередь в папке /temlates/. Файлы находящиеся в папке шаблона, являются файлами одного шаблона.

Также вы можете подключать один файл шаблона в другой, используя тег {include file="my_block.tpl"} данный тег подключает указанный файл my_block.tpl в шаблон. Тег призван облегчить структуру шаблона, если используется сложная верстка со множеством тегов. Данный тег действует во всех шаблонных файлах .tpl Подключаемый файл должен находится в папке вашего шаблона или его вложенных папках, если вы хотите подключить файл шаблона, находящийся в другом шаблоне, необходимо использовать полный путь от корня где установлен скрипт, например, {include file="/templates/mytemplate/my_block.tpl"}. Также вы можете подлючать при помощи данного тега стили CSS вашего шаблона {include file="{THEME}/css/styles.css"} или JS файлы.

Теги в подключаемом шаблоне должны быть такие же, какие допустимы в шаблоне где подключается файл, например если файл my_block.tpl подключается в шаблоне main.tpl, то и теги в этом файлы будут работать только те которые возможны в main.tpl


Главный шаблон сайта

Навигация: Шаблоны >

Главный шаблон сайта

Данный файл шаблона является общим файлом, который подключает в себя вывод всех других файлов шаблона из всех разделов. Он находится в файле main.tpl В этом файле настраиваются шаблоны ваших страниц, куда подключаются другие компоненты движка. Редактирование данного файла не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно.

{headers} | Выводит сгенерированные метатеги о кодировке страницы, title, keywords, description. А также подключает все необходимые скрипты. Размещаеться в шаблоне между тегами <head>. Данный тег обязателен в шаблоне.
{jsfiles} | Выводит подключение всех JS скриптов, которые использует DLE в указанном месте шаблона. При помощи данного тега вы можете, например, перенести все JS скрипты в самый низ страницы, для ускорения загрузки и рендеринга ваших страниц. Данный тег является необязательным, и в случае его отсутствия в шаблоне, все скрипты будут подключены, как и ранее к тегу {headers}. Внимание, если вы переносите подключение скриптов, то должны иметь ввиду, что тег {AJAX} также должен находится ниже тега {jsfiles}, а также вы должны предусмотреть работу всех своих сторонних скриптов в шаблоне, если они используют, например, библиотеку Jquery, чтобы они не запускались раньше, чем выполнится подключение всех скриптов. Мы настоятельно не рекомендуем новичкам пользоваться данным тегом, он предназначен для опытных вебмастеров, которые имеют опыт в работе с JS скриптами.
{THEME} | Путь к выбранному шаблону
{login} | Вставка панели для входа и регистрации посетителей
{vote} | Вставка опроса на сайте
{changeskin} | Вставка формы для смены скинов на сайте
[changeskin] текст [/changeskin] | Выводят текст заключённый в них в случае, если пользователям разрешена смена тем оформления сайта
{calendar} | Вставка модуля календаря
{topnews} | Вывод самых рейтинговых статей, добавленных за последний месяц
{archives} | Вывод архивов
{info} | выводит служебную информацию движка, в случае если возникла необходимость. Присутствие тега обязательно в шаблоне.
{content} | Вывод непосредственно самого контекста на сайте, новостей, обратной связи регистрации и прочего, в общем основная колонка. Присутствие тега практически обязательно в шаблоне, за исключением крайне редких случаев, в зависимости от необходимых возможностей самого сайта.
{custom} | Смотрите раздел "Вывод новостей на страницах"
[available=раздел]текст[/available] | Смотрите раздел "Вывод новостей на страницах"
{AJAX} | Подключает все необходимы скрипты для работы DLE и AJAX, подключение обязательно, и рекомендуется размещение в начале страницы, сразу после тега <body>. Данный тег обязателен в шаблоне.
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
[category=X]текст[/category] | Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
{banner_имя} | Этот тег предназначен для вывода рекламной информации на сайте. Само имя для баннера задается в специальном модуле в админпанели.
{inform_имя} | Этот тег предназначен для вывода RSS информеров и новостей с других сайтов. Имя и все настройки для данного тега устанавливаются в админпанели скрипта.
[not-category=X]текст[/not-category] | Предназначен для вывода текста если пользователь находится везде, кроме как в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
[not-group=X]текст[/not-group] | Вывод текста любой группе пользователей, кроме указанной. Где X это список ID через запятую группы пользователей для которых непоказывать информацию.
[page-count=1,2,3] текст [/page-count] | Выводит текст заключенный в них, если пользователь находится на определенной по номеру страницы в навигации по новостям, независимо от раздела сайта, где 1,2,3 это номера страниц в навигации.
[not-page-count=1,2,3] текст [/not-page-count] | Выводит текст опубликованный в тегах на любых номерах страниц кроме указанных в теге.
[news=1,2,3] текст [/news] | Выводят заключенный в них текст, если посетитель просматривает полную новость указанных в параметре тега новостей, где 1,2,3 это ID новостей.
[not-news=1,2,3] текст [/not-news] | Выводит текст на любых других страницах кроме просмотра указанных в теге новостей.
[tags=тег1,тег2,тег3] текст [/tags] | Выводят заключенный в них текст если посетитель просматривает страницы с перечисленными ключевыми словами из облака тегов, где тег1,тег2,тег3 это ключевые слова из облака тегов.
[not-tags=тег1,тег2,тег3] текст [/not-tags] | Выводит текст на любых других страницах кроме указанных в теге.
[related-news] {related-news} [/related-news] | Выводят блок похожих новостей при просмотре полной новости.
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex
{catmenu} | Выводит меню из категорий сайта. Оформление меню осуществляется в шаблоне categorymenu.tpl
{catnewscount id="X"} | Выводит количество публикаций для указанной категории, где X это ID нужной вам категории.
{category-id} | Выводит ID просматриваемой посетителем сайта категории. Данный тег будет полезен при организации меню на сайте, а также когда нужно быстро переназначить какие-либо CSS классы или сами имена файлов шаблонов, при оформлении шаблонов вывода публикаций.
{category-title} | Выводит имя просматриваемой посетителем сайта категории. Данный тег будет полезен, когда на сайте нужно отдельно вывести имя просматриваемой категории.
{category-description} | Выводит заданное описание категории, когда пользователь просматривает данную категорию, также вывод доступен и при выводе полных публикаций.
{page-title} | Выводит указанный вами в разделе "Заголовки, описания, метатеги" заголовок для страницы
[category-icon] текст [/category-icon] | Выводят текст, заключенный в них если в просматриваемой категории задана иконка для категории. Также данные теги работают при просмотре полной новости и учитывается категория публикации.
[not-category-icon] текст [/not-category-icon] | Выводят текст, заключенный в них если в просматриваемой категории не задана иконка для категории, либо просматривается не категория
{category-icon} | Выводит URL иконки категории.
{page-description} | Выводит указанное вами в разделе "Заголовки, описания, метатеги" описание для страницы
[page-title] текст [/page-title] | Выводят текст, заключенный в них если в модуле "Заголовки, описания, метатеги" был задан заголовок для просматриваемой страницы.
[not-page-title] текст [/not-page-title] | Выводят текст, заключенный в них если заголовок для просматриваемой страницы не был задан.
[page-description] текст [/page-description] | Выводят текст, заключенный в них если в модуле "Заголовки, описания, метатеги" было задано описание для просматриваемой страницы
[not-page-description] текст [/not-page-description] | Выводят текст, заключенный в них если описание для просматриваемой страницы не было задано.
[navigation] текст [/navigation] | Выводит текст, заключённый в них если навигация по новостям имеется
[not-navigation] текст [/not-navigation] | Выводит текст, заключённый в них если навигация отсутствует
{navigation} | Выводит блок навигации по страницам
{cloudstag} | Выводит ключевое слово из облако тегов, при просмотре раздела сайта, который показывает публикации по определённому ключевому слову из облака тегов
[xfvalue_x] | Значение дополнительного поля "x", где "x" название дополнительного поля
[xfvalue_X limit="X2"] | Выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое. Доступно только при просмотре полной новости.
[xfnotgiven_X] [/xfnotgiven_X] | Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля. Доступно только при просмотре полной новости.
[ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue] | Выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую. Доступно только при просмотре полной новости.
[ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue] | Выводят текст заключенный в них, если значение поля не совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую. Доступно только при просмотре полной новости.
[xfvalue_thumb_url_X] | Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для уменьшенной копии загруженного изображения, где "х" это имя дополнительного поля. Доступно только при просмотре полной новости.
[xfvalue_image_url_X] | Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для полноразмерной картинки загруженного изображения, где "х" это имя дополнительного поля. Доступно только при просмотре полной новости.
[xfvalue_image_description_X] | Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только описание для загруженного изображения, где "х" это имя дополнительного поля. Доступно только при просмотре полной новости.
[xfvalue_X image="Nr"] | Выводит загруженные для дополнительного поля с типом "Галерея" изображения, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Например, при использовании [xfvalue_test image="2"] будет выведено изображение номер два, загруженное в дополнительное поле с именем "test". Доступно только при просмотре полной новости.
[xfvalue_X image-url="Nr"] | Выводит загруженные для дополнительного поля с типом "Галерея" URL полных изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Доступно только при просмотре полной новости.
[xfvalue_X image-thumb-url="Nr"] | Выводит загруженные для дополнительного поля с типом "Галерея" URL уменьшенных копий изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Доступно только при просмотре полной новости.
[xfvalue_X image-description="Nr"] | Выводит загруженные для дополнительного поля с типом "Галерея" описания изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Доступно только при просмотре полной новости.
[xfgiven_X image="NR"] текст [/xfgiven_X image="NR"] | Выводят текст заключённый в них если изображение с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения. Доступно только при просмотре полной новости. Доступно только при просмотре полной новости.
[xfnotgiven_X image="NR"] Текст [/xfnotgiven_X image="NR"] | Выводят текст заключённый в них если изображение с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения. Доступно только при просмотре полной новости. Доступно только при просмотре полной новости.
[xfvalue_X video="Nr"] | Выводит загруженные для дополнительного поля с типом "Видео плейлист" видео c выбранным номером по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста. Доступно только при просмотре полной новости.
[xfvalue_X video-url="Nr"] | Выводит загруженные для дополнительного поля с типом "Видео плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста. Доступно только при просмотре полной новости.
[xfvalue_X video-description="Nr"] | Выводит загруженные для дополнительного поля с типом "Видео плейлист" описания видео, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста
[xfgiven_X video="Nr"] Текст [/xfgiven_X video="Nr"] | Выводят текст заключённый в них если видео с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер видео. Доступно только при просмотре полной новости.
[xfnotgiven_X video="Nr"] Текст [/xfnotgiven_X video="Nr"] | Выводят текст заключённый в них если видео с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер видео. Доступно только при просмотре полной новости.
[xfvalue_X audio="Nr"] | выводит загруженные для дополнительного поля с типом "Аудио плейлист" видео по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста. Доступно только при просмотре полной новости.
[xfvalue_X audio-url="Nr"] | Выводит загруженные для дополнительного поля с типом "Аудио плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста. Доступно только при просмотре полной новости.
[xfvalue_X audio-description="Nr"] | Выводит загруженные для дополнительного поля с типом "Аудио плейлист" описания аудио файла, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста. Доступно только при просмотре полной новости.
[xfgiven_X audio="Nr"] текст [/xfgiven_X audio="Nr"] | Выводят текст заключённый в них если аудио с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла. Доступно только при просмотре полной новости.
[xfnotgiven_X audio="Nr"] Текст [/xfnotgiven_X audio="Nr"] | Выводят текст заключённый в них если аудио с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла. Доступно только при просмотре полной новости.


Панель авторизации на сайте

Навигация: Шаблоны >

Панель авторизации на сайте

Вывод данного раздела настраивается в файле login.tpl В данном разделе настраивается вывод панели авторизации посетителя на сайте. Возможно использование следующих тегов:

{registration-link} | Ссылка на страницу регистрации посетителя
{lostpassword-link} | Ссылка на страницу восстановления пароля
{login} | Логин пользователя
{logout-link} | Ссылка на разлогинивание пользователя на сайте
{admin-link} | Ссылка на админпанель скрипта
{pm-link} | Ссылка на страницу персональных сообщений
{new-pm} | Количество новых персональных сообщений
{all-pm} | Общее количество персональных сообщений
{favorite-count} | Количество новостей, добавленных пользователем себе в закладки на сайте
{foto} | Ссылка на аватар пользователя.
[admin-link] и [/admin-link] | Выводит текст в тегах, если пользователь имеет доступ к админпанели скрипта
{profile-link} | Ссылка на профиль пользователя
{stats-link} | Ссылка на статистику на сайте
{addnews-link} | Ссылка на страницу добавления новости на сайте
{favorites-link} | Ссылка на просмотр закладок пользователя
{newposts-link} | Ссылка на просмотр непрочитанных новостей пользователем с последнего посещения им сайта
{group-icon} | Выводит иконку группы пользователя
{login-method} | В зависимости от установленного в настройках скрипта типа авторизации, вывод что необходимо вводить пользователю: логин или E-mail
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_x] текст [/xfnotgiven_x] | Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
[xfvalue_x] | Выводится значение дополнительного поля "x", где "x" название дополнительного поля
{group} | Выводит название группы пользователя сайта в которой он находится в данный момент


Краткое содержание

Навигация: Шаблоны >

Краткое содержание

Вывод кратких новостей настраивается в файле shortstory.tpl и возможно использование следующих тегов:

{title}

Выводится заголовок статьи

{title limit="x"}

Выводится урезанный до X количества символов, заголовок новости.

{news-id}

ID номер новости, это номер под которым данная новость храниться в базе данных

{short-story}

Выводится краткая новость

{short-story limit="x"}

Выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов.

{author}

Автор статьи

{date}

Дата публикации, формат вывода даты настраивается в настройках системы

[new] Текст [/new]

Выводят текст заключённый в них если публикация считается новой, если с момента публикации меньше больше указанного в настройках времени.

[not-new] Текст [/not-new]

Выводят текст, заключённый в них, если с момента публикации прошло больше указанного в настройках времени.

[updated] Текст [/updated]

Выводят текст заключённый в них если публикация считается обновлённой, если с момента редактирования прошло меньше указанного в настройках времени

[not-updated] Текст [/not-updated]

Выводят текст, заключённый в них, если с момента редактирования прошло больше указанного в настройках времени

{rating}

Отображение рейтинга новости

[rating] текст [/rating]

Выводят заключенный в них текст, только если рейтинг для новости включен и убирают содержимое, если он был отключен при добавлении новости.

[rating-type-1] текст [/rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-3] текст [/rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[rating-type-4] текст [/rating-type-4]

Выводят текст, заключенный в теге, в случае если в настройках включено использование четвертого типа рейтинга 'Нравится' и 'Не нравится'.

[rating-minus] текст [/rating-minus]

Выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга публикации, выводится данная ссылка только если используется третий тип рейтинга.

[rating-plus] текст [/rating-plus]

Выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга публикации, выводится данная ссылка только если используется второй и третий тип рейтинга.

{likes}

Выводит количество лайков

{dislikes}

Выводит количество дизлайков

{vote-num}

Выводит количество пользователей, выставивших рейтинг для данной новости

{ratingscore}

Выводит число усредненного рейтинга от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д.

{comments-num}

Отображает количество комментариев , написанных к статье

{category}

Категория, к которой относится статья

{category-icon}

ссылка на иконку категории, внимание выводится именно путь к картинке, сам вывод вы должны предусмотреть самостоятельно например <img src="{category-icon}" />

{views}

Количество просмотров новости

{favorites}

Ссылка на добавление или удаление из Избранного

[add-favorites] текст [/add-favorites]

Выводят текст в них в виде ссылки на добавление новость в закладки на сайте

[del-favorites] текст [/del-favorites]

Выводят текст в них в виде ссылки удаление новости из закладок на сайте

[edit] текст [/edit]

Ссылка редактирование новости

[del] текст [/del]

Выводят ссылку на удаление публикации с сайта для пользователей

{link-category}

Ссылка на все категории в которой присутствует новость

[full-link] и [/full-link]

Ссылка на полную версию, например [full-link]Подробнее…[/full-link]

[com-link] и [/com-link]

Ссылка на комментарии к статье, выводится только если они разрешены

[xfvalue_x]

Значение дополнительного поля "x", где "x" название дополнительного поля

[xfvalue_X limit="X2"]

Выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test

[xfgiven_x] [xfvalue_x] [/xfgiven_x]

Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается

[xfnotgiven_X] [/xfnotgiven_X]

Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля

[ifxfset fields="X"] текст [/ifxfset]

Выводят текст заключённый в них если поле с именем X было задано и заполнено для новости. При этом вы можете перечислить несколько имён полей через запятую. Например [ifxfset fields="test1,test2"]оба поля с именем test1 и test2 заполнены[/ifxfset] выведет текст если оба поля были заполнены в новости. Основное отличие от существующих тегов [xfgiven_x] и [xfnotgiven_x] заключается в том, что вы одновременно можете перечислить несколько полей и проверяется заполненность всех перечисленных полей одновременно, а также проверяется именно заполненность полей без значений, например если у поля задано “0” или значение “нет”, это тоже является заполненным полем в публикации.

[ifxfnotset fields="X"] текст [/ifxfnotset]

выводят текст заключённый в них если поле с именем X не было задано и заполнено для новости. При этом вы также можете перечислить несколько имён полей через запятую. Например [ifxfnotset fields="test1,test2"]оба поля с именем test1 и test2 не были заполнены[/ifxfnotset] выведет текст если оба поля не были заполнены в новости. Основное отличие от существующих тегов [xfgiven_x] и [xfnotgiven_x] заключается в том, что вы одновременно можете перечислить несколько полей и проверяется заполненность всех перечисленных полей одновременно, а также проверяется именно заполненность полей без значений, например если у поля задано “0” или значение “нет”, это тоже является заполненным полем в публикации.

[ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue]

Выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую.

[ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue]

Выводят текст заключенный в них, если значение поля не совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую.

[xfvalue_thumb_url_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для уменьшенной копии загруженного изображения, где "х" это имя дополнительного поля

[xfvalue_image_url_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для полноразмерной картинки загруженного изображения, где "х" это имя дополнительного поля

[xfvalue_image_description_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только описание для загруженного изображения, где "х" это имя дополнительного поля.

[xfvalue_X image="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" изображения, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Например, при использовании [xfvalue_test image="2"] будет выведено изображение номер два, загруженное в дополнительное поле с именем "test".

[xfvalue_X image-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" URL полных изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfvalue_X image-thumb-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" URL уменьшенных копий изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfvalue_X image-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" описания изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfgiven_X image="NR"] текст [/xfgiven_X image="NR"]

Выводят текст заключённый в них если изображение с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения

[xfnotgiven_X image="NR"] Текст [/xfnotgiven_X image="NR"]

Выводят текст заключённый в них если изображение с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения

[xfvalue_X video="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" видео c выбранным номером по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста.

[xfvalue_X video-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста

[xfvalue_X video-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" описания видео, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста

[xfgiven_X video="Nr"] Текст [/xfgiven_X video="Nr"]

Выводят текст заключённый в них если видео с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер видео

[xfnotgiven_X video="Nr"] Текст [/xfnotgiven_X video="Nr"]

Выводят текст заключённый в них если видео с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер видео

[xfvalue_X audio="Nr"]

выводит загруженные для дополнительного поля с типом "Аудио плейлист" видео по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfvalue_X audio-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Аудио плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfvalue_X audio-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Аудио плейлист" описания аудио файла, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfgiven_X audio="Nr"] текст [/xfgiven_X audio="Nr"]

Выводят текст заключённый в них если аудио с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла

[xfnotgiven_X audio="Nr"] Текст [/xfnotgiven_X audio="Nr"]

Выводят текст заключённый в них если аудио с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла

[xfvalue_X format="Формат"]

Предназначено для вывода дополнительных полей с типом “Дата и время” где X это имя дополнительного поля, а “Формат” это формат вывода заданной в поле даты и времени. Вы можете выводить данное дополнительное поле в разных форматах даты и времени, а не только в том формате, которое указано для поля по умолчанию в настройках поля. Например тег [xfvalue_test format="j F Y H:i"] выведет дату и время указанное в поле в формате времени j F Y H:i.

[group=X]текст[/group]

Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.

[category=X]текст[/category]

Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую

[has-category] текст [/has-category]

Выводят текст, заключённых в них, если публикация находится в какой-либо категории

[not-has-category] текст [/not-has-category]

Выводят текст, заключённых в них, если у публикации нет никаких категорий.

[category-icon] текст [/category-icon]

Выводят текст, заключенный в них, если для категории, где находится публикация, была задана иконка в настройках категории

[not-category-icon] текст [/not-category-icon]

Выводят текст если для категории, где находится публикация, не задана иконка

[tags] текст [/tags]

Выводит текст если новость содержит ключевые слова, назначенные для облака тегов

{tags}

Выводит кликабельные ключевые слова новости

{full-link}

Для вывода полного постоянного адреса новости

[edit-date] текст [/edit-date]

Выводит текст если новость была отредактирована

{edit-date}

Выводит дату редактирования новости

{edit-date=формат даты}

Выводит дату редактирования публикации в заданном в теге формате. Тем самым вы можете задавать свой собственный формат для даты редактирования, или выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {edit-date=d} выведет день месяца, а тег {edit-date=F} выведет название месяца, а тег {edit-date=d-m-Y H:i} выведет полную дату и время

{editor}

Выводит логин пользователя, отредактировавшего новость

[edit-reason] текст [/edit-reason]

Выводит текст если при редактировании была указана причина редактирования

{edit-reason}

Выводит причину редактирования новости

{date=формат даты}

Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{approve}

Выводится только при просмотре пользователем собственного профиля и показывает статус его новостей ожидающих модерации

[fixed] текст [/fixed]

Выводит текст в тегах если данная новость зафиксирована

[not-fixed] текст [/not-fixed]

Выводит текст в тегах если данная новость не была зафиксирована

[day-news] текст [/day-news]

Выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}

[catlist=1,2....] текст [/catlist]

Выводит текст в теге, если новость принадлежит указанным категориям

[not-catlist=1,2....] текст [/not-catlist]

Выводит текст в теге, если новость не принадлежит указанным категориям.

{login}

Выводит логин пользователя добавившего новость в виде обычной текстовой информации без ссылок на профиль и карточку пользователя.

[poll] текст [/poll]

Выводят текст в данных тегах, если для данной публикации задан опрос.

{poll}

Выводит опрос, добавленный к новости

[not-poll] текст [/not-poll]

Выводят текст в данных тегах, если для данной публикации не был задан опрос.

[profile] текст [/profile]

Выводят прямую ссылку на профиль автора публикации, без использования всплывающего окна минипрофиля.

[complaint]

текст

[/complaint]

Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на новость.

{category-url}

Выводит полный URL на категорию, которой принадлежит данная новость. Данный тег выводит только URL в чистом виде без форматирования или готовой ссылки.

[comments]

текст

[/comments]

Выводят текст, заключенный в них, если у данной публикации присутствуют комментарии на сайте.

[not-comments]

текст

[/not-comments]

Выводят текст, заключенный в них, если у данной публикации отсутствуют комментарии на сайте.

{image-x}

Выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x]

Выводят текст указанный в них только в случае если картинка с номером X присутствует в новости

[not-image-x] текст [/not-image-x]

Выводят текст, указанный в них только в случае если картинка с номером X отсутствует в новости.

[tags=тег1,тег2,тег3] текст [/tags]

Выводят заключенный в них текст если посетитель просматривает страницы с перечисленными ключевыми словами из облака тегов, где тег1,тег2,тег3 это ключевые слова из облака тегов.

[not-tags=тег1,тег2,тег3] текст [/not-tags]

Выводит текст на любых других страницах кроме указанных в теге.

[declination=X] текст [/declination]

Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "комментарий", "комментария", "комментариев"

[newscount=x] текст [/newscount]

Выводит текст указанный в тегах если показывается X новость, где X это число показываемой на странице новости. Например [newscount=1] текст [/newscount] покажет текст при показе первой по счету на странице новости.

[not-newscount=X] текст [/not-newscount]

Выводят текст заключенный в данные теги при показе любых по счету новостей, кроме указанных X новостей. Данный тег будет полезен, если вы хотите выводить какие-либо элементы оформления во всех новостях при показе кратких новостей, кроме вышеуказанных. Например, что-либо не показывать в первой по списку новости.

{banner_x}

Выводит баннер добавленный в админпанели в разделе управления рекламными материалами. Где Х это имя баннера.

[not-news] текст [/not-news]

Выводят заключенный текст в них, в случае если публикации по данным критериям отсутствуют. Тем самым вы можете переназначить стандартное системное сообщение об отсутствии публикаций в каком-либо отдельном разделе сайта, сделав его уникальным, например, для каждого раздела сайта.

[if field = "значение"] текст [/if]

Выводят текст заключённых в них если значения поля равно указанному значению.

[if field = "значение"] текст [/if] - выведет текст если поле равно параметру 'значение'

[if field != "значение"]текст[/if] - выведет текст если поле не равно параметру 'значение'

[if field > "1"] текст [/if] - выведет текст если поле больше параметра 'значение'

[if field >= "2"] текст [/if] - выведет текст если поле больше либо равно параметру 'значение'

[if field < "3"] текст [/if] - выведет текст если поле меньше параметра 'значение'

[if field <= "4"] текст [/if] - выведет текст если поле меньше либо равно параметру 'значение'

[if field ~ "значение"] текст [/if] - выведет текст если в поле встречается текст 'значение'

[if field !~ "значение"] текст [/if] - выведет текст если в поле НЕ встречается текст 'значение'

Комбинированное использование:

[if field > "3" AND field2 < "5"] текст [/if] выведет текст если поле field больше трех, и при этом field2 меньше 5

[if field > "3" OR field2 < "5"] текст [/if] выведет текст если поле field больше трех или field2 меньше 5, то есть совпадение какого либо либого из условий

Имена полей, которое может принимать field:

id - Уникальный ID номер новости (число)

autor - Логин автора новости (текст)

date - Дата новости (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата новости округляется до минуты)

short_story - Текст короткой новости (текст)

full_story - В шаблоне короткой новости это количество символов в полном описании. В шаблоне полной новости непосредственно полный текст.

title - Текст заголовка новости (текст)

descr - Метатег описания новости (текст)

keywords - Метатег "ключевые слова" (текст)

category - Список категорий в которым принадлежит (массив, проверка по массиву ID категорий, которой принадлежит новость)

alt_name - Заголовок на латинице, для формирования адреса страницы при использовании ЧПУ. (текст)

comm_num - Количество комментариев (число)

allow_comm - Разрешены или нет комментарии (число, 1 или 0)

allow_main - Опубликована или нет новость на главной (число, 1 или 0)

approve - Новость опубликована на сайте или на модерации (число, 1 или 0)

fixed - Новость зафиксирована или нет (число, 1 или 0)

symbol - Символьный код (текст)

tags - Список тегов из списка тегов для облака тегов (массив, проверка по массиву слов из облака тегов)

news_read - Количество просмотров (число)

allow_rate - Разрешен рейтинг для новости или нет (число, 1 или 0)

rating - Рейтинг новости, общая сумма всех значений (число)

vote_num - Количество проголосовавших в рейтинге (число)

votes - Есть ли опрос в новости (число, 1 или 0)

view_edit - Отображать или нет причину редактирования (число, 1 или 0)

disable_index - Запрещена или нет индексация в поисковиках (число, 1 или 0)

editdate - Дата редактирования новости (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

editor - Логин последнего редактора публикации (текст)

reason - Причина редактирования новости (текст)

user_id - ID автора публикации (число)

xfield_x - Значение дополнительного поля публикации, где x это имя дополнительного поля. Например xfield_test значение дополнительного поля test

Список доступных тегов в случае включения вывода полной информации из профиля пользователя:

{profile-link}

Выводит ссылку на профиль автора публикации

{foto}

Выводит ссылку на аватар автора публикации

{fullname}

Выводит полное имя автора публикации

[fullname] текст [/fullname]

Выводит текст заключенный в теги в случае если полное имя указано в профиле автора

[not-fullname] текст [/not-fullname]

Выводит текст заключенный в теги в случае если полное имя не было указано в профиле автора

{land}

Выводит страну автора

[land] текст [/land]

Выводит текст заключенный в теги в случае если страна указана в профиле автора

[not-land] текст [/not-land]

Выводит текст заключенный в теги в случае если страна не была указана в профиле автора

{signature}

Выводит подпись автора

[signature] текст [/signature]

Выводит текст заключенный в теги в случае если подпись указана в профиле автора

[not-signature] текст [/not-signature]

Выводит текст заключенный в теги в случае если подпись не была указана в профиле автора

{user-info}

Выводит информацию о себе автора публикации

[user-info] текст [/user-info]

Выводит текст заключенный в теги в случае если информация о себе указана в профиле автора

[not-user-info] текст [/not-user-info]

Выводит текст заключенный в теги в случае если информация о себе не была указана в профиле автора

[online] текст [/online]

Выводит текст заключенный в теги в случае если автор публикации онлайн на сайте

[offline] текст [/offline]

Выводит текст заключенный в теги в случае если автор публикации оффлайн на сайте

{mail}

Выводит E-mail адрес пользователя

[pm] Текст [/pm]

Выводит ссылку с содержанием "Текст" на написание персонального сообшения автору публикации

{group}

Выводит группу пользователя

{registration}

Выводит дату регистрации пользователя

{lastdate}

Выводит дату последнего посещения пользователя

{group-icon}

Выводит иконку группы пользователя

{time_limit}

Выводит дату до которой пользователь находится в группе, если группа является временной

[time_limit] текст [/time_limit]

Выводит текст заключенный в теги в случае если пользователь находится во временной группе

{comm-num}

Выводит количество комментариев пользователя

{comments-url}

Выводит адрес ссылки на комментарии пользователя

[comm-num] текст [/comm-num]

Выводит текст заключенный в теги если пользователь имеет комментарии на сайте

[not-comm-num] текст [/not-comm-num]

Выводит текст заключенный в теги если пользователь не имеет комментариев на сайте

{news}

Выводит адрес ссылки на новости пользователя

{rss}

Выводит адрес ссылки на RSS новостей пользователя

{news-num}

Выводит количество новостей пользователя

[news-num] текст [/news-num]

Выводит текст заключенный в теги если пользователь имеет новости на сайте

[not-news-num] текст [/not-news-num]

Выводит текст заключенный в теги если пользователь не имеет новостей на сайте

{all-pm}

Выводит общее количество персональных сообщений пользователя

{favorite-count}

Выводит общее количество публикаций в закладках пользователя

[profile_xfvalue_X

Выводит значение дополнительного поля с именем "X" из его профиля

[profile_xfgiven_X] текст [/profile_xfgiven_X]

Выводит текст заключенный в теги если дополнительное поле с именем "X" указано в его профиле

[profile_xfnotgiven_X] текст [/profile_xfnotgiven_X]

Выводит текст заключенный в теги если дополнительное поле с именем "X" не указано в его профиле

[author-group=X] текст [/author-group]

Выводит текст заключенный в теги автор публикации находится в указанной группе "X" пользователей. Допускается перечесление групп через запятую, например: 1,2,3

[not-author-group=X] текст [/not-author-group]

Выводит текст заключенный в теги автор публикации не находится в указанной группе "X" пользователей. Допускается перечесление групп через запятую, например: 1,2,3


Статья целиком

Навигация: Шаблоны >

Статья целиком

Вывод статьи целиком настраивается в файле fullstory.tpl и возможно использование следующих тегов:

{title}

Заголовок статьи

{title limit="x"}

Выводится урезанный до X количества символов, заголовок новости.

{full-story}

Полная версия

{short-story}

Краткая версия новости

{full-story limit="x"}

Выводит только текст полной новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов

{author}

Автор статьи

{date}

Дата публикации

[new] Текст [/new]

Выводят текст заключённый в них если публикация считается новой, если с момента публикации меньше больше указанного в настройках времени.

[not-new] Текст [/not-new]

Выводят текст, заключённый в них, если с момента публикации прошло больше указанного в настройках времени.

[updated] Текст [/updated]

Выводят текст заключённый в них если публикация считается обновлённой, если с момента редактирования прошло меньше указанного в настройках времени

[not-updated] Текст [/not-updated]

Выводят текст, заключённый в них, если с момента редактирования прошло больше указанного в настройках времени

{pages}

Навигация по страницам новости

[pages] текст [/pages]

Выводят указанный текст в тегах, если новость разбита на несколько страниц при помощи тега {PАGEBREAK} и убирает текст в нем, если новость состоит из одной страницы.

{link-category}

Ссылка на все категрии в которой присутствует новость

{rating}

Выводится рейтинг публикации

[rating] текст [/rating]

Выводят заключенный в них текст, только если рейтинг для новости включен и убирают содержимое, если он был отключен при добавлении новости.

[rating-type-1] текст [/rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-3] текст [/rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[rating-type-4] текст [/rating-type-4]

Выводят текст, заключенный в теге, в случае если в настройках включено использование четвертого типа рейтинга 'Нравится' и 'Не нравится'.

[rating-minus] текст [/rating-minus]

Выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга публикации, выводится данная ссылка только если используется третий тип рейтинга.

[rating-plus] текст [/rating-plus]

Выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга публикации, выводится данная ссылка только если используется второй и третий тип рейтинга.

{likes}

Выводит количество лайков

{dislikes}

Выводит количество дизлайков

{vote-num}

Выводит количество пользователей, выставивших рейтинг для данной новости

{ratingscore}

Выводит число усредненного рейтинга от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д.

{comments-num}

Позволяет отображать количество комментариев к статье

{category}

Категория, к которой относится статья

{category-url}

Выводит полный URL на категорию, которой принадлежит данная новость. Данный тег выводит только URL в чистом виде без форматирования или готовой ссылки.

{category-icon}

Ссылка на иконку категории

[category-icon] текст [/category-icon]

Выводят текст, заключенный в них, если для категории, где находится публикация, была задана иконка в настройках категории

[not-category-icon] текст [/not-category-icon]

Выводят текст если для категории, где находится публикация, не задана иконка

[has-category] текст [/has-category]

Выводят текст, заключённых в них, если публикация находится в какой-либо категории

[not-has-category] текст [/not-has-category]

Выводят текст, заключённых в них, если у публикации нет никаких категорий.

{views}

Количество просмотров новости

{favorites}

Ссылка на добавление или удаление из Избранного

[add-favorites] текст [/add-favorites]

Выводят текст в них в виде ссылки на добавление новость в закладки на сайте

[del-favorites] текст [/del-favorites]

Выводят текст в них в виде ссылки удаление новости из закладок на сайте

[edit] текст [/edit]

Ссылка на редактирование новости

[del] текст [/del]

Выводят ссылку на удаление публикации с сайта для пользователей

[print-link] и [/print-link]

Ссылка на версию для печати

[com-link] и [/com-link]

Ссылка на комментарии к статье только если они разрешены

[xfvalue_x]

Значение дополнительного поля "x", где "x" название дополнительного поля

[xfvalue_X limit="X2"]

Выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test

[xfgiven_x] [xfvalue_x] [/xfgiven_x]

Выводится дополнительное поле "x", если поле не пустое

[xfnotgiven_X] [/xfnotgiven_X]

Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля

[ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue]

Выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую.

[ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue]

Выводят текст заключенный в них, если значение поля не совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую.

[xfvalue_thumb_url_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для уменьшенной копии загруженного изображения, где "х" это имя дополнительного поля

[xfvalue_image_url_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для полноразмерной картинки загруженного изображения, где "х" это имя дополнительного поля

[xfvalue_image_description_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только описание для загруженного изображения, где "х" это имя дополнительного поля.

[xfvalue_X image="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" изображения, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Например, при использовании [xfvalue_test image="2"] будет выведено изображение номер два, загруженное в дополнительное поле с именем "test".

[xfvalue_X image-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" URL полных изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfvalue_X image-thumb-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" URL уменьшенных копий изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfvalue_X image-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" описания изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfgiven_X image="NR"] текст [/xfgiven_X image="NR"]

Выводят текст заключённый в них если изображение с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения

[xfnotgiven_X image="NR"] Текст [/xfnotgiven_X image="NR"]

Выводят текст заключённый в них если изображение с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения

[ifxfset fields="X"] текст [/ifxfset]

Выводят текст заключённый в них если поле с именем X было задано и заполнено для новости. При этом вы можете перечислить несколько имён полей через запятую. Например [ifxfset fields="test1,test2"]оба поля с именем test1 и test2 заполнены[/ifxfset] выведет текст если оба поля были заполнены в новости. Основное отличие от существующих тегов [xfgiven_x] и [xfnotgiven_x] заключается в том, что вы одновременно можете перечислить несколько полей и проверяется заполненность всех перечисленных полей одновременно, а также проверяется именно заполненность полей без значений, например если у поля задано “0” или значение “нет”, это тоже является заполненным полем в публикации.

[ifxfnotset fields="X"] текст [/ifxfnotset]

выводят текст заключённый в них если поле с именем X не было задано и заполнено для новости. При этом вы также можете перечислить несколько имён полей через запятую. Например [ifxfnotset fields="test1,test2"]оба поля с именем test1 и test2 не были заполнены[/ifxfnotset] выведет текст если оба поля не были заполнены в новости. Основное отличие от существующих тегов [xfgiven_x] и [xfnotgiven_x] заключается в том, что вы одновременно можете перечислить несколько полей и проверяется заполненность всех перечисленных полей одновременно, а также проверяется именно заполненность полей без значений, например если у поля задано “0” или значение “нет”, это тоже является заполненным полем в публикации.

[xfvalue_X video="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" видео c выбранным номером по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста.

[xfvalue_X video-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста

[xfvalue_X video-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" описания видео, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста

[xfgiven_X video="Nr"] Текст [/xfgiven_X video="Nr"]

Выводят текст заключённый в них если видео с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер видео

[xfnotgiven_X video="Nr"] Текст [/xfnotgiven_X video="Nr"]

Выводят текст заключённый в них если видео с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер видео

[xfvalue_X audio="Nr"]

выводит загруженные для дополнительного поля с типом "Аудио плейлист" видео по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfvalue_X audio-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Аудио плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfvalue_X audio-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Аудио плейлист" описания аудио файла, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfgiven_X audio="Nr"] текст [/xfgiven_X audio="Nr"]

Выводят текст заключённый в них если аудио с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла

[xfnotgiven_X audio="Nr"] Текст [/xfnotgiven_X audio="Nr"]

Выводят текст заключённый в них если аудио с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла

[xfvalue_X format="Формат"]

Предназначено для вывода дополнительных полей с типом “Дата и время” где X это имя дополнительного поля, а “Формат” это формат вывода заданной в поле даты и времени. Вы можете выводить данное дополнительное поле в разных форматах даты и времени, а не только в том формате, которое указано для поля по умолчанию в настройках поля. Например тег [xfvalue_test format="j F Y H:i"] выведет дату и время указанное в поле в формате времени j F Y H:i.

[group=X]текст[/group]

Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.

{related-news}

Выводить ссылки на 5 наиболее подходящих по контексту новостей.

[catlist=1,2....] текст [/catlist]

Выводит текст в теге, если новость принадлежит указанным категориям

[not-catlist=1,2....] текст [/not-catlist]

Выводит текст в теге, если новость не принадлежит указанным категориям.

[tags] текст [/tags]

Выводит текст если новость содержит ключевые слова, назначенные для облака тегов

{tags}

Выводит кликабельные ключевые слова новости

{full-link}

Для вывода полного постоянного адреса новости

[edit-date] текст [/edit-date]

Выводит текст если новость была отредактирована

{edit-date}

Выводит дату редактирования новости

{edit-date=формат даты}

Выводит дату редактирования публикации в заданном в теге формате. Тем самым вы можете задавать свой собственный формат для даты редактирования, или выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {edit-date=d} выведет день месяца, а тег {edit-date=F} выведет название месяца, а тег {edit-date=d-m-Y H:i} выведет полную дату и время

{editor}

Выводит логин пользователя, отредактировавшего новость

[edit-reason] текст [/edit-reason]

Выводит текст если при редактировании была указана причина редактирования

{edit-reason}

Выводит причину редактирования новости

{poll}

Подключает шаблон с опросом для новости, если опрос был добавлен к новости.

{date=формат даты}

выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

[fixed] текст [/fixed]

Выводит текст в тегах если данная новость зафиксирована

[not-fixed] текст [/not-fixed]

Выводит текст в тегах если данная новость не была зафиксирована

[day-news] текст [/day-news]

Выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}

{comments}

Выводит комментарии, написанные к данной новости. Данный тег будет полезен тем, кому необходимо разместить комментарии, например общем дизайне полной новости. Данный тег не является обязательным, в случае его отсутствия комментарии будут автоматически расположены скриптом ниже полной новости

{addcomments}

Выводит форму добавления комментариев на сайт, совместно с новым тегом {comments} вы можете размещать форму добавления комментариев как выше, так и ниже самих комментариев. Данный тег также не является обязательным, в случае его отсутствия форма будет автоматически расположена скриптом ниже полной новости

{navigation}

Выводит навигацию по комментариям, если комментарии расположены на нескольких страницах, совместно с новым тегом {comments} вы можете располагать навигацию по комментариям как выше, так и ниже самих комментариев. Данный тег также не является обязательным, в случае его отсутствия навигация будет автоматически расположена скриптом ниже полной новости

{login}

Выводит логин пользователя добавившего новость в виде обычной текстовой информации без ссылок на профиль и карточку пользователя.

{related-ids}

Выводит список ID похожих публикаций для данной новости. Данный тег полезен при совместном использовании с тегом {custom ...}, например тег {custom id="{related-ids}"}

[related-news]

текст

[/related-news]

Выводят информацию, заключенную в тегах, только если для данной новости присутствуют похожие новости, в противном случае информация удаляется из шаблона.

[poll] текст [/poll]

Выводят текст в данных тегах, если для данной публикации задан опрос.

[not-poll] текст [/not-poll]

Выводят текст в данных тегах, если для данной публикации не был задан опрос.

[profile] текст [/profile]

Выводят прямую ссылку на профиль автора публикации, без использования всплывающего окна минипрофиля.

[complaint]

текст

[/complaint]

Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на новость.

{custom}

Смотрите раздел "Вывод новостей на страницах"

[comments]

текст

[/comments]

Выводят текст, заключенный в них, если у данной публикации присутствуют комментарии на сайте.

[not-comments]

текст

[/not-comments]

Выводят текст, заключенный в них, если у данной публикации отсутствуют комментарии на сайте

{image-x}

Выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x]

Выводят текст указанный в них только в случае если картинка с номером X присутствует в новости

[not-image-x] текст [/not-image-x]

Выводят текст, указанный в них только в случае если картинка с номером X отсутствует в новости.

{fullimage-x}

Выводит URL картинки, находящийся в тексте полной новости, где "x" это номер картинки в новости

[fullimage-x] текст [/fullimage-x]

Выводят указанный в них текст, только если картинка с номером "x" присутствует в полной новости.

[news=1,2,3] текст [/news]

Выводят заключенный в них текст, если посетитель просматривает полную новость указанных в параметре тега новостей, где 1,2,3 это ID новостей.

[not-news=1,2,3] текст [/not-news]

Выводит текст на любых других страницах кроме просмотра указанных в теге новостей.

[declination=X] текст [/declination]

Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "комментарий", "комментария", "комментариев"

{banner_x}

Выводит баннер добавленный в админпанели в разделе управления рекламными материалами. Где Х это имя баннера.

[vk] текст [/vk]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте

{vk_url}

Выводит ссылку URL на авторизацию в соц. сети Вконтакте

[odnoklassniki] текст [/odnoklassniki]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники

{odnoklassniki_url}

Выводит ссылку URL на авторизацию в соц. сети Одноклассники

[facebook] текст [/facebook]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook

{facebook_url}

Выводит ссылку URL на авторизацию в соц. сети Facebook

[google] текст [/google]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google

{google_url}

Выводит ссылку URL на авторизацию в соц. сети Google

[mailru] текст [/mailru]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru

{mailru_url}

Выводит ссылку URL на авторизацию в соц. сети Mail.ru

[yandex] текст [/yandex]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex

{yandex_url}

Выводит ссылку URL на авторизацию в соц. сети Yandex

[comments-subscribe]

текст

[/comments-subscribe]

Выводят текст, заключенный в них в виде ссылки на подписку на уведомления о новых комментариях.

[next-url] Текст [/next-url]

Выводят текст заключенных в них, если следующая новость присутствует на сайте

{next-url}

Выводит URL следующей публикации

{next-title}

Выводит заголовок следующей публикации

[prev-url] Текст [/prev-url]

Выводят текст заключенных в них, если предыдущая новость присутствует на сайте

{prev-url}

Выводит URL предыдущей публикации

{prev-title}

Выводит заголовок предыдущей новости

[if field = "значение"] текст [/if]

Выводят текст заключённых в них если значения поля равно указанному значению.

[if field = "значение"] текст [/if] - выведет текст если поле равно параметру 'значение'

[if field != "значение"]текст[/if] - выведет текст если поле не равно параметру 'значение'

[if field > "1"] текст [/if] - выведет текст если поле больше параметра 'значение'

[if field >= "2"] текст [/if] - выведет текст если поле больше либо равно параметру 'значение'

[if field < "3"] текст [/if] - выведет текст если поле меньше параметра 'значение'

[if field <= "4"] текст [/if] - выведет текст если поле меньше либо равно параметру 'значение'

[if field ~ "значение"] текст [/if] - выведет текст если в поле встречается текст 'значение'

[if field !~ "значение"] текст [/if] - выведет текст если в поле НЕ встречается текст 'значение'

Комбинированное использование:

[if field > "3" AND field2 < "5"] текст [/if] выведет текст если поле field больше трех, и при этом field2 меньше 5

[if field > "3" OR field2 < "5"] текст [/if] выведет текст если поле field больше трех или field2 меньше 5, то есть совпадение какого либо либого из условий

Имена полей, которое может принимать field:

id - Уникальный ID номер новости (число)

autor - Логин автора новости (текст)

date - Дата новости (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата новости округляется до минуты)

short_story - Текст короткой новости (текст)

full_story - В шаблоне короткой новости это количество символов в полном описании. В шаблоне полной новости непосредственно полный текст.

title - Текст заголовка новости (текст)

descr - Метатег описания новости (текст)

keywords - Метатег "ключевые слова" (текст)

category - Список категорий в которым принадлежит (массив, проверка по массиву ID категорий, которой принадлежит новость)

alt_name - Заголовок на латинице, для формирования адреса страницы при использовании ЧПУ. (текст)

comm_num - Количество комментариев (число)

allow_comm - Разрешены или нет комментарии (число, 1 или 0)

allow_main - Опубликована или нет новость на главной (число, 1 или 0)

approve - Новость опубликована на сайте или на модерации (число, 1 или 0)

fixed - Новость зафиксирована или нет (число, 1 или 0)

symbol - Символьный код (текст)

tags - Список тегов из списка тегов для облака тегов (массив, проверка по массиву слов из облака тегов)

news_read - Количество просмотров (число)

allow_rate - Разрешен рейтинг для новости или нет (число, 1 или 0)

rating - Рейтинг новости, общая сумма всех значений (число)

vote_num - Количество проголосовавших в рейтинге (число)

votes - Есть ли опрос в новости (число, 1 или 0)

view_edit - Отображать или нет причину редактирования (число, 1 или 0)

disable_index - Запрещена или нет индексация в поисковиках (число, 1 или 0)

editdate - Дата редактирования новости (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

editor - Логин последнего редактора публикации (текст)

reason - Причина редактирования новости (текст)

user_id - ID автора публикации (число)

xfield_x - Значение дополнительного поля публикации, где x это имя дополнительного поля. Например xfield_test значение дополнительного поля test

Список доступных тегов в случае включения вывода полной информации из профиля пользователя:

{profile-link}

Выводит ссылку на профиль автора публикации

{foto}

Выводит ссылку на аватар автора публикации

{fullname}

Выводит полное имя автора публикации

[fullname] текст [/fullname]

Выводит текст заключенный в теги в случае если полное имя указано в профиле автора

[not-fullname] текст [/not-fullname]

Выводит текст заключенный в теги в случае если полное имя не было указано в профиле автора

{land}

Выводит страну автора

[land] текст [/land]

Выводит текст заключенный в теги в случае если страна указана в профиле автора

[not-land] текст [/not-land]

Выводит текст заключенный в теги в случае если страна не была указана в профиле автора

{signature}

Выводит подпись автора

[signature] текст [/signature]

Выводит текст заключенный в теги в случае если подпись указана в профиле автора

[not-signature] текст [/not-signature]

Выводит текст заключенный в теги в случае если подпись не была указана в профиле автора

{user-info}

Выводит информацию о себе автора публикации

[user-info] текст [/user-info]

Выводит текст заключенный в теги в случае если информация о себе указана в профиле автора

[not-user-info] текст [/not-user-info]

Выводит текст заключенный в теги в случае если информация о себе не была указана в профиле автора

[online] текст [/online]

Выводит текст заключенный в теги в случае если автор публикации онлайн на сайте

[offline] текст [/offline]

Выводит текст заключенный в теги в случае если автор публикации оффлайн на сайте

{mail}

Выводит E-mail адрес пользователя

[pm] Текст [/pm]

Выводит ссылку с содержанием "Текст" на написание персонального сообшения автору публикации

{group}

Выводит группу пользователя

{registration}

Выводит дату регистрации пользователя

{lastdate}

Выводит дату последнего посещения пользователя

{group-icon}

Выводит иконку группы пользователя

{time_limit}

Выводит дату до которой пользователь находится в группе, если группа является временной

[time_limit] текст [/time_limit]

Выводит текст заключенный в теги в случае если пользователь находится во временной группе

{comm-num}

Выводит количество комментариев пользователя

{comments-url}

Выводит адрес ссылки на комментарии пользователя

[comm-num] текст [/comm-num]

Выводит текст заключенный в теги если пользователь имеет комментарии на сайте

[not-comm-num] текст [/not-comm-num]

Выводит текст заключенный в теги если пользователь не имеет комментариев на сайте

{news}

Выводит адрес ссылки на новости пользователя

{rss}

Выводит адрес ссылки на RSS новостей пользователя

{news-num}

Выводит количество новостей пользователя

[news-num] текст [/news-num]

Выводит текст заключенный в теги если пользователь имеет новости на сайте

[not-news-num] текст [/not-news-num]

Выводит текст заключенный в теги если пользователь не имеет новостей на сайте

{all-pm}

Выводит общее количество персональных сообщений пользователя

{favorite-count}

Выводит общее количество публикаций в закладках пользователя

[profile_xfvalue_X]

Выводит значение дополнительного поля с именем "X" из его профиля

[profile_xfgiven_X] текст [/profile_xfgiven_X]

Выводит текст заключенный в теги если дополнительное поле с именем "X" указано в его профиле

[profile_xfnotgiven_X] текст [/profile_xfnotgiven_X]

Выводит текст заключенный в теги если дополнительное поле с именем "X" не указано в его профиле

[author-group=X] текст [/author-group]

Выводит текст заключенный в теги если автор публикации находится в указанной группе "X" пользователей. Допускается перечисление групп через запятую, например: 1,2,3

[not-author-group=X] текст [/not-author-group]

Выводят текст заключенный в теги если автор публикации не находится в указанной группе "X" пользователей. Допускается перечисление групп через запятую, например: 1,2,3

[allow-comments-subscribe] текст [/allow-comments-subscribe]

Выводят текст заключённый в них, в случае если пользователю разрешено подписываться на комментарии. Тем самым вы можете сделать оформление ссылки на подписку на комментарии в нужном вам блоке и скрывать его если подписка запрещена.

[comments-unsubscribe] текст [/comments-unsubscribe]

Выводят текст заключенный в них в виде ссылки на отписку от комментариев к данной публикации. Тем самым пользователи могут отписаться только от одной конкретной новости на сайте, ранее для этого им нужно было отписываться от всех публикаций.


Комментарии

Навигация: Шаблоны >

Комментарии

Вывод данного раздела настраивается в файле comments.tpl В данном разделе настраивается вывод комментариев для статьи.

{author}

Имя человека, оставившего комментарий

{mail}

е-mail человека, оставившего комментарий

{date}

Дата публикации комментария, формат вывода даты настраивается в настройках системы

{comment}

Текст комментария

{comment limit="X"}

Выводит текст комментария без HTML форматирования, при этом сам текст комментария сокращается до указанного "x" количества символов.

{comment-id}

Идентификационный номер комментария

{ip}

IP адрес человека, оставившего комментарий, просмотр доступен только администраторам сайта

[com-edit] и [/com-edit]

Ссылка на редактирование комментария только если это разрешено

[com-del] и [/com-del]

Ссылка на удаление комментария только если это разрешено

{news_title}

Выводит ссылку на новость при просмотре последних комментариев, при выводе комментариев в новости тег вырезается

{news-title}

Выводит HTML безопасный заголовок новости, которой принадлежит данный комментарий, при просмотре последних комментариев. При выводе комментариев в новости тег вырезается. Данный тег будет полезен при использовании пользовательского вывода комментариев и при показе последних комментариев.

{news-link}

Выводит URL новости, которой принадлежит данный комментарий, при просмотре последних комментариев. При выводе комментариев в новости тег вырезается. Данный тег будет полезен при использовании пользовательского вывода комментариев и при показе последних комментариев.

[images] текст [/images]

Выводят заключенный в них текст, в случае если к комментарию были загружены изображения

{images}

Выводит все загруженные для комментария изображения в виде галереи изображений

{foto}

Выводит ссылку на фотографию

{fullname}

Выводит полное имя пользователя

{land}

Выводит место жительства

[signature] и [/signature]

Выводит текст заключенный в теги, если пользователь задал подпись в профиле

{signature}

Выводит подпись пользователя

{registration}

Выводит дату регистрации на сайте

{lastdate}

Выводит дату последнего посещения сайта пользователя.

{lastdate=формат даты}

Выводит последнего посещения сайта пользователем в заданном в теге формате. Например тег {lastdate=d} выведет день месяца, а тег {lastdate=F} выведет название месяца, а тег {lastdate=d-m-Y H:i} выведет полную дату и время.

{registration=формат даты}

Выводит дату регистрации пользователя в заданном в теге формате. Например тег {registration=d} выведет день месяца, а тег {registration=F} выведет название месяца, а тег {registration=d-m-Y H:i} выведет полную дату и время.

[fast] [/fast]

Быстрое цитирование комментариев

{group-icon}

Выводит иконку группы участника

{group-name}

Выводит имя группы участника

{news-num}

Выводит количество новостей участника

{comm-num}

Выводит количество комментариев участника

{date=формат даты}

Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{login}

Выводит логин автора комментария без каких либо ссылок и меню

[profile] текст [/profile]

Выводит текст заключенный в теге в виде ссылки на профиль пользователя оставившего комментарий

{mass-action}

Устанавливает возможность массовой отметки комментариев для выполнения массовых действий на сайте

[complaint]

текст

[/complaint]

Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на комментарий.

[xfgiven_x]

[xfvalue_x]

[/xfgiven_x]

Выводится дополнительное поле "x", если поле не пустое

[xfnotgiven_x]

текст

[/xfnotgiven_x]

Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя

[xfvalue_x]

Значение дополнительного поля "x", где "x" название дополнительного поля

[fullname]

текст [/fullname]

Выводится текст заключенный в них только если полное имя пользователя задано

[not-fullname]

текст [/not-fullname]

Выводится текст, заданный в них только если полное имя пользователя не задано

[land] текст [/land]

Выводится текст заключенный в них только если местожительство пользователя было им задано

[not-land] текст [/not-land]

Выводится текст, заданный в них только если местожительство пользователя не было им указано

[news-num]

текст

[/news-num]

Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте

[not-news-num]

текст

[/not-news-num]

Выводится текст заключенных в них если у данного пользователя нет новостей на сайте

[comm-num]

текст [/comm-num]

Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте

[not-comm-num]

текст [/not-comm-num]

Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте

[online] текст [/online]

Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)

[offline] текст [/offline]

Выводят текст если пользователь оффлайн

[spam] Спамер [/spam]

Выводят текст, указанных в них, в виде ссылки, при нажатии на которую происходит отметка посетителя, оставившего комментарий, как "спамера"

[declination=X] текст [/declination]

Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "комментарий", "комментария", "комментариев"

[commentsgroup=1,2,3]

текст

[/commentsgroup]

Выводят заключенный в них текст указанных в них, если комментарий был написан пользователем принадлежащем перечисленным группам

[not-commentsgroup=1,2,3]

текст

[/not-commentsgroup]

Выводят заключенный в них текст если комментарий был написан пользователем не принадлежащем указанным группам

[commentscount=x]

текст

[/commentscount]

Выводят текст указанный в тегах если показывается X комментарий, где X это число показываемого на странице комментария. Например [commentscount=1] текст [/commentscount] покажет текст при показе первого по счету на странице комментария. Данный тег полезен для вебмастеров, которые хотят например регулировать где им показывать рекламу на сайте между комментариями. Например, добавленный в самый конец шаблона код [commentscount=1,10] рекламный код [/commentscount], будет показывать рекламу после первого и десятого комментария.

[not-commentscount=X]

текст

[/not-commentscount]

Выводят текст заключенный в данные теги при показе любых по счету комментариев, кроме указанных X комментариях. Данный тег будет полезен, если вы хотите выводить какие-либо элементы оформления во всех по счету комментариях, кроме вышеуказанных. Например, что-либо не показывать в первом по списку комментарии.

[rating-type-1] текст [/rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-3] текст [/rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[rating-type-4] текст [/rating-type-4]

Выводят текст, заключенный в теге, в случае если в настройках включено использование четвертого типа рейтинга 'Нравится' и 'Не нравится'.

[rating-minus] текст [/rating-minus]

Выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга комментария, выводится данная ссылка только если используется третий и четвертый тип рейтинга.

[rating-plus] текст [/rating-plus]

Выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга комментария, выводится данная ссылка только если используется второй, третий и четвертый тип рейтинга.

{rating}

Выводит выставленный для комментария рейтинг.

{likes}

Выводит количество лайков

{dislikes}

Выводит количество дизлайков

{vote-num}

Выводит количество пользователей, которые выставили рейтинг для данного комментария.

{ratingscore}

Выводит число усредненного рейтинга от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д.

[reply] текст [/reply]

Выводят текст в них, в виде ссылки на открытие всплывающего окна для ответа на комментарий, в случае если включена поддержка древовидных комментариев, а в случае если она отключена вставляет логин выбранного комментатора в форму добавления комментариев

[replycount]

текст

[/replycount]

Выводят текст заключённый в них, если комментарий имеет ответы на него от других пользователей

[not-replycount]

текст

[/not-replycount]

Выводят текст заключённых в них если ответов на комментарий нет

[treecomments]

текст

[/treecomments]

Выводят текст, заключенных в них, в случае если включены древовидные комментарии в настройках скрипта.

[not-treecomments]

текст

[/not-treecomments]

Выводят текст, заключенный в них, в случае если древовидные комментарии отключены.

[rootcomments] текст [/rootcomments]

Выводят текст, заключенных в них, в случае если комментарий является основным родительским к новости, а не является ответом на какой-либо другой комментарий.

[childrencomments] текст [/childrencomments]

Выводят текст, заключенных в них, в случае если комментарий является ответом на другой комментарий.

{replycount}

Выводит количество имеющихся ответов на данный комментарий

[comments-author]

текст

[/comments-author]

Выводят текст, заключенный в них, если пользователь, просматривающий страницу сайта, является автором данного комментария

[not-comments-author]

текст

[/not-comments-author]

Выводят текст, заключенный в них, если пользователь, просматривающий страницу сайта, не является автором данного комментария

[news-author] текст [/news-author]

Выводят текст, заключенный в них, если комментарий принадлежит автору данной новости

[not-news-author]

текст

[/not-news-author]

Выводят текст, заключенный в них, если комментарий не принадлежит автору данной новости

[positive-comment]

текст

[/positive-comment]

Выводят текст, заключенный в них, если комментарий имеет позитивный рейтинг

[negative-comment]

текст

[/negative-comment]

Выводят текст, заключенный в них, если комментарий имеет негативный рейтинг

[neutral-comment]

текст

[/neutral-comment]

Выводят текст, заключенный в них, если комментарий имеет нейтральный рейтинг

[catlist=1,2....] текст [/catlist]

Выводит текст в теге, если новость принадлежит указанным категориям

[not-catlist=1,2....] текст [/not-catlist]

Выводит текст в теге, если новость не принадлежит указанным категориям.

{banner_X}

Выводит рекламу из модуля рекламных материалов в админпанели. Где X это имя рекламного баннера

[if field = "значение"] текст [/if]

Выводят текст заключённых в них если значения поля равно указанному значению.

[if field = "значение"] текст [/if] - выведет текст если поле равно параметру 'значение'

[if field != "значение"]текст[/if] - выведет текст если поле не равно параметру 'значение'

[if field > "1"] текст [/if] - выведет текст если поле больше параметра 'значение'

[if field >= "2"] текст [/if] - выведет текст если поле больше либо равно параметру 'значение'

[if field < "3"] текст [/if] - выведет текст если поле меньше параметра 'значение'

[if field <= "4"] текст [/if] - выведет текст если поле меньше либо равно параметру 'значение'

[if field ~ "значение"] текст [/if] - выведет текст если в поле встречается текст 'значение'

[if field !~ "значение"] текст [/if] - выведет текст если в поле НЕ встречается текст 'значение'

Комбинированное использование:

[if field > "3" AND field2 < "5"] текст [/if] выведет текст если поле field больше трех, и при этом field2 меньше 5

[if field > "3" OR field2 < "5"] текст [/if] выведет текст если поле field больше трех или field2 меньше 5, то есть совпадение какого либо либого из условий

Имена полей, которое может принимать field:

id - Уникальный ID номер комментария (число)

post_id - Уникальный ID номер публикации (число)

user_id - Уникальный ID номер пользователя оставившего комментарий если он зарегистрирован (число)

date - Дата комментария (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата новости округляется до минуты)

gast_name - Логин автора комментария (текст)

gast_email - Е-mail автора комментария (текст)

ip - IP пользователя оставившего комментарий (текст)

is_register - Зарегистрирован автор комментария на сайте или нет (число 1 или 0)

rating - Общий рейтинг комментария (число)

vote_num - Количество голосов в рейтинге комментария (число)

name - Логин автора комментария если он зарегистрирован. (текст)

email - E-mail автора комментария если он зарегистрирован (текст)

news_num - Количество публикаций автора комментария если он зарегистрирован (число)

comm_num - Количество комментариев автора комментария если он зарегистрирован (число)

user_group - Группа автора комментария если он зарегистрирован (число)

lastdate - Дата последнего посещения автора комментария если он зарегистрирован (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата новости округляется до минуты)

reg_date - Дата регистрации автора комментария если он зарегистрирован (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата новости округляется до минуты)

signature - Подпись автора комментария если он зарегистрирован (текст)

foto - Ссылка на аватар автора комментария если он зарегистрирован (текст)

fullname - Полное имя автора комментария если он зарегистрирован (текст)

land - Местожительства автора комментария если он зарегистрирован (текст)

xfield_x - Значение дополнительного поля профиля пользователя, где x это имя дополнительного поля. Например xfield_test значение дополнительного поля test


Меню категорий

Навигация: Шаблоны >

Меню категорий

Вывод данного раздела настраивается в файле categorymenu.tpl В данном разделе настраивается вывод меню из категорий публикаций.

[root] текст [/root] | Выводят текст, заключенный в них при первоначальной генерации шаблона меню. Данные теги могут использоваться для создания внешнего оформления меню. Например, для добавления внешних HTML элементов или элементов меню не входящих в список категорий.
[item] текст [/item] | Выводят каждый элемент категории при построении списка меню категорий. В тексте заключенном в этом теге выводится HTML оформление каждого пункта меню
[sub-prefix] текст [/sub-prefix] | Выводят текст, заключенных в них в виде префикса для подкатегорий, если категория является родительской и у нее есть подкатегории.
[sub-suffix] текст [/sub-suffix] | Выводят текст заключенных, в них в виде суффикса для подкатегорий, если категория является родительской и у нее есть подкатегории.
{sub-item} | Указывает место для вывода подкатегорий в родительской категории, в случае если у нее есть подкатегории. Данный тег может использоваться только внутри тегов [item] [/item]
{id} | Выводит ID категории.
{name} | Выводит имя категории. Данный тег может использоваться только внутри тегов [item] [/item]
{url} | Выводит URL категории. Данный тег может использоваться только внутри тегов [item] [/item]
{icon} | Выводит иконку категории. Данный тег может использоваться только внутри тегов [item] [/item]
[cat-icon] текст [/cat-icon] | Выводят текст, заключенный в них, если для категории, где находится публикация, была задана иконка в настройках категории
[not-cat-icon] текст [/not-cat-icon] | Выводят текст если для категории, где находится публикация, не задана иконка
{news-count} | Выводит количество публикаций в категории. Данный тег может использоваться только внутри тегов [item] [/item]
[active] текст [/active] | Выводят текст заключенный в них, если просматривая на сайте категория или новость, принадлежит категории из меню. Данный тег может использоваться только внутри тегов [item] [/item] и используется например для подветки активных категорий из меню.
[not-active] текст [/not-active] | Выводят текст, заключенный в них, если просматриваемая на сайте категория, или новость, не принадлежит категории из меню.
[isparent] текст [/isparent] | Выводят текст заключенный в них, если категория является родительской и содержит в себе подкатегории Данный тег может использоваться только внутри тегов [item] [/item].
{description} | Выводит описание категории
[description] текст [/description] | Выводят текст заключённый в них если задано описание категории
[not-description] текст [/not-description] | Выводят текст заключённый в них если не было задано описание категории
[not-parent] текст [/not-parent] | Выводят текст, заключённый в них, если категория не является родительской и не содержит в себе подкатегории
[is-children] текст [/is-children] | Выводят текст, заключённый в них, если категория является подкатегорией другой категории
[not-children] текст [/not-children] | Выводят текст заключённый в них, если категория не является подкатегорией другой категории

Пример простейшего шаблона меню категорий на основе HTML тегов ul и li:

[root]<ul class="catmenu">[/root]

[item]

<li><a href="{url}">{name}</a>

[sub-prefix]<ul>[/sub-prefix]{sub-item}[sub-suffix]</ul>[/sub-suffix]

</li>

[/item]

[root]</ul>[/root]


Скачивание файлов

Навигация: Шаблоны >

Скачивание файлов

Настройка вывода файлов для скачивания, загруженных через скрипт. Файл шаблона attachment.tpl. Допускается использование следующих тегов:

[allow-download] текст [/allow-download] | Выводят текст заключенных в них, если для пользователя сайта разрешено скачивание загруженных файлов
[not-allow-download] текст [/not-allow-download] | Выводят текст заключенных в них, если для пользователя сайта запрещено скачивание загруженных файлов.
[count] текст [/count] | Выводят текст заключенных в них, если в настройках скрипта включена поддержка счетчика скачиваний файла с сервера
{id} | Выводит уникальный ID номер загруженного файла, информация о котором хранится в базе данных
{name} | Выводит имя загруженного файла, либо текст указанный для имени файла в теге [аttachment=...] в тексте новости
{extension} | Выводит расширение загруженного к новости файла
{link} | Выводит URL на скачивание загруженного файла
{size} | Выводит размер загруженного файла
{md5} | Выводит контрольную сумму MD5 загруженного файла
{date} | Выводит дату загрузки файла на сервер, в формате даты, указанной в настройках скрипта
{date=формат даты} | Выводит дату в заданном в теге формате. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца загрузки файла, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
{count} | Выводит количество скачиваний файла с сервера
{online-view-link} | Выводит ссылку URL на просмотр документа онлайн в браузере
[allow-online] текст [/allow-online] | Выводят заключенный в них текст, если загруженный документ имеет поддерживаемый для просмотра формат


Форма добавления комментария

Навигация: Шаблоны >

Форма добавления комментария

Вывод данного раздела настраивается в файле addcomments.tpl В этом разделе настраиваются шаблоны, которые используются при добавлении комментариев в базу данных со стороны посетителей сайта. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{title} | Выводит заголовок, для чего эта форма, для добавления или редактирования комментариев
[not-logged] и [/not-logged] | Выводится код заключенный в теги, если пользователь не зарегистрирован, например вы можете заключить в эти теги поля для ввода имени и e-mail адреса, если они не заполнены и пользователь авторизован на сайте, эти данные будут взяты автоматически из его профиля.
{editor} | Выводит в зависимости от настроек BBCODE или WYSIWYG редактор для добавления комментария
{image-upload} | Выводит специальное поле куда пользователь может переместить картинки для загрузки, либо выбрать их с компьютера.
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при добавлении комментариев
{sec_code} | Выводит код отображения CAPTCHA
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | выводит вопрос для посетителя из заданного ранее списка вопросов и ответов
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex
[comments-subscribe] текст [/comments-subscribe] | Выводят текст, заключенный в них в виде ссылки на подписку на уведомления о новых комментариях.
[catlist=1,2....] текст [/catlist] | Выводит текст в теге, если новость принадлежит указанным категориям
[not-catlist=1,2....] текст [/not-catlist] | Выводит текст в теге, если новость не принадлежит указанным категориям.
[allow-comments-subscribe] текст [/allow-comments-subscribe] | Выводят текст заключённый в них, в случае если пользователю разрешено подписываться на комментарии. Тем самым вы можете сделать оформление ссылки на подписку на комментарии в нужном вам блоке и скрывать его если подписка запрещена.
[comments-unsubscribe] текст [/comments-unsubscribe] | Выводят текст заключенный в них в виде ссылки на отписку от комментариев к данной публикации. Тем самым пользователи могут отписаться только от одной конкретной новости на сайте, ранее для этого им нужно было отписываться от всех публикаций.
{comments-subscribe} | Выводит чекбокс на подписку на комментарии в форме добавления комментария.
{guest-name} | Выводит логин незарегистрованного пользователя, которое он вводил во время предыдущего добавления комментария.
{guest-mail} | Выводит E-Mail незарегистрованного пользователя, который он вводил во время предыдущего добавления комментария.


Опросы в новостях

Навигация: Шаблоны >

Опросы в новостях

Вывод данного раздела настраивается в файле poll.tpl В данном разделе настраивается вывод опроса для опубликованной новости

{title} | Заголовок опроса
{question} | Вопрос
{votes} | Общее количество голосов
{list} | Список вариантов ответа
[voted] текст [/voted] | Выводят текст в тегах если пользователь уже проголосовал в опросе, в противном случае его скрывают
[not-voted] текст [/not-voted] | Выводят текст в тегах если пользователь еще не проголосовал в опросе, в противном случае его скрывают
[closed] текст [/closed] | Выводят текст заключённый в них, если опрос был закрыт для голосования
[not-closed] текст [/not-closed] | Выводят текст заключённый в них, если опрос открыт для голосования посетителям сайта
{close-date} | Выводит дату закрытия опроса от голосований, если он был закрыт


Добавление новости

Навигация: Шаблоны >

Добавление новости

Вывод данной формы настраивается в файле addnews.tpl В этом разделе настраиваются шаблоны, которые используются при добавлении новости в базу данных со стороны посетителей сайта. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{header-title} | Выводит заголовок раздела в зависимости от того добавляется новость или редактируется существующая
{category} | Выводится поле для выбора категории к которой будет принадлежать категория
{xfields} | Вывод дополнительных полей при добавлении новости
[xfinput_X] | Выводит ваше выбранное дополнительное поле в форме добавления новости в нужном вам месте, где X это имя дополнительного поля для новостей
{admintag} | Вывод дополнительных опций для администратора
[urltag] и [/urltag] | Выводится код заключенный в теги, для изменения ЧПУ URL статьи (доступно администратору)
{shortarea} | Выводит WYSIWYG редактор для добавления краткой новости
{title} | Выводит заголовок во время редактирования новости
{alt-name} | Значение ЧПУ при редактировании новости
{short-story} | Короткая новость при редактировании новости
{full-story} | Полная новость при редактировании новости
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при добавлении новостей
{sec_code} | Код отображения CAPTCHA
{fullarea} | Выводит WYSIWYG редактор для добавления полной новости
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | Выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | Выводит вопрос для посетителя из заданного ранее списка вопросов и ответов
{votetitle} | Выводит заголовок опроса при редактировании новости
{frage} | Выводит вопрос из опроса при редактировании новости
{votebody} | Выводит список вариантов ответа из опроса при редактировнии новости
[allow-shortstory] текст [/allow-shortstory] | Выводят текст заключённый в них в случае, если в настройках скрипта включена поддержка поля краткого описания, и скрывают текст в случае данное поле отключено.
[allow-fullstory] текст [/allow-fullstory] | Выводят текст заключённый в них в случае, если в настройках скрипта включена поддержка поля полного описания, и скрывают текст в случае данное поле отключено

Имеется также возможность передавать в URL браузера категории, которые необходимо сделать выбранными по умолчанию. Для этого используется URL http://вашсайт.ru/index.php?do=addnews&category=X где "X" это ID нужных вам категорий, перечисленные через запятую. Например, по адресу http://вашсайт.ru/index.php?do=addnews&category=3,4,5 в форме добавления новости на сайте будут выбраны по умолчанию категории с ID 1, 2 и 3. Данное нововведение будет полезно для сайтов, которые используют доп. поля для публикаций назначенные разным категориям, и хотят дать пользователям при добавлении публикаций несколько уже предустановленных форм добавления публикации, для различных категорий.


Предосмотр новостей

Навигация: Шаблоны >

Предосмотр новостей

Вывод данного раздела настраивается в файле preview.tpl В этом разделе настраиваются шаблоны, предназначенные для предосмотра добавляемых новостей. В данном шаблоне вы можете использовать все теги для краткой и полной новости, а также статических страниц, при этом для разделения просматриваемых частей используются дополнительно теги:

[short-preview] и [/short-preview] выводит в тегах текст шаблона предназначенного для просмотра краткой новости

[full-preview] и [/full-preview] выводит в тегах текст шаблона предназначенного для просмотра полной новости

[static-preview] и [/static-preview] выводит в тегах текст шаблона предназначенного для просмотра статической страницы


Предыдущая и следующая страницы для новостей

Навигация: Шаблоны >

Предыдущая и следующая страницы для новостей

Вывод данного раздела настраивается в файле navigation.tpl В данном разделе настраивается вывод навигации для новостей

[prev-link] and [/prev-link] | Создает ссылку на предыдущую страницу (если такая есть)
[next-link] and [/next-link] | Создает ссылку на следующую страницу (если такая есть)
{pages} | Создает ссылки на страницы; например: 1 2 3 4


Регистрация на сайте

Навигация: Шаблоны >

Регистрация на сайте

Вывод данного раздела настраивается в файле registration.tpl В этом разделе настраиваются шаблоны, которые используются при регистрации посетителей на сайте. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

[registration] и [/registration] | Выводит текст заключенный в тегах при регистрации
[validation] и [/validation] | Выводит текст заключенный в тегах при активации
[sec_code] и [/sec_code] | Выводит текст заключенный в тегах если разрешен показ кода безопасности
{reg_code} | Выводит код безопасности для посетителя
{xfields} | Выводит поля для ввода дополнительных полей профиля
[xfinput_X] | Выводит ваше выбранное дополнительное поле в виде заполения поля в нужном вам месте, где X это имя дополнительного поля
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | Выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | Выводит вопрос для посетителя из заданного ранее списка вопросов и ответов
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex


Профиль пользователя

Навигация: Шаблоны >

Профиль пользователя

Вывод данного раздела настраивается в файле userinfo.tpl В этом разделе настраиваются шаблоны, которые используются при выводе профиля пользователя. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{user-id}

Вывод ID пользователя. Данный тег может использоваться в ряде случаев при оформлении шаблона, а также, например для формирования пользовательских ссылок, например ссылок на последние комментарии пользователя и т.д.

{usertitle}

Вывод имени пользователя

{info}

Краткая информация о пользователе

{editmail}

Выводит Е-mail адрес пользователя

{comm-num}

Выводит количество комментариев

{news-num}

Выводит количество новостей пользователя

{status}

Статус пользователя (его группа на сайте)

{rate}

Текущий рейтинг новостей посетителя (складывается автоматически на основе рейтинга его статей)

[rating-type-1] текст [/rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-3] текст [/rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[comments-rating-type-1]

текст [/comments-rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев первого типа рейтинга 'Оценка'.

[comments-rating-type-2]

текст [/comments-rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.

[comments-rating-type-3]

текст [/comments-rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев третьего типа рейтинга 'Нравится' или 'Не нравится'.

{commentsrate}

Выводит суммарный рейтинг всех комментариев данного пользователя.

{ratingscore}

Выводит число усреднённого рейтинга всех публикаций пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д. Данный тег позволяет задать, например, собственное оформление звезд рейтинга с частичным заполнением, а не только 2 или 4 заполненных звезды.

{commentsratingscore}

Выводит число усредненного рейтинга всех комментариев пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д.

{registration}

Выводит его дату регистрации на сайте

{editinfo}

Вывод существующей краткой информации в поле при редактировании профиля

{hidemail}

Выводить чекбокс на скрытие e-mail адреса.

{foto}

Выводит ссылку на загруженную фотографию

{fullname}

Выводит полное имя пользователя

{land}

Выводит место жительства пользователя

[own-profile] Текст [/own-profile]

Выводят текст, заключённый в них, в случае если пользователь просматривает собственный профиль на сайте

[not-own-profile] текст [/not-own-profile]

Выводят текст, заключённый в них, в случае если пользователь просматривает чужой профиль на сайте

[not-logged] и [/not-logged]

Выводится код заключенный в теги, если пользователь который просматривает профиль и есть этот самый пользователь либо администратор сайта, используется для того чтобы посетители могли редактировать свой собственный профиль.

[signature] и [/signature]

Выводит текст заключенный в теги, если пользователь задал подпись в профиле

{signature}

Выводит подпись пользователя

{editsignature}

Выводит отформатированную для редактирования подпись пользователя

{lastdate}

Выводит дату последнего посещения сайта пользователем

{comments}

Выводит ссылку на все комментарии этого пользователя

{allowed-ip}

Значение IP с которого разрешена авторизация

{xfields}

Выводится Список дополнительных полей профиля при их редактировании

[xfinput_X]

Выводит ваше выбранное дополнительное поле в виде заполения поля в нужном вам месте, где X это имя дополнительного поля

[xfvalue_x]

Выводится значение дополнительного поля "x", где "x" название дополнительного поля

[xfgiven_x] [xfvalue_x] [/xfgiven_x]

Выводится дополнительное поле "x", если поле не пустое

[xfnotgiven_x]

текст

[/xfnotgiven_x]

Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя

{group-icon}

Выводит иконку группы участника

[time_limit] [/time_limit]

Выводит текст между тегами если пользователь находится во временной группе

{time_limit}

Выводит дату, до которой пользователь находится во временной группе

{news}

Выводит ссылку на просмотр всех новостей данного пользователя

[rss] тект [/rss]

Выводит ссылку в профиле на RSS поток всех новостей пользователя.

{ignore-list}

Список пользователей, добавленных в игнорируемые.

[fullname]

текст [/fullname]

Выводится текст заключенный в них только если полное имя пользователя задано

[not-fullname]

текст [/not-fullname]

Выводится текст, заданный в них только если полное имя пользователя не задано

[land] текст [/land]

Выводится текст заключенный в них только если местожительство пользователя было им задано

[not-land] текст [/not-land]

Выводится текст, заданный в них только если местожительство пользователя не было им указано

[info] текст [/info]

Выводится текст заключенный в теги, если пользователь задал краткую информацию о себе в профиле

[not-info] текст [/not-info]

Выводится текст заключенный в теги, если пользователь не задавал краткую информацию о себе в профиле

[news-num]

текст

[/news-num]

Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте

[not-news-num]

текст

[/not-news-num]

Выводится текст заключенных в них если у данного пользователя нет новостей на сайте

[comm-num]

текст [/comm-num]

Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте

[not-comm-num]

текст [/not-comm-num]

Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте

[online] текст [/online]

Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)

[offline] текст [/offline]

Выводят текст если пользователь оффлайн

[profile-user-group=X] Текст [/profile-user-group]

Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, принадлежит указанной группе X. Где X это номер группы. Допускается также перечисление нужных групп через запятую.

[not-profile-user-group=X] Текст [/not-profile-user-group]

Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, не принадлежит указанной группе X. Где X это номер группы.

{timezones}

Выводит список доступных часовых поясов в системе, и позволяет пользователю выбрать свой часовой пояс для своего профиля на сайте.

{unsubscribe}

Выводит чекбокс на отписку от комментариев, и количество подписанных публикаций.

{news-subscribe}

Выводит чекбокс на подписку получения уведомлений о новых комментариях, которые добавляются к новостям, автором которых является пользователь.

{comments-reply-subscribe}

Выводит чекбокс на подписку получения уведомлений о новых комментариях, которые являются ответами на собственные комментарии пользователя.

{pm}

Ссылка на написание персонального сообщения пользователю

{email}

Ссылка на написание E-Mail сообщения пользователю

{twofactor-auth}

Выводит чекбокс для включения или отключения двухфакторной авторизации на сайте для пользователя

[banned] текст [/banned]

Выводят текст заключённый в них если пользователь в данный момент забанен на сайте

[not-banned] текст [/not-banned]

Выводят текст заключённый в них если пользователь не забанен на сайте

{ban-description}

Выводит причину по которой пользователь забанен

{ban-date}

Выводит дату до которой пользователь был забанен на сайте

[vk] текст [/vk]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте

{vk_url}

Выводит ссылку URL на авторизацию в соц. сети Вконтакте

[odnoklassniki] текст [/odnoklassniki]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники

{odnoklassniki_url}

Выводит ссылку URL на авторизацию в соц. сети Одноклассники

[facebook] текст [/facebook]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook

{facebook_url}

Выводит ссылку URL на авторизацию в соц. сети Facebook

[google] текст [/google]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google

{google_url}

Выводит ссылку URL на авторизацию в соц. сети Google

[mailru] текст [/mailru]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru

{mailru_url}

Выводит ссылку URL на авторизацию в соц. сети Mail.ru

[yandex] текст [/yandex]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex

{yandex_url}

Выводит ссылку URL на авторизацию в соц. сети Yandex

{social-list}

Выводит список привязанных социальных сетей и ссылки на их отключения от данного аккаунта

[attached-vk] текст [/attached-vk]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Вконтакте

[attached-odnoklassniki] текст [/attached-odnoklassniki]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Одноклассники

[attached-facebook] текст [/attached-facebook]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Facebook

[attached-google] текст [/attached-google]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Google

[attached-mailru] текст [/attached-mailru]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Mail.ru

[attached-yandex] текст [/attached-yandex]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Яндекс

[detach-vk] текст [/detach-vk]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Вконтакте, случае если аккаунт пользователя привязан к ней.

[detach-odnoklassniki] текст [/detach-odnoklassniki]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Одноклассники, случае если аккаунт пользователя привязан к ней.

[detach-facebook] текст [/detach-facebook]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Facebook, случае если аккаунт пользователя привязан к ней.

[detach-google] текст [/detach-google]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Google, случае если аккаунт пользователя привязан к ней.

[detach-mailru] текст [/detach-mailru]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Mail.ru, случае если аккаунт пользователя привязан к ней.

[detach-yandex] текст [/detach-yandex]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Яндекс, случае если аккаунт пользователя привязан к ней.

[ignore] текст [/ignore]

Выводят текст заключённый в них в виде ссылки на добавление пользователя в список игнорируемых

[delete] Текст [/delete]

Выводят текст заключённый в них в виде ссылки на удаление собственного профиля на сайте пользователем, в случае если это ему разрешено настройками групп пользователей

[if field = "значение"] текст [/if]

Выводят текст заключённых в них если значения поля равно указанному значению.

[if field = "значение"] текст [/if] - выведет текст если поле равно параметру 'значение'

[if field != "значение"]текст[/if] - выведет текст если поле не равно параметру 'значение'

[if field > "1"] текст [/if] - выведет текст если поле больше параметра 'значение'

[if field >= "2"] текст [/if] - выведет текст если поле больше либо равно параметру 'значение'

[if field < "3"] текст [/if] - выведет текст если поле меньше параметра 'значение'

[if field <= "4"] текст [/if] - выведет текст если поле меньше либо равно параметру 'значение'

[if field ~ "значение"] текст [/if] - выведет текст если в поле встречается текст 'значение'

[if field !~ "значение"] текст [/if] - выведет текст если в поле НЕ встречается текст 'значение'

Комбинированное использование:

[if field > "3" AND field2 < "5"] текст [/if] выведет текст если поле field больше трех, и при этом field2 меньше 5

[if field > "3" OR field2 < "5"] текст [/if] выведет текст если поле field больше трех или field2 меньше 5, то есть совпадение какого либо либого из условий

Имена полей, которое может принимать field:

name - Логин пользователя. (текст)

email - E-mail пользователя (текст)

user_id - Уникальный ID номер пользователя (число)

news_num - Количество публикаций пользователя (число)

comm_num - Количество комментариев пользователя (число)

user_group - Группа пользователя (число)

lastdate - Дата последнего посещения пользователя (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

reg_date - Дата регистрации пользователя (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

allow_mail - Разрешил ли пользователь получать письма с сайта (число 1 или 0)

info - Информация пользователя о себе (текст)

signature - Подпись пользователя (текст)

fullname - Полное имя пользователя (текст)

land - Местожительства пользователя (текст)

foto - Ссылка на аватар пользователя (текст)

pm_all - Количество персональных сообщений пользователя (число)

pm_unread - Количество непрочитанных персональных сообщений пользователя (число)

restricted - Наложены ли на пользователя ограничения (число 0 - ограничений нет, 1 - запрет на добавление публикаий 2 - запрет на добавление комментариев 3 - запрет на публикации и комментарии)

restricted_days - Количество дней на которое наложен запрет (число)

restricted_date - Дата до которой наложены запреты на пользователя (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

logged_ip - IP c которым пользователь заходил на сайт (текст)

timezone - Часовой пояс пользователя в формате часовых поясов, например Europe/Moscow (текст)

news_subscribe - Подписан ли пользователь на уведомления о новых публициях (число 1 или 0)

comments_reply_subscribe - Подписан ли пользователь на уведомления об ответах на свои комментарии (число 1 или 0)

twofactor_auth - Включил ли пользователь двухфакторную авторизацию (число 1 или 0)

cat_allow_addnews - Категории в которые пользователю разрешено добавлять публикации (массив ID категорий)

cat_add - Категории которые являются доверительными для пользователя при добавлении публикаций (массив ID категорий)

xfield_x - Значение дополнительного поля пользователя, где x это имя дополнительного поля. Например xfield_test значение дополнительного поля test


Карточка профиля пользователя

Навигация: Шаблоны >

Карточка профиля пользователя

Вывод данного раздела настраивается в файле profile_popup.tpl В этом разделе настраиваются шаблоны, которые используются при выводе карточки профиля пользователя.

{user-id}

Вывод ID пользователя. Данный тег может использоваться в ряде случаев при оформлении шаблона, а также, например для формирования пользовательских ссылок, например ссылок на последние комментарии пользователя и т.д.

{usertitle}

Выводит логин пользователя

{fullname}

Выводит полное имя пользователя

{foto}

Выводит ссылку на загруженную фотографию

{status}

Статус пользователя

{registration}

Дата регистрации на сайте

{lastdate}

Выводит дату последнего посещения сайта пользователем

{lastdate=формат даты}

Выводит последнего посещения сайта пользователем в заданном в теге формате. Например тег {lastdate=d} выведет день месяца, а тег {lastdate=F} выведет название месяца, а тег {lastdate=d-m-Y H:i} выведет полную дату и время.

{registration=формат даты}

Выводит дату регистрации пользователя в заданном в теге формате. Например тег {registration=d} выведет день месяца, а тег {registration=F} выведет название месяца, а тег {registration=d-m-Y H:i} выведет полную дату и время.

{comm-num}

Количество комментариев

{news-num}

Количество новостей

{land}

Выводит место жительства

{info}

Краткая информация о пользователе

[info] текст [/info]

Выводится текст заключенный в теги, если пользователь задал краткую информацию о себе в профиле

{rate}

Текущий рейтинг новостей посетителя (складывается автоматически на основе рейтинга его статей)

[own-profile] Текст [/own-profile]

Выводят текст, заключённый в них, в случае если пользователь просматривает собственный профиль на сайте

[not-own-profile] текст [/not-own-profile]

Выводят текст, заключённый в них, в случае если пользователь просматривает чужой профиль на сайте

[rating-type-1] текст [/rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-3] текст [/rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[comments-rating-type-1]

текст [/comments-rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.

[comments-rating-type-2]

текст [/comments-rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.

[comments-rating-type-3]

текст [/comments-rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев третьего типа рейтинга 'Нравится' или 'Не нравится'.

{commentsrate}

Выводит суммарный рейтинг всех комментариев данного пользователя.

{ratingscore}

Выводит число усреднённого рейтинга всех публикаций пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д. Данный тег позволяет задать, например, собственное оформление звезд рейтинга с частичным заполнением, а не только 2 или 4 заполненных звезды.

{commentsratingscore}

Выводит число усредненного рейтинга всех комментариев пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д.

[signature] и [/signature]

Выводит текст заключенный в теги, если пользователь задал подпись в профиле

{signature}

Выводит подпись пользователя

{group-icon}

Выводит иконку группы пользователя

{news}

Выводит ссылку на просмотр всех новостей данного пользователя

{comments}

Выводит ссылку на все комментарии этого пользователя

[rss] тект [/rss]

Выводит ссылку в профиле на RSS поток всех новостей пользователя

[fullname]

текст [/fullname]

Выводится текст заключенный в них только если полное имя пользователя задано

[not-fullname]

текст [/not-fullname]

Выводится текст, заданный в них только если полное имя пользователя не задано

[land] текст [/land]

Выводится текст заключенный в них только если местожительство пользователя было им задано

[not-land] текст [/not-land]

Выводится текст, заданный в них только если местожительство пользователя не было им указано

[news-num]

текст

[/news-num]

Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте

[not-news-num]

текст

[/not-news-num]

Выводится текст заключенных в них если у данного пользователя нет новостей на сайте

[comm-num]

текст [/comm-num]

Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте

[not-comm-num]

текст [/not-comm-num]

Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте

[xfgiven_x]

[xfvalue_x]

[/xfgiven_x]

Выводится дополнительное поле "x", если поле не пустое

[xfnotgiven_x]

текст

[/xfnotgiven_x]

Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя

[xfvalue_x]

Значение дополнительного поля "x", где "x" название дополнительного поля

[online] текст [/online]

Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)

[offline] текст [/offline]

Выводят текст если пользователь оффлайн

[profile-user-group=X] Текст [/profile-user-group]

Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, принадлежит указанной группе X. Где X это номер группы. Допускается также перечисление нужных групп через запятую.

[not-profile-user-group=X] Текст [/not-profile-user-group]

Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, не принадлежит указанной группе X. Где X это номер группы.

[ignore] текст [/ignore]

Выводят текст заключённый в них в виде ссылки на добавление пользователя в список игнорируемых

[banned] текст [/banned]

Выводят текст заключённый в них если пользователь в данный момент забанен на сайте

[not-banned] текст [/not-banned]

Выводят текст заключённый в них если пользователь не забанен на сайте

{ban-description}

Выводит причину по которой пользователь забанен

{ban-date}

Выводит дату до которой пользователь был забанен на сайте

[if field = "значение"] текст [/if]

Выводят текст заключённых в них если значения поля равно указанному значению.

[if field = "значение"] текст [/if] - выведет текст если поле равно параметру 'значение'

[if field != "значение"]текст[/if] - выведет текст если поле не равно параметру 'значение'

[if field > "1"] текст [/if] - выведет текст если поле больше параметра 'значение'

[if field >= "2"] текст [/if] - выведет текст если поле больше либо равно параметру 'значение'

[if field < "3"] текст [/if] - выведет текст если поле меньше параметра 'значение'

[if field <= "4"] текст [/if] - выведет текст если поле меньше либо равно параметру 'значение'

[if field ~ "значение"] текст [/if] - выведет текст если в поле встречается текст 'значение'

[if field !~ "значение"] текст [/if] - выведет текст если в поле НЕ встречается текст 'значение'

Комбинированное использование:

[if field > "3" AND field2 < "5"] текст [/if] выведет текст если поле field больше трех, и при этом field2 меньше 5

[if field > "3" OR field2 < "5"] текст [/if] выведет текст если поле field больше трех или field2 меньше 5, то есть совпадение какого либо либого из условий

Имена полей, которое может принимать field:

name - Логин пользователя. (текст)

email - E-mail пользователя (текст)

user_id - Уникальный ID номер пользователя (число)

news_num - Количество публикаций пользователя (число)

comm_num - Количество комментариев пользователя (число)

user_group - Группа пользователя (число)

lastdate - Дата последнего посещения пользователя (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

reg_date - Дата регистрации пользователя (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

allow_mail - Разрешил ли пользователь получать письма с сайта (число 1 или 0)

info - Информация пользователя о себе (текст)

signature - Подпись пользователя (текст)

fullname - Полное имя пользователя (текст)

land - Местожительства пользователя (текст)

foto - Ссылка на аватар пользователя (текст)

pm_all - Количество персональных сообщений пользователя (число)

pm_unread - Количество непрочитанных персональных сообщений пользователя (число)

restricted - Наложены ли на пользователя ограничения (число 0 - ограничений нет, 1 - запрет на добавление публикаий 2 - запрет на добавление комментариев 3 - запрет на публикации и комментарии)

restricted_days - Количество дней на которое наложен запрет (число)

restricted_date - Дата до которой наложены запреты на пользователя (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

logged_ip - IP c которым пользователь заходил на сайт (текст)

timezone - Часовой пояс пользователя в формате часовых поясов, например Europe/Moscow (текст)

news_subscribe - Подписан ли пользователь на уведомления о новых публициях (число 1 или 0)

comments_reply_subscribe - Подписан ли пользователь на уведомления об ответах на свои комментарии (число 1 или 0)

twofactor_auth - Включил ли пользователь двухфакторную авторизацию (число 1 или 0)

cat_allow_addnews - Категории в которые пользователю разрешено добавлять публикации (массив ID категорий)

cat_add - Категории которые являются доверительными для пользователя при добавлении публикаций (массив ID категорий)

xfield_x - Значение дополнительного поля пользователя, где x это имя дополнительного поля. Например xfield_test значение дополнительного поля test


Форма поиска

Навигация: Шаблоны >

Форма поиска

Вывод данного раздела настраивается в файле search.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод формы поиска по сайту:

{searchtable} | Форма поиска в виде таблицы
{searchmsg} | Вывод сообщения о результатах поиска
[searchmsg] и [/searchmsg] | Вывод текста в случае если был произведен поиск
[simple-search] текст [/simple-search] | Выводит текст заключенный в теги если производится поиск по сокращенным
[extended-search] текст [/extended-search] | Выводит текст заключенный в теги если производится поиск по расширеным параметрам
{searchfield} | Выводит поле для заполнения текста который необходимо найти
{word-option} | Выводит чекбокс параметра поиска заданного текста (точное совпадение всех слов или нет)
{search-area} | Выводит выбор области поиска на сайте
{userfield} | Выводит поле для ввода автора публикаций
{user-option} | Выводит чекбокс параметра поиска автора (точное совпадение всех слов или нет)
{news-option} | Выводит выбор параметров комментариев у новостей
{comments-num} | Выводит поле для ввода количества комментариев у новостей
{date-option} | Выводит выбор параметров даты у новостей
{date-beforeafter} | Выводит выбор параметров новее или старее даты у новостей нужно найти
{sort-option} | Выводит выбор параметров сортировки найденных результатов
{order-option} | Выводит выбор порядка сортировки (возрастание или убывание)
{view-option} | Выводит выбор режима отображения найденных результатов
{category-option} | Выводит выбор категорий в которых необходимо произвести поиск


Результаты поиска

Навигация: Шаблоны >

Результаты поиска

Вывод данного раздела настраивается в файле searchresult.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод новостей найденных в результате поиска:

[searchposts] и [/searchposts] | Вывод найденных результатов для новостей
[searchcomments] и [/searchcomments] | Вывод найденных результатов для комментариев
[fullresult] и [/fullresult] | Вывод результатов в виде статей
[shortresult] и [/shortresult] | Вывод результатов в виде заголовков

Внимание, в данном шаблоне для непосредственного вывода статей и комментариев используются полностью аналогичные теги как и в шаблонах вывода кратких новостей и комментариев.


Результаты быстрого поиска

Навигация: Шаблоны >

Результаты быстрого поиска

Вывод данного раздела настраивается в файле fastsearchresult.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод новостей найденных в результате быстрого поиска на сайте. В данном шаблоне для непосредственного вывода статей используются полностью аналогичные теги как и в шаблонах вывода кратких новостей


Статистика сайта

Навигация: Шаблоны >

Статистика сайта

Вывод данного раздела настраивается в файле stats.tpl В данном разделе настраивается вывод общей статистики сайта

{datenbank} | Общий размер базы данных
{news_num} | Общее количество новостей
{news_allow} | Опубликовано новостей
{news_main} | Опубликовано на главной
{news_moder} | Ожидает модерации
{comm_num} | Количество комментариев
{user_num} | Зарегистрировано пользователей
{user_banned} | Забаненных пользователей
{topusers} | Список лучших авторов на сайте
{news_day} | Опубликовано новостей за сутки
{news_week} | Опубликовано новостей за неделю
{news_month} | Опубликовано новостей за месяц
{comm_day} | Опубликовано комментариев за сутки
{comm_week} | Опубликовано комментариев за неделю
{comm_month} | Опубликовано комментариев за месяц
{user_day} | Зарегистрировано пользователей за сутки
{user_week} | Зарегистрировано пользователей за неделю
{user_month} | Зарегистрировано пользователей за месяц


Вывод информации и ошибок

Навигация: Шаблоны >

Вывод информации и ошибок

Вывод данного раздела настраивается в файле info.tpl В данном разделе настраивается вывод формы в случае возникновения ошибок, либо наоборот в случае успешного выполнения действий.

{title} – заголовок сообщения

{error} – текст ошибки


Форма для отправки E-Mail

Навигация: Шаблоны >

Форма для отправки E-Mail

Вывод данного раздела настраивается в файле feedback.tpl В этом разделе настраиваются шаблоны, которые используются при выводе формы для отправки E-Mail. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{recipient} - Выводит список получателей

[not-logged] и [/not-logged] - Выводит текст между тегами если посетитель не зарегистрирован

{code} - Выводит код отображения CAPTCHA

[sec_code] и [/sec_code] Выводит текст если в настройках скрипта включена стандартная CAPTCHA

[recaptcha] и [/recaptcha] Выводит текст если в настройках скрипта включена reCAPTCHA

{recaptcha} Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи

[attachments] текст [/attachments] Выводят текст, заключённый в них, если разрешена отправка файлов в обратной связи для данной группы пользователей.

Также у вас есть возможность использования дополнительных полей в разделе обратной связи на сайте. Для того чтобы добавить дополнительное поле в форму обратной связи, вам необходимо только разместить необходимое поле с определенным именем в форме, после чего оно будет доступно для использования в шаблонах e-mail сообщений. Для добавления дополнительного поля в форму, для поля ввода необходимо использовать атрибут с именем: name="xfield[X]", где X это имя поля, написанное латинскими буквами. Например, вы хотите разместить в форме обратной связи поле для заполнения номера телефона, для этого в шаблоне feedback.tpl размещаете поле:

<input placeholder="Ваш номер телефона" type="text" name="xfield[tel]">

где tel это уникальное имя дополнительного поля, а в шаблоне e-mail сообщений в админпанели размещаете тег: {%tel%}, после чего заполненный пользователем номер телефона будет также присылаться вместе с сообщением. Допускается использование любого количества дополнительных полей.

Вы также можете в обратной связи прикреплённые к письмам файлы. Для этого в настройках групп можете задать для каждой группы пользователей разрешено ли им прикреплять к письмам файлы. Также можете указать сколько максимально файлов они могут приложить к письму, их максимальный суммарный размер, а также какие типы расширений файлов, которые они могут отправлять.

Непосредственно для прикрепления файлов к форме вы можете использовать тег:

<input name="attachments[]" type="file" multiple>

при этом имя тега и количество тегов может быть любым, главное это использование type="file" в атрибуте. DLE сам посчитает все прикреплённые к письму файлы и их соответствие настройкам групп.

Также имеется возможность использования нескольких форм обратной связи на сайте. Для этого используется специально сформированный URL в браузере. Для отправки стандартной формы обратной связи используется адрес http://вашсайт.ru/index.php?do=feedback Для того чтобы добавить ещё одну форму связи вы можете использовать адрес http://вашсайт.ru/index.php?do=feedback&template=X1&mailtemplate=X2, где X1 это имя шаблона для шаблона формы обратной связи, а X2 это имя шаблона письма, которое будет отправляться через эту форму. При этом если задан шаблон X1, то на сервере в папке шаблона у вас должен находится файл с именем feedback_X1.tpl, а если задан шаблон X2, то на сервере в папке шаблона у вас должен находится файл с именем email_X2.tpl. Например, при использовании URL http://вашсайт.ru/index.php?do=feedback&template=test&mailtemplate=test в папке вашего шаблона должен находится файл feedback_test.tpl для формы обратной связи и email_test.tpl для шаблона отправляемого сообщения. Эти файлы поддерживают все те же теги что и стандартная форма обратной связи, и стандартный шаблон e-mail сообщений в админпанели. Тем самым с учётом того что формы обратной связи поддерживают дополнительные поля разного типа, вы можете организовать на своём сайте, несколько различных форм обратной связи.


Восстановление пароля

Навигация: Шаблоны >

Восстановление пароля

Вывод данного раздела настраивается в файле lostpassword.tpl В этом разделе настраиваются шаблоны, которые используются при выводе формы для восстановления пароля на E-Mail. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{code} - Выводит код отображения CAPTCHA

[sec_code] и [/sec_code] Выводит текст если в настройках скрипта включена стандартная CAPTCHA

[recaptcha] и [/recaptcha] Выводит текст если в настройках скрипта включена reCAPTCHA

{recaptcha} Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи


Статические страницы

Навигация: Шаблоны >

Статические страницы

Вывод статических страниц настраивается в файле static.tpl или в файле который вы назначите при создании статической страницы в админпанели скрипта. В данном шаблоне вы можете использовать следующие теги:

{description} выводит описание статической страницы

{static} выводит текст статической страницы

{pages} Выводит навигацию по нескольким страницам одной статической страницы.

{views} Выводит количество просмотров статической страницы.

{custom} Смотрите раздел "Вывод новостей на страницах"

{text limit="x"} выводит только текст добавленных для статической страницы без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов. При этом сокращение текста происходит до последнего логического слова.

{image-x} выводит URL картинки, находящейся в тексте статической страницы, где "x" это номер картинки в тексте страницы, например, {image-1} выведет URL первой картинки в тексте страницы.

[image-x] текст [/image-x] выводят указанный в них текст, только если картинка с номером "x" присутствует в тексте страницы.

[print-link] текст [/print-link] выводить ссылку на версию для печати

{date} выводит дату создания страницы в формате установленном в настройках скрипта

{date=формат даты} выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y, H:i} выведет полную дату и время. Также дополнительно как в тексте статических страниц, так и в их шаблонах вы можете указывать теги из модуля управления рекламой и теги информеров.

[edit] текст [/edit] выводит текст заключённый в них в виде ссылки на редактирование статической страницы, для групп пользователей, которым разрешено редактирование статических страниц.

[static=имя страницы] текст [/static] выводит текст заключенный в теги , если посетитель просматривает статическую страницу с указанным именем.

[not-static=имя страницы] текст [/not-static] выводит текст заключенный в теги, если посетитель не просматривает статическую страницу с указанным именем.

{full-link} выводит URL для данной статической страницы,

{print-link} выводит URL версии для печати для данной страницы.

Также в шаблоне имеется поддержка тегов рекламы и RSS информеров


Персональные сообщения

Навигация: Шаблоны >

Персональные сообщения

Вывод данного раздела настраивается в файле pm.tpl В этом разделе настраиваются шаблоны, которые используются для работы с персональными сообщениями. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

[inbox] и [/inbox] | Ссылка на список сообщений
[new_pm] и [/new_pm] | Ссылка на написание сообщения
[pmlist] и [/pmlist] | Выводится текст в тегах, если просматривается список сообщений
[readpm] и [/readpm] | Выводится текст в тегах, если просматривается переписка
[messages] и [/messages] | Выводит текст заключенный в них при показе сообщений в переписке. Данный тег должен находится внутри тегов [readpm] и [/readpm]
{pmlist} | Выводит список полученных сообщений
[newpm] и [/newpm] | Выводится текст в тегах, если написание сообщения
{pm-limit} | Выводит максимальное количество сообщений, который может хранить пользователь
{proc-pm-limit} | Выводит количество заполненного пространства ящика пользователя в процентах
{pm-progress-bar} | Выводит шкалу наполненности ящика персональных сообщений
{author} | Выводит автора сообщения
{subj} | Тема переписки
{editor} | Выводит редактор для написания сообщения
{text} | Текст сообщения
[pm-edit] и [/pm-edit] | Выводит ссылку для редактирования сообщения
[reply] и [/reply] | Выводит ссылку для цитирования сообщения или выделенного текста
[del] и [/del] | Ссылка на удаление сообщения. Если удаляемое сообщение является первым, то тогда пользователь покидает переписку.
{sec_code} | Код отображения CAPTCHA
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при написании персональных сообщений
{foto} | Выводит ссылку на фотографию
{group-icon} | Выводит иконку группы участника
{group-name} | Выводит имя группы участника
{news-num} | Выводит количество новостей участника
{comm-num} | Выводит количество комментариев участника
{login} | Выводит логин автора персонального сообщения, без какого-либо дополнительного оформления
{date=формат даты} | Выводит дату в заданном в теге формате. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время.
{lastdate=формат даты} | Выводит последнего посещения сайта пользователем в заданном в теге формате. Например тег {lastdate=d} выведет день месяца, а тег {lastdate=F} выведет название месяца, а тег {lastdate=d-m-Y H:i} выведет полную дату и время.
{registration=формат даты} | Выводит дату регистрации пользователя в заданном в теге формате. Например тег {registration=d} выведет день месяца, а тег {registration=F} выведет название месяца, а тег {registration=d-m-Y H:i} выведет полную дату и время.
[signature]{signature}[/signature] | Выводит текст заключенный в теги и подпись пользователя, если пользователь задал подпись в профиле
{date} | Дата публикации комментария, формат вывода даты настраивается в настройках системы
{registration} | Выводит дату регистрации на сайте
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[complaint] текст [/complaint] | Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на персональное сообщение.
[ignore]текст[/ignore] | Выводит ссылки на добавление пользователя в список игнорируемых.
[online] текст [/online] | Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)
[offline] текст [/offline] | Выводят текст если пользователь оффлайн
[xfgiven_x] текст [/xfgiven_x] | Выводится текст, указанный в них, если дополнительное поле пользователя было задано, где X это имя дополнительного поля профиля пользователя
[xfnotgiven_x] текст [/xfnotgiven_x] | Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
[xfvalue_x] | Значение дополнительного поля профия пользователя "x", где "x" название дополнительного поля
[declination=X] текст [/declination] | Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "1 комментарий", "2 комментария", "10 комментариев"
[pm-author] текст [/pm-author] | Выводят текст заключённый в них в случае, если пользователь, просматривающий переписку, является автором этого сообщения
[not-pm-author] текст [/not-pm-author] | Выводят текст, в случае если пользователь не является автором данного сообщения


Облако тегов

Навигация: Шаблоны >

Облако тегов

Вывод данного раздела настраивается в файле tagscloud.tpl В этом разделе настраиваются шаблоны, которые используются для работы с облаком тегов. В данном блоке показываются все ключевые теги добавленные к новостям.

Возможно использование следующих тегов:

{tags} - Используется для вывода всех ключевых тегов, находящихся в базе данных

{tags limit="100"} - Используется для вывода 100 самых популярных ключевых тегов, находящихся в базе данных


Голосование на сайте

Навигация: Шаблоны >

Голосование на сайте

Вывод данного раздела настраивается в файле vote.tpl В этом разделе настраиваются шаблоны, которые используются для работы с голосованием на сайте.

Возможно использование следующих тегов:

{title} - Заголовок опроса

{list} - Список вопросов

{vote_id} - ID опроса

{votes} - Количество голосов

[votelist] и [/votelist] - Выводит текст который нужно показывать для еще не голосовавших людей

[voteresult] и [/voteresult] - Выводит текст который нужно показывать для уже голосовавших людей


Топ новостей

Навигация: Шаблоны >

Топ новостей

Вывод данного раздела настраивается в файле topnews.tpl В этом разделе настраиваются шаблоны, которые используются для вывода блока популярных новостей.

Возможно использование следующих тегов:

{title} - выводит заголовок новости

{title limit="x"} - Выводится урезанный до X количества символов, заголовок новости.

{link} - выводит ссылку на новость

{date} - Выводится дата публикации, формат вывода даты настраивается в настройках системы

{date=формат даты} - Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости

{text} - выводит полностью краткое содержание новости

{text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. При этом обрезание текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым вы получаете возможность более расширенного оформления публикации популярных новостей на сайте.

{category} - выводит категорию, к которой относится статья

{link-category} - выводит ссылку на все категрии в которой присутствует новость

[xfvalue_x] - выводит значение дополнительного поля "x", где "x" название дополнительного поля

[xfgiven_x] [xfvalue_x] [/xfgiven_x] - Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается

[xfnotgiven_X] текст [/xfnotgiven_X] - Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля


Похожие новости

Навигация: Шаблоны >

Похожие новости

Вывод данного раздела настраивается в файле relatednews.tpl В этом разделе настраиваются шаблоны, которые используются для вывода списка похожих новостей при просмотре полной новости на сайте.

Возможно использование следующих тегов:

{title} - выводит заголовок новости

{title limit="x"} - выводит заголовок новости, сокращенный до указанного количества в теге X символов. При этом сокращение заголовка производится до завершения логического слова, а не обрывается посередине.

{link} - выводит ссылку на новость

{date} - Выводится дата публикации, формат вывода даты настраивается в настройках системы

{date=формат даты} - Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости.

{text} - выводит полностью краткое содержание новости

{text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. При этом обрезание текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым вы получаете возможность более расширенного оформления публикации популярных новостей на сайте.

{category} - выводит категорию, к которой относится статья

{link-category} - выводит ссылку на все категрии в которой присутствует новость

[xfvalue_x] - выводит значение дополнительного поля "x", где "x" название дополнительного поля

[xfgiven_x] [xfvalue_x] [/xfgiven_x] - Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается

[xfnotgiven_X] текст [/xfnotgiven_X] - Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля


Временное отключение сайта

Навигация: Шаблоны >

Временное отключение сайта

В данном разделе вы можете настроить страницу, которая будет выводится при отключении сайта например на технические работы. Помните что администраторы всегда будут допущены к просмотру сайта как при включенном режиме. Все остальные будут видеть страницу из данного раздела.

Шаблон настраивается в файле offline.tpl и возможно использование следующих тегов:

{reason} - Используется для вывода причины отключения сайта, которое вы задаете в настройках скрипта


Бан пользователя или запрет доступа к сайту

Навигация: Шаблоны >

Бан пользователя или запрет доступа к сайту

Вывод данного раздела настраивается в файле banned.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод информации о том что для посетителя запрещен доступ к сайту:

{description} | Выводит причину блокировки доступа к сайту для посетителя
{end} | Выводит дату окончания блокировки, если она была установлена
[banned-from] и [/banned-from] | Выводят текст заключенный в них, если блокировка была назначена администратором
{banned-from} | Выводит логин пользователя который выставил блокировку на сайт.


Модуль speedbar

Навигация: Шаблоны >

Модуль speedbar

В данном разделе вы можете настроить вывод текущего местоположения пользователя на вашем сайте. Данный шаблон использует только один тег {speedbar} который и выводит непосредственно местоположение.


RSS трансляция новостей

Навигация: Шаблоны >

RSS трансляция новостей

Данный шаблон находится в файле templates/rss.tpl и предназначен для настройки вывода RSS потока вашего сайта.

В данном шаблоне вы можете использовать следующие теги:

[rss] текст [/rss] - Выводят текст заключенный в них, при использовании блока стандартного RSS.

[dzen] текст [/dzen] - Выводят текст заключенный в них, при использовании блока дзен новостей.

нн

{title} - Выводит заголовок новости

{rsslink} - Выводит полный URL новости

{rssauthor} - Выводят автора новости

{rssdate} - Выводят дату новости

{category} - Выводят категорию новости

{short-story} - Выводят текст краткой новости

{images} - Выводит набор картинок для Яндекс новостей

{full-story} - Выводит текст полной новости

Также вы можете использовать дополнительно любые теги которые поддерживаются шаблоном вывода краткиких новостей shortstory.tpl, однако вам необходимо быть внимательными чтобы не был нарушен стандарт вывода RSS 2.0 который используется для RSS трансляции публикаций.


RSS информер

Навигация: Шаблоны >

RSS информер

В данном шаблоне вы можете настроить вывод вашего RSS информера. Имя данного шаблона вы назначаете самостоятельно в админпанели при добавлении нового RSS информера. В данном шаблоне вы можете использовать следующие теги:

[link] текст [/link] - формирует ссылку на новость партнера

{link} - предназначен для вывода только URL ссылки на страницу источника публикации

{title} - заголовок новости

{news} - непосредственно сама новость

{category} - выводит категорию в которой опубликована новости в RSS потоке

{author} - выводит автора новости

{date} - выводит дату новости, при этом формат даты можно задать в настройках информера, для каждого информера.

{date=формат даты} - выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату, принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время.

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости


Разработка и подключение модулей

Навигация: Разработчикам >

Разработка и подключение модулей

DataLife Engine предоставляет удобные механизмы для подключения разработанных вами модификаций скрипта. Данные механизмы позволяют обеспечить работоспособность и после обновления скрипта на новую версию, т.к. данные механизмы позволяют осуществлять подключение без правки файлов скрипта. Для подключения разработанных вами модулей вам необходимо в любом необходимом вам шаблоне добавить тег:

{include file="engine/modules/mymod.php"}

Где engine/modules/ это путь к файлу вашего модуля, а mymod.php имя подключаемого файла. Стандартные файлы модулей DataLife Engine находятся в этой папке и мы вам рекомендуем использовать данную папку, однако это не является обязательным требованием и файл может находится в любой другой папке на сервере. Единственное ограничение безопасности по подобному подключению модулей, это то что на папку в которой находится файл не должно быть прав на запись (CHMOD 777). Также мы рекомендуем вам использовать именно относительные пути при подключении модулей, DataLfe Engine автоматически распознает относительные пути и подключает ваши модули уже согласно настройкам скрипта и путям где установлен скрипт. Тем самым вы можете создавать универсальные инструкции по установке ваших модификаций.

Также вы можете подключать PHP файлы вашего модуля передав им различные параметры, например:

{include file="engine/modules/mymod.php?param=value1&variable2=value2"}

Благодаря подобному подключению, вы можете делать ваши модификации многофункциональными, которые будут выполнять различные роли и функции при различных подключениях. Переданные переменные будут доступны в вашем модуле как $param и $variable2 соответственно.

В качестве параметров к подключаемым модулям вы можете задавать шаблонные теги скрипта (за исключением использования тега в шаблоне main.tpl и тегов принадлежащих шаблону main.tpl). Например, при добавлении в шаблон полной новости конструкции {include file="engine/modules/mymod.php?param={news-id}"}, вы можете передавать вашему стороннему модулю в качестве параметра ID новости и т.д. Вниманию разработчиков: Передаваемые в скрипт параметры, это аналоги GET параметров URL браузера, соответственно при выборе передаваемых тегов вы должны учитывать ограничения GET строки, другими словами вы не можете передать в качестве параметра содержимое полной новости к примеру.

Также вы можете использовать подключение своих модулей и для замены основного блока, где выводятся новости и другая основная информация, для этого необходимо использовать данный тег совместно с тегами [aviable=раздел]текст[/aviable] и [not-aviable=раздел]текст[/not-aviable] Описание тегов смотрите в документации в разделе "Вывод новостей на страницах". Вы можете использовать как стандартный список разделов, так и использовать создание собственного раздела сайта, передав его в URL браузера. Рассмотрим простейший пример. Вы хотите добавить к стандартным разделам сайта, добавить свой раздел и выводить информацию в нем из вашего модуля. Допустим вы хотите создать раздел FAQ. Для этого в шаблоне main.tpl прописывается конструкция:

[aviable=faq]{include file="engine/modules/mymod.php"}[/aviable]

[not-aviable=faq]{content}[/not-aviable]

После подобного подключения помимо работы стандартных разделов сайта при обращении по адресу: http://site.ru/index.php?do=faq вместо новостей будет выводится ваш новый раздел из вашего модуля.

Для работы ваших модулей и вывода информации именно в том месте шаблона, где вставлен вышеуказанный тег, обязательно только одно важное условие. Вывод информации должен осуществляется только через функцию PHP echo. Рассмотрим пример простейшего модуля и вывода информации. Создадим файл mymod.php со следующим содержимым:

<?php

echo "Тестовый модуль";

?>

При подключении этого файла в шаблоне, в данном месте шаблона появится текст: Тестовый модуль

Список переменных и классов DLE которые вы можете использовать в вашем подключаемом модуле, без дополнительного объявления:

$is_logged - содержит информацию, является ли посетитель авторизованным пользователем или гостем, и содержит значения true или false.

$member_id - содержит массив с информацией о авторизованном пользователе, включая всю его информацию из профиля.

$db - класс DLE для работы с базой данных.

$tpl - класс DLE для работы с шаблонами.

$cat_info - массив содержащий информацию обо всех категориях на сайте.

$config - массив содержащий информацию обо всех настройках скрипта.

$user_group - массив содержащий информацию о всех группах пользователей и их настройках.

$category_id - содержит ID категории которую просматривает посетитель.

$_TIME - содержит текущее время в UNIX формате с учетом настроек смещения в настройках скрипта.

$lang - массив содержащий текст из языкового пакета.

$smartphone_detected - содержит информацию о том, просматривает ли пользователь сайт со смартфона или с обычного браузера, и содержит значения true или false.

$dle_module - содержит информацию о разделе сайта, который просматривает пользователь, либо информацию переменной do из URL браузера.

Внимание: Ваш модуль должен только читать данные из данных переменных, внесение изменений в значения переменных повлечет сбои в работе стандартных возможностей скрипта и дальнейшей его некорректной работе.


Подключение модулей в адмипанели

Навигация: Разработчикам >

Подключение модулей в адмипанели

DataLife Engine предоставляет удобные механизмы для подключения разработанных вами модификаций скрипта в админпанели. Данные механизмы позволяют подключать модули админпанели без внесения изменений в файлы скрипта и позволяют сохранять работоспособность после обновления скрипта на новую версию скрипта.

Для того чтобы подключить ваш сторонний модуль в админпанель, вы должны разместить файл вашего модуля в папке engine/inc/ это обязательное условие. Только файлы находящиеся в этой папке могут быть подключены. Например имя файла вашего модуля mymod.php вы разместили его в папке engine/inc/ После этого вы можете вызвать и обратится к вашему модулю из админпанели по адресу: http://site.ru/admin.php?mod=mymod где mymod это имя вашего модуля без расширения .php Подключение происходит автоматически, никаких изменений в файлах скрипта не требуется.

Для того чтобы пользователи не вводили адрес вашего модуля в браузере вручную и он отображался в списке всех разделов в административной панели, для этого предусмотрена специальная таблица в базе данных MySQL. Имя таблицы: ПРЕФИКС_admin_sections. ПРЕФИКС ваш скрипт установки может прочитать из файла engine/data/dbconfig.php. Данная таблица содержит следующие имена полей:

name - содержит имя вашего модуля, а именно файла .php находящегося в папке engine/inc/, но без расширения файла. Например имя вашего файла mymod.php, то в данное поле должно быть записано значение mymod.

title - содержит заголовок вашего модуля.

descr - содержит описание вашего модуля.

icon - содержит имя иконки для вашего модуля, с указанием пути. Например, engine/skins/images/myicon.png. Рекомендуемые размеры иконок 70 на 70 пикселей.

allow_groups - содержит информацию о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанел.

Пример запроса для записи информации о модуле mymod:

INSERT INTO `префикс_admin_sections` (`name`, `title`, `descr`, `icon`, `allow_groups`) VALUES

('mymod', 'Тестовый модуль', 'Здесь находится описание тестового модуля', 'mymod.png', '1');

после выполнения данного запроса модуль в админпанели будет прописан в админпанели только для администраторов.

ВНИМАНИЕ: указание о группах в базе данных не запрещает и не предотвращяет запуск модуля пользователями из других групп. Для разграничения доступа ваши подключаемые модули обязаны сами производить проверку групп и разрешать выполнение только разрешенным группам.


API для разработки модулей

Навигация: Разработчикам >

API для разработки модулей

API предназначен для написания модификаций совместимых со старыми и будущими версиями скрипта. В случае использования API для получения данных из базы, вы можете быть уверенными, что данный код будет работать и в будущих версиях скрипта, тем самым облегчается проверка и адаптация кода при выходе новой версии. Также при использовании API вам нет необходимости писать собственные функции для выборки данных, нет необходимости подключать и объявлять необходимые для работы с БД классы. Достаточно просто подключить файл API, и начать использовать его функции, все остальное он берет на себя.

Для использования API в своем модуле вы должны его подключить строчкой:

include ('engine/api/api.class.php');

При этом вам нет необходимости задумываться есть ли подключение к БД или нет, подключены или нет необходимые классы. Данный код вы можете использовать как внутри файлов самого скрипта DLE, так и просто в других скриптах, не имеющих отношения к DLE. Тем самым вы можете организовывать стандартизированные интеграции скрипта DLE, с другими скриптами. Например форумами.

Список функций API:

$dle_api->take_user_by_id( int $id [, string $select_list] );

получение массива с информацией о пользователе по его ID. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией о пользователе либо false, если пользователь не найден.

$dle_api->take_user_by_name( string $name [, string $select_list]);

получение массива с информацией о пользователе по его логину. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией либо false, если пользователь не найден.

$dle_api->take_user_by_email( string $email [, string $select_list]);

получение массива с информацией о пользователе по его E-Mail. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией либо false, если пользователь не найден.

$dle_api->take_users_by_group( int $group_id [, string $select_list [, int $limit]]);

получение массива с информацией о пользователях по номеру группы. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить. Необязательный параметр $limit указывает на лимит количества возращаемых пользователей. Возвращает массив с информацией либо false, если пользователи не найдены.

$dle_api->take_users_by_ip( string $ip, [, bool $like [, string $select_list [, int $limit]]]);

Получение списка пользователей по IP, второй параметр $like указывает использовать точное совпадение при поиске, либо неточное. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить. Необязательный параметр $limit указывает на лимит количества возращаемых пользователей. Возвращает массив с информацией либо false, если пользователи не найдены.

$dle_api->change_user_name( int $user_id, string $new_name);

Изменение логина пользователя. user_id ID пользователя, логин которого необходимо заменить. new_name новый логин пользователя. Возвращаемые значения: true если успешно выполнено, false если новое имя уже занято другим пользователем.

$dle_api->change_user_pass( int $user_id, string $new_pass);

Изменение пароля пользователя. user_id ID пользователя, пароль которого необходимо заменить. new_pass новый пароль пользователя.

$dle_api->change_user_email( int $user_id, string $new_email);

Изменение E-Mail пользователя. user_id ID пользователя, E-Mail которого необходимо заменить. new_email новый E-Mail пользователя. Возвращаемые значения: 1 - успешно выполнено, -1 - новый E-Mail уже существует, -2 - некорректный E-mail.

$dle_api->change_user_group( int $user_id, int $new_group);

Изменение группы пользователя. user_id ID пользователя, группу которого необходимо заменить. new_group ID новой группы пользователя. Возвращаемые значения: true если успешно выполнено, false если указан ID несуществующей группы.

$dle_api->external_auth( string $login, string $password);

Авторизация по логину и паролю. Возвращаемые значения: true - авторизация успешна, false - логин или пароль не верны.

$dle_api->external_register( string $login, string $password, string $email, int $group);

Регистрация пользователя в базе данных. В функцию передаются: Логин, Пароль, E-mail и номер группы в которой зарегистрировать пользователя. Возвращаемые значения: 1 - успешно выполнено, -1 - новый логин уже существует, -2 - новый E-Mail уже существует, -3 - некорректный E-Mail, -4 - задана несуществующая группа.

$dle_api->send_pm_to_user ( int $user_id, string $subject, string $text, string $from);

Отправка персонального сообщения пользователю. $user_id ID получателя. $subject тема сообщения. $text текст сообщения. $from логин отправителя. Возвращаемые значения: 1 - успешно выполнено, -1 - получатель не найден, 0 - ошибка БД.

$dle_api->load_table ( string $table [, string $fields [, string $where [, bool $multirow [, int $start [, int $limit [, string $sort [, string $sort_order]]]]]]]);

Получение информации из таблицы БД.

$table - название таблицы

$fields - необходимые поля через запятую или * для всех

$where - условие выборки

$multirow - забирать ли один ряд или несколько

$start - начальное значение выборки

$limit - количество записей для выборки, 0 - выбрать все

$sort - поле, по которому осуществляется сортировка

$sort_order - направление сортировки

Возвращается массив с данными, либо false если в БД по указанным параметрам ничего не найдено.

$dle_api->save_to_cache ( string $fname, mixed $vars);

Запись данных в файл кеша. Параметр $fname указывает имя файла кеша без указания его расширения. $vars - данные для записи в кеш.

$dle_api->load_from_cache ( string $fname, [, int $timeout [, string $type]]);

Чтение данных из файла кеша. Параметр $fname указывает имя файла кеша без указания его расширения. Необязательный параметр $timeout указывает количество секунд, в течении которых информацию из кеша считать актуальной. Если файл кеша будет устаревшим, то функция возвращает false. Необязательный параметр $type указывает на тип данных который хранится в кеше, если не 'text' - считаем, что хранился массив и возвращается массив данных.

$dle_api->clean_cache ( [string $name] );

Удаление кеша. Необязательный параметр $name указывает на конкретное имя файла без расширения который нужно удалить

$dle_api->get_cached_files();

Получение массива содержащего названия файлов кеша.

$dle_api->edit_config ( mixed $key, [, string $new_value]);

Изменение и сохранение настроек скрипта.

Параметр $key string или array

string: Название параметра

array: ассоциативный массив параметров

Параметр $new_value - значение параметра. Не используется, если $key массив

$dle_api->take_news ( string $cat, [, string $fields [, int $start [, int $limit [, string $sort [, string $sort_order]]]]]);

Получение новостей

$cat - категории новостей, через запятую

$fields - перечень получаемых полей новостей или * для всех

$start - начальное значение выборки

$limit - количество новостей для выборки, 0 - выбрать все новости

$sort - поле, по которому осуществляется сортировка

$sort_order - направление сортировки

Возвращает ассоциативный 2-х мерный массив с новостями

$dle_api->checkGroup ( int $group );

Проверяет существует ли указанная группа или нет. Возвращаемые значения: true если группа существует, false если группа не существует.

$dle_api->install_admin_module ( string $name, string $title, string $descr, string $icon [, string $perm] );

Установка стороннего модуля в админпанель скрипта.

$name - название модуля, а именно файла .php находящегося в папке engine/inc/, но без расширения файла

$title - заголовок модуля

$descr - описание модуля

$icon - имя иконки для модуля, без указания пути. Иконка обязательно при этом должна находится в папке engine/skins/images/

$perm - информация о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанель

$dle_api->uninstall_admin_module ( string $name );

Удаление стороннего модуля из админпанели скрипта.

$name - название удаляемого модуля

$dle_api->change_admin_module_perms ( string $name, string $perm );

Изменение группы пользователей которым разрешен показ стороннего модуля в админпанели скрипта.

$name - название модуля

$perm - информация о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанель

Разработка полноценного API, только начата и на данный момент API имеет пока ограниченный набор функций. Поэтому мы просим всех заинтересованных в данном API разработчиков посетить специально созданную для этого тему на форуме и оставить свои пожелания о том какие новые функции вы хотите видеть в новых версиях. Потому что только опираясь на ваши потребности можно создать полноценный API, охватывающий все аспекты взаимодействия с скриптом.


Запуск функций по крону

Навигация: »Основной раздел«

Запуск функций по крону

В DataLife Engine присутствует возможность запускать некоторые функции по расписанию. Вы можете создавать автоматически бекап БД, оптимизировать БД, а также создавать карту сайта для поисковиков. Для этого необходима поддержка вашим хостингом функции запуска приложений по расписанию (CRON). Для запуска функций по крону предназначен файл cron.php расположенный в корне вашего сайта. По умолчанию в целях безопасности возможность запуска этого файла отключена, поэтому рассмотрим как можно включить данную функцию.

Во первых мы рекомендуем обязательно в целях безопасности изменить название файла cron.php на любое другое с расширением .php

Далее откройте этот файл в текстовом редакторе и в самом начале найдите строчку

$allow_cron = 0;

Измените ее на

$allow_cron = 1;

Тем самым вы разрешаете этому файлу выполнять функции в автоматическом режиме.

Далее вы можете изменить количество файлов резервных копий БД которые будут хранится на сервере. Для этого найдите чуть ниже строчку

$max_count_files = 5;

где 5 это количество копий БД. Вы можете поставить свое собственное количество файлов. При превышении данного лимита более старые резервные копии базы данных будут автоматически удалятся.

После того как вы произвели необходимые изменения, сохраните данный файл на сервере. Теперь вам нужно добавить данный файл на запуск по расписанию (CRON) время создания и периодичность вы устанавливаете самостоятельно. Подробную инструкцию по добавлению данного файла в функцию CRON вы можете получить у вашего хостинг провайдера.

Файл крона может выполнять следующие операции:

1. Создание резервной копии базы данный. Для запуска данного режима

просто запустите файл cron.php без указания ему параметров

2. Создание карты сайты сайта. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=sitemap

если используется консольный запуск скрипта, то используйте php -f cron.php sitemap

При создании карты сайта по крону, также будет выполняться автоматическое уведомление поисковых систем о наличии карты сайта.

3. Оптимизация базы данных. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=optimize

если используется консольный запуск скрипта, то используйте php -f cron.php optimize

4. Запуск антивируса. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=antivirus

если используется консольный запуск скрипта, то используйте php -f cron.php antivirus

При этом конечно не следует забывать про указание правильных путей как к PHP интерпретатору, так и к самому скрипту от корня вашего сервера.


RSS Экспорт

Навигация: »Основной раздел«

RSS Экспорт

Движок DataLife Engine поддерживает также экспорт новостей в формате RSS для того чтобы посетители получили экспорт новостей с главной страницы вы должны использовать следующий путь.

С использованием ЧПУ:

http://website.com/rss.xml - трансляция основного потока RSS

http://website.com/rssdzen.xml - трансляция потока RSS для сервиса Дзен

Без использования ЧПУ:

http://website.com/index.php?mod=rss - трансляция основного потока RSS

http://website.com/index.php?mod=rss&rssmode=dzen - трансляция потока RSS для сервиса Дзен

Для экспорта новостей из определенной категории используйте следующие ссылки

С использованием ЧПУ:

http://website.com/альтернативное имя категории/rss.xml - трансляция основного потока RSS

http://website.com/альтернативное имя категории/rssdzen.xml - трансляция потока RSS для сервиса Дзен

Без использования ЧПУ:

http://website.com/index.php?mod=rss&do=cat&category=альтернативное имя - трансляция основного потока RSS

http://website.com/index.php?mod=rss&do=cat&rssmode=dzen&category=альтернативное имя - трансляция потока RSS для сервиса Дзен

Для экспорта всех новостей определенного пользователя используйте следующие ссылки

С использованием ЧПУ:

http://website.com/user/имя пользователя/rss.xml - трансляция основного потока RSS

http://website.com/user/имя пользователя/rssdzen.xml - трансляция потока RSS для сервиса Дзен

Без использования ЧПУ:

http://website.com/index.php?mod=rss&subaction=allnews&user=имя пользователя - трансляция основного потока RSS

http://website.com/index.php?mod=rss&subaction=allnews&rssmode=dzen&user=имя пользователя - трансляция потока RSS для сервиса Дзен

Для экспорта новостей из определенного каталога используйте следующие ссылки

С использованием ЧПУ:

http://website.com/catalog/идентификатор/rss.xml - трансляция основного потока RSS

http://website.com/catalog/идентификатор/rssdzen.xml - трансляция потока RSS для сервиса Дзен

Без использования ЧПУ:

http://website.com/index.php?mod=rss&catalog=идентификатор - трансляция основного потока RSS

http://website.com/index.php?mod=rss&rssmode=dzen&catalog=идентификатор - трансляция потока RSS для сервиса Дзен